aboutsummaryrefslogtreecommitdiff
path: root/emulators/gxemul
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2014-02-25 20:32:40 +0000
committerWarner Losh <imp@FreeBSD.org>2014-02-25 20:32:40 +0000
commit917e0f32388fdb122c48e0a3ddc3046b3127a15b (patch)
treeb12e6d12d5b094ef546229da25332b080263c972 /emulators/gxemul
parent8e9a2ad5ef1cff3cbe135f1abc5ffc54e719b124 (diff)
downloadports-917e0f32388fdb122c48e0a3ddc3046b3127a15b.tar.gz
ports-917e0f32388fdb122c48e0a3ddc3046b3127a15b.zip
Force gcc, since gxemul isn't clang ready yet.
Fix for building with gcc 4.6 due to slight differences in namespace pollution.
Notes
Notes: svn path=/head/; revision=346073
Diffstat (limited to 'emulators/gxemul')
-rw-r--r--emulators/gxemul/Makefile2
-rw-r--r--emulators/gxemul/files/patch-ab11
2 files changed, 13 insertions, 0 deletions
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 751f65daf186..09883bdfe906 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -22,6 +22,8 @@ MAN1= gxemul.1
PORTDOCS= *
PLIST_FILES= bin/gxemul
+USE_GCC= yes
+
# svgalib installs vga.h, which conflicts with gxemul when building with
# a virtual VGA adaptor.
CONFLICTS= svgalib-[0-9]*
diff --git a/emulators/gxemul/files/patch-ab b/emulators/gxemul/files/patch-ab
new file mode 100644
index 000000000000..aa155710ce96
--- /dev/null
+++ b/emulators/gxemul/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/include/refcount_ptr.h 2010-02-14 02:33:54.000000000 -0700
++++ src/include/refcount_ptr.h 2014-02-24 03:48:14.000000000 -0700
+@@ -28,6 +28,8 @@
+ * SUCH DAMAGE.
+ */
+
++#include <stddef.h>
++
+ /**
+ * \brief Base class for reference countable objects.
+ *