aboutsummaryrefslogtreecommitdiff
path: root/emulators/hatari
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-07-15 14:43:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-07-15 14:43:30 +0000
commitc00323f194b84db8c77fa33d09457483583bdf24 (patch)
tree57c9fc7c8539371b2596fca34ffa9f5fe4a4bfea /emulators/hatari
parentc99bd8e43a3b5a5215ec5b517e3bd8b7d2db6ce6 (diff)
downloadports-c00323f194b84db8c77fa33d09457483583bdf24.tar.gz
ports-c00323f194b84db8c77fa33d09457483583bdf24.zip
- Update to 1.7.0
PR: 180502 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=323036
Diffstat (limited to 'emulators/hatari')
-rw-r--r--emulators/hatari/Makefile22
-rw-r--r--emulators/hatari/distinfo4
-rw-r--r--emulators/hatari/pkg-plist4
3 files changed, 18 insertions, 12 deletions
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index 12e999315f5d..4dacf5e92a93 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hatari
-PORTVERSION= 1.6.2
+PORTVERSION= 1.7.0
CATEGORIES= emulators
MASTER_SITES= http://download.tuxfamily.org/hatari/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -19,9 +19,9 @@ RUN_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
OPTIONS_DEFINE= DOCS
USE_BZIP2= yes
+USES= cmake readline
USE_GNOME= pygtk2
USE_SDL= sdl
-USES= cmake readline
CMAKE_ARGS= -DPORTAUDIO_INCLUDE_DIR:STRING="${PA2_INCLUDE_DIR}" \
-DPORTAUDIO_LIBRARY:STRING="${PA2_LIBRARY}" \
-DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
@@ -32,7 +32,8 @@ MAKE_JOBS_SAFE= yes
MANCOMPRESSED= yes
MANLANG= "" fr
MAN1= ${PORTNAME}.1
-MAN1_EN= atari-hd-image.1 hatariui.1 hconsole.1 hmsa.1 zip2st.1
+MAN1_EN= atari-hd-image.1 gst2ascii.1 hatari_profile.1 hatariui.1 \
+ hconsole.1 hmsa.1 zip2st.1
CFLAGS+= -I${LOCALBASE}/include/portaudio2
PA2_INCLUDE_DIR=-I${LOCALBASE}/include/portaudio2
@@ -56,18 +57,19 @@ post-build:
@cd ${WRKSRC}/doc/fr && ${GZIP_CMD} -c ${PORTNAME}.1 > ${PORTNAME}.1.gz
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1.gz ${MANPREFIX}/man/man1
+ (cd ${WRKSRC}/doc && ${INSTALL_MAN} ${PORTNAME}.1.gz \
+ ${MANPREFIX}/man/man1)
@${MKDIR} ${MANPREFIX}/man/fr/man1
- ${INSTALL_MAN} ${WRKSRC}/doc/fr/${PORTNAME}.1.gz ${MANPREFIX}/man/fr/man1
+ (cd ${WRKSRC}/doc/fr && ${INSTALL_MAN} ${PORTNAME}.1.gz \
+ ${MANPREFIX}/man/fr/man1)
.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/[a-z]*.txt ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} readme.txt ${DOCSDIR})
+ (cd ${WRKSRC}/doc && ${INSTALL_DATA} *.html [a-z]*.txt ${DOCSDIR})
@${MKDIR} ${DOCSDIR}/fr
- ${INSTALL_DATA} ${WRKSRC}/doc/fr/*.txt ${DOCSDIR}/fr
+ (cd ${WRKSRC}/doc/fr && ${INSTALL_DATA} *.txt ${DOCSDIR}/fr)
@${MKDIR} ${DOCSDIR}/images
- ${INSTALL_DATA} ${WRKSRC}/doc/images/*.png ${DOCSDIR}/images
+ (cd ${WRKSRC}/doc/images && ${INSTALL_DATA} *.png ${DOCSDIR}/images)
.endif
.include <bsd.port.mk>
diff --git a/emulators/hatari/distinfo b/emulators/hatari/distinfo
index b1cfa96409d2..cdee98237314 100644
--- a/emulators/hatari/distinfo
+++ b/emulators/hatari/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hatari-1.6.2.tar.bz2) = 20de0430eb8950d206e9df4d8088fa759625e23390e7604484e351d030761b3f
-SIZE (hatari-1.6.2.tar.bz2) = 1739570
+SHA256 (hatari-1.7.0.tar.bz2) = 2056d12807cb827585f337912238492f8b66b7ff3d9d0628090e58209a519e4d
+SIZE (hatari-1.7.0.tar.bz2) = 2254241
diff --git a/emulators/hatari/pkg-plist b/emulators/hatari/pkg-plist
index 5903dd0e3f52..499877ce02a1 100644
--- a/emulators/hatari/pkg-plist
+++ b/emulators/hatari/pkg-plist
@@ -1,5 +1,7 @@
bin/atari-hd-image
+bin/gst2ascii
bin/hatari
+bin/hatari_profile.py
bin/hatariui
bin/hmsa
bin/zip2st
@@ -10,11 +12,13 @@ share/applications/hatariui.desktop
%%PORTDOCS%%%%DOCSDIR%%/compatibility.html
%%PORTDOCS%%%%DOCSDIR%%/emutos.txt
%%PORTDOCS%%%%DOCSDIR%%/fr/clavier-exemple.txt
+%%PORTDOCS%%%%DOCSDIR%%/images/callgraph.png
%%PORTDOCS%%%%DOCSDIR%%/images/devices.png
%%PORTDOCS%%%%DOCSDIR%%/images/fileselector.png
%%PORTDOCS%%%%DOCSDIR%%/images/floppydisks.png
%%PORTDOCS%%%%DOCSDIR%%/images/harddisks.png
%%PORTDOCS%%%%DOCSDIR%%/images/joystick.png
+%%PORTDOCS%%%%DOCSDIR%%/images/kcachegrind.png
%%PORTDOCS%%%%DOCSDIR%%/images/keyboard.png
%%PORTDOCS%%%%DOCSDIR%%/images/main.png
%%PORTDOCS%%%%DOCSDIR%%/images/memory.png