aboutsummaryrefslogtreecommitdiff
path: root/emulators/hatari
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-27 10:29:27 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-27 10:29:27 +0000
commite2ec0678b3838ba604cdbebdb332a01bf1158912 (patch)
tree459afb249f9dd6d238c3598c55117ad012de82ec /emulators/hatari
parentd59c801078f2ef85bbc2de9af79462441d424ba3 (diff)
downloadports-e2ec0678b3838ba604cdbebdb332a01bf1158912.tar.gz
ports-e2ec0678b3838ba604cdbebdb332a01bf1158912.zip
- Update to version 1.4.0
PR: 155823 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=271865
Diffstat (limited to 'emulators/hatari')
-rw-r--r--emulators/hatari/Makefile38
-rw-r--r--emulators/hatari/distinfo5
-rw-r--r--emulators/hatari/files/patch-Makefile45
-rw-r--r--emulators/hatari/files/patch-Makefile.cnf.in22
-rw-r--r--emulators/hatari/files/patch-tools_hmsa_Makefile13
-rw-r--r--emulators/hatari/pkg-plist6
6 files changed, 31 insertions, 98 deletions
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index 9b6471f6a95e..818436cef41f 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -6,42 +6,54 @@
#
PORTNAME= hatari
-PORTVERSION= 1.3.1
-PORTREVISION= 1
+PORTVERSION= 1.4.0
CATEGORIES= emulators
MASTER_SITES= BERLIOS
MAINTAINER= ports@FreeBSD.org
COMMENT= An Atari ST emulator
+BUILD_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+RUN_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
USE_BZIP2= yes
+USE_GNOME= pygtk2
USE_SDL= sdl
-USE_GMAKE= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_CMAKE= yes
+CMAKE_ARGS= -DPORTAUDIO_INCLUDE_DIR:STRING="${PA2_INCLUDE_DIR}" \
+ -DPORTAUDIO_LIBRARY:STRING="${PA2_LIBRARY}" \
+ -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG"
+MANCOMPRESSED= yes
MANLANG= "" fr
MAN1= ${PORTNAME}.1
+MAN1_EN= ${PORTNAME}ui.1
-CPPFLAGS= `libpng-config --I_opts`
-LDFLAGS= `libpng-config --L_opts`
+CFLAGS+= -I${LOCALBASE}/include/portaudio2
+PA2_INCLUDE_DIR=-I${LOCALBASE}/include/portaudio2
+PA2_LIBRARY= ${LOCALBASE}/lib/portaudio2/libportaudio.so
+
+post-extract:
+ @cd ${WRKSRC}/doc && ${GZIP_CMD} -c ${PORTNAME}.1 > ${PORTNAME}.1.gz
+ @cd ${WRKSRC}/doc/fr && ${GZIP_CMD} -c ${PORTNAME}.1 > ${PORTNAME}.1.gz
post-patch:
- @${REINPLACE_CMD} -e '/if test/s|==|=|g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/^ICONPATH/s|/icons/.*$$|/pixmaps|' \
- ${WRKSRC}/python-ui/Makefile
+ @${REINPLACE_CMD} -e '/CONFDIR/s|"/etc|"${PREFIX}/etc| ; \
+ /MANDIR/s|share/man|man| ; \
+ /doc/s|^add_|#add_|' ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e '/DESTINATION/s|/icons/.*)|/pixmaps)|' \
+ ${WRKSRC}/python-ui/CMakeLists.txt
post-install:
- ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1.gz ${MANPREFIX}/man/man1
@${MKDIR} ${MANPREFIX}/man/fr/man1
- ${INSTALL_MAN} ${WRKSRC}/doc/fr/${PORTNAME}.1 ${MANPREFIX}/man/fr/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/fr/${PORTNAME}.1.gz ${MANPREFIX}/man/fr/man1
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/[a-z]*.txt ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/fr
${INSTALL_DATA} ${WRKSRC}/doc/fr/*.txt ${DOCSDIR}/fr
@${MKDIR} ${DOCSDIR}/images
diff --git a/emulators/hatari/distinfo b/emulators/hatari/distinfo
index adc7f3f3cac0..87f0a400f588 100644
--- a/emulators/hatari/distinfo
+++ b/emulators/hatari/distinfo
@@ -1,3 +1,2 @@
-MD5 (hatari-1.3.1.tar.bz2) = 112b544ec4affb7c04e931088e62a115
-SHA256 (hatari-1.3.1.tar.bz2) = ebae927ad99a029f8cd8796463df2113357a7636c2199e00290ad4a35856e0da
-SIZE (hatari-1.3.1.tar.bz2) = 1045627
+SHA256 (hatari-1.4.0.tar.bz2) = 690e21bd2210a7e86af5d76ccc7f4e608aae37df466d2ead2ac4d105a637bc7b
+SIZE (hatari-1.4.0.tar.bz2) = 1260844
diff --git a/emulators/hatari/files/patch-Makefile b/emulators/hatari/files/patch-Makefile
deleted file mode 100644
index 016828ab0ce7..000000000000
--- a/emulators/hatari/files/patch-Makefile
+++ /dev/null
@@ -1,45 +0,0 @@
---- Makefile.orig 2009-01-24 12:12:44.000000000 -0200
-+++ Makefile 2009-11-06 21:26:15.000000000 -0200
-@@ -31,9 +31,6 @@
- cp -v config-default.h config.h; \
- fi
-
--hatari.1.gz: doc/hatari.1
-- gzip -9 -c doc/hatari.1 > $@
--
-
- clean:
- $(MAKE) -C src/ clean
-@@ -43,14 +40,12 @@
- $(MAKE) -C src/ distclean
- $(MAKE) -C tools/hmsa/ distclean
- $(RM) config.cache config.log Makefile.cnf config.h
-- $(RM) hatari.1.gz
--
-
- # Use "make depend" to generate file dependencies:
- depend:
- $(MAKE) -C src/ depend
-
--install: all hatari.1.gz
-+install: all
- @if [ "x$(INSTALL)" = "x" ]; then \
- echo; \
- echo "*** Hatari was not configured for installation. ***"; \
-@@ -58,9 +53,6 @@
- fi
- $(INSTALL) -d $(DESTDIR)$(BINDIR)
- $(INSTALL) -d $(DESTDIR)$(DATADIR)
-- $(INSTALL) -d $(DESTDIR)$(MANDIR)
-- $(INSTALL) -d $(DESTDIR)$(DOCDIR)
-- $(INSTALL) -d $(DESTDIR)$(DOCDIR)/images
- $(INSTALL_PROGRAM) src/hatari $(DESTDIR)$(BINDIR)/hatari
- $(INSTALL_PROGRAM) tools/hmsa/hmsa $(DESTDIR)$(BINDIR)/hmsa
- $(INSTALL_SCRIPT) tools/zip2st.sh $(DESTDIR)$(BINDIR)/zip2st
-@@ -68,6 +60,3 @@
- if test -f src/tos.img -a \! -f $(DESTDIR)$(DATADIR)/tos.img ; then \
- $(INSTALL_DATA) src/tos.img $(DESTDIR)$(DATADIR)/tos.img ; \
- fi
-- $(INSTALL_DATA) hatari.1.gz $(DESTDIR)$(MANDIR)/
-- $(INSTALL_DATA) doc/*.txt doc/*.html $(DESTDIR)$(DOCDIR)/
-- $(INSTALL_DATA) doc/images/*.png $(DESTDIR)$(DOCDIR)/images/
diff --git a/emulators/hatari/files/patch-Makefile.cnf.in b/emulators/hatari/files/patch-Makefile.cnf.in
deleted file mode 100644
index 509502586a18..000000000000
--- a/emulators/hatari/files/patch-Makefile.cnf.in
+++ /dev/null
@@ -1,22 +0,0 @@
-# This patch prevents shadowing of hatari's header
-# files by files in directories mentioned in X_CFLAGS.
---- Makefile.cnf.in Sun Nov 22 01:43:31 2009 +0100
-+++ Makefile.cnf.in Sun Nov 22 01:58:24 2009 +0100
-@@ -5,7 +5,7 @@
- CC = @CC@
-
- # Set flags passed to the compiler (e.g. optimization flags)
--CFLAGS = @CFLAGS@ @X_CFLAGS@
-+CFLAGS = @CFLAGS@
-
- # Set flags passed to the preprocessor (e.g. -I<include dir>)
- CPPFLAGS = @CPPFLAGS@
-@@ -30,7 +30,7 @@
-
-
- # SDL-Library configuration (compiler flags and linker options)
--SDL_CFLAGS = @SDL_CFLAGS@
-+SDL_CFLAGS = @X_CFLAGS@ @SDL_CFLAGS@
- SDL_LIBS = @SDL_LIBS@
-
-
diff --git a/emulators/hatari/files/patch-tools_hmsa_Makefile b/emulators/hatari/files/patch-tools_hmsa_Makefile
deleted file mode 100644
index f26982f5369a..000000000000
--- a/emulators/hatari/files/patch-tools_hmsa_Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-# This patch prevents shadowing of hatari's header
-# files by files in directories mentioned in X_CFLAGS.
---- tools/hmsa/Makefile Sun Nov 22 01:43:31 2009 +0100
-+++ tools/hmsa/Makefile Sun Nov 22 01:59:13 2009 +0100
-@@ -8,7 +8,7 @@
- OBJS = $(HMSA_OBJS) $(HATARI_OBJS:%.o=../../src/%.o)
-
- # Additional include directories:
--CPPFLAGS += $(SDL_CFLAGS) -I../.. -I../../src/includes -I../../src/uae-cpu
-+CPPFLAGS += -I../.. -I../../src/includes -I../../src/uae-cpu $(SDL_CFLAGS)
-
- all: hmsa
-
diff --git a/emulators/hatari/pkg-plist b/emulators/hatari/pkg-plist
index c1b56ed9d345..5d0e682a398f 100644
--- a/emulators/hatari/pkg-plist
+++ b/emulators/hatari/pkg-plist
@@ -1,8 +1,9 @@
+bin/atari-hd-image.sh
bin/hatari
bin/hatari-console.py
bin/hatariui
bin/hmsa
-bin/zip2st
+bin/zip2st.sh
share/applications/hatariui.desktop
%%PORTDOCS%%%%DOCSDIR%%/authors.txt
%%PORTDOCS%%%%DOCSDIR%%/changelog.txt
@@ -17,6 +18,7 @@ share/applications/hatariui.desktop
%%PORTDOCS%%%%DOCSDIR%%/images/keyboard.png
%%PORTDOCS%%%%DOCSDIR%%/images/main.png
%%PORTDOCS%%%%DOCSDIR%%/images/memory.png
+%%PORTDOCS%%%%DOCSDIR%%/images/monitor.png
%%PORTDOCS%%%%DOCSDIR%%/images/newfloppy.png
%%PORTDOCS%%%%DOCSDIR%%/images/screen.png
%%PORTDOCS%%%%DOCSDIR%%/images/sound.png
@@ -30,7 +32,6 @@ share/applications/hatariui.desktop
%%PORTDOCS%%%%DOCSDIR%%/release-notes.txt
%%PORTDOCS%%%%DOCSDIR%%/todo.txt
%%DATADIR%%/hatari-icon.bmp
-%%DATADIR%%/hatariui/Changelog
%%DATADIR%%/hatariui/README
%%DATADIR%%/hatariui/TODO
%%DATADIR%%/hatariui/config.py
@@ -40,6 +41,7 @@ share/applications/hatariui.desktop
%%DATADIR%%/hatariui/hatari.png
%%DATADIR%%/hatariui/hatari.py
%%DATADIR%%/hatariui/hatariui.py
+%%DATADIR%%/hatariui/release-notes.txt
%%DATADIR%%/hatariui/uihelpers.py
%%DATADIR%%/tos.img
share/pixmaps/hatari-icon.png