aboutsummaryrefslogtreecommitdiff
path: root/emulators/hatari
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-12 19:40:36 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-08-12 19:40:36 +0000
commited40f4ba7b5ae7a1a666d2bd53a218366ceb415e (patch)
tree3b6c4150518c58f3d5835cf20b9190b06567ee14 /emulators/hatari
parentaa0eefce9e4834ffdb9b89808f34a2e62e4f7c49 (diff)
downloadports-ed40f4ba7b5ae7a1a666d2bd53a218366ceb415e.tar.gz
ports-ed40f4ba7b5ae7a1a666d2bd53a218366ceb415e.zip
Update to 1.5.0
PR: 159439 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=279567
Diffstat (limited to 'emulators/hatari')
-rw-r--r--emulators/hatari/Makefile29
-rw-r--r--emulators/hatari/distinfo4
-rw-r--r--emulators/hatari/pkg-plist12
3 files changed, 30 insertions, 15 deletions
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index 818436cef41f..984d769a29fa 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -6,13 +6,16 @@
#
PORTNAME= hatari
-PORTVERSION= 1.4.0
+PORTVERSION= 1.5.0
CATEGORIES= emulators
MASTER_SITES= BERLIOS
MAINTAINER= ports@FreeBSD.org
COMMENT= An Atari ST emulator
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
+
BUILD_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
RUN_DEPENDS= portaudio>=19:${PORTSDIR}/audio/portaudio2
@@ -23,28 +26,34 @@ USE_SDL= sdl
USE_CMAKE= yes
CMAKE_ARGS= -DPORTAUDIO_INCLUDE_DIR:STRING="${PA2_INCLUDE_DIR}" \
-DPORTAUDIO_LIBRARY:STRING="${PA2_LIBRARY}" \
- -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG"
+ -DCMAKE_C_FLAGS_RELEASE:STRING="-DNDEBUG" \
+ -DETCDIR:STRING="${PREFIX}/etc" \
+ -DMANDIR:STRING="man/man1"
+MAKE_JOBS_SAFE= yes
MANCOMPRESSED= yes
MANLANG= "" fr
MAN1= ${PORTNAME}.1
-MAN1_EN= ${PORTNAME}ui.1
+MAN1_EN= atari-hd-image.1 hatariui.1 hconsole.1 hmsa.1 zip2st.1
CFLAGS+= -I${LOCALBASE}/include/portaudio2
PA2_INCLUDE_DIR=-I${LOCALBASE}/include/portaudio2
PA2_LIBRARY= ${LOCALBASE}/lib/portaudio2/libportaudio.so
-post-extract:
- @cd ${WRKSRC}/doc && ${GZIP_CMD} -c ${PORTNAME}.1 > ${PORTNAME}.1.gz
- @cd ${WRKSRC}/doc/fr && ${GZIP_CMD} -c ${PORTNAME}.1 > ${PORTNAME}.1.gz
-
post-patch:
- @${REINPLACE_CMD} -e '/CONFDIR/s|"/etc|"${PREFIX}/etc| ; \
- /MANDIR/s|share/man|man| ; \
- /doc/s|^add_|#add_|' ${WRKSRC}/CMakeLists.txt
+ @${FIND} ${WRKSRC} -name "*.1" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|^/etc|${PREFIX}/etc| ; \
+ s| (or /usr.*|| ; \
+ s|/usr/share|${PREFIX}/share|'
+ @${REINPLACE_CMD} -e '/doc/s|^add_|#add_|' \
+ ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e '/DESTINATION/s|/icons/.*)|/pixmaps)|' \
${WRKSRC}/python-ui/CMakeLists.txt
+post-build:
+ @cd ${WRKSRC}/doc && ${GZIP_CMD} -c ${PORTNAME}.1 > ${PORTNAME}.1.gz
+ @cd ${WRKSRC}/doc/fr && ${GZIP_CMD} -c ${PORTNAME}.1 > ${PORTNAME}.1.gz
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/${PORTNAME}.1.gz ${MANPREFIX}/man/man1
@${MKDIR} ${MANPREFIX}/man/fr/man1
diff --git a/emulators/hatari/distinfo b/emulators/hatari/distinfo
index 87f0a400f588..15e4eda85cb0 100644
--- a/emulators/hatari/distinfo
+++ b/emulators/hatari/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hatari-1.4.0.tar.bz2) = 690e21bd2210a7e86af5d76ccc7f4e608aae37df466d2ead2ac4d105a637bc7b
-SIZE (hatari-1.4.0.tar.bz2) = 1260844
+SHA256 (hatari-1.5.0.tar.bz2) = 0cb9c627ea6942bc60908c3a59b4b5c86a54e5bd0551cd95d8cff76bbde61e7f
+SIZE (hatari-1.5.0.tar.bz2) = 1570048
diff --git a/emulators/hatari/pkg-plist b/emulators/hatari/pkg-plist
index 5d0e682a398f..477025360186 100644
--- a/emulators/hatari/pkg-plist
+++ b/emulators/hatari/pkg-plist
@@ -1,12 +1,12 @@
-bin/atari-hd-image.sh
+bin/atari-hd-image
bin/hatari
-bin/hatari-console.py
bin/hatariui
bin/hmsa
-bin/zip2st.sh
+bin/zip2st
share/applications/hatariui.desktop
%%PORTDOCS%%%%DOCSDIR%%/authors.txt
%%PORTDOCS%%%%DOCSDIR%%/changelog.txt
+%%PORTDOCS%%%%DOCSDIR%%/coding.txt
%%PORTDOCS%%%%DOCSDIR%%/compatibility.html
%%PORTDOCS%%%%DOCSDIR%%/emutos.txt
%%PORTDOCS%%%%DOCSDIR%%/fr/clavier-exemple.txt
@@ -43,8 +43,14 @@ share/applications/hatariui.desktop
%%DATADIR%%/hatariui/hatariui.py
%%DATADIR%%/hatariui/release-notes.txt
%%DATADIR%%/hatariui/uihelpers.py
+%%DATADIR%%/hconsole/example-commands
+%%DATADIR%%/hconsole/example-debugger
+%%DATADIR%%/hconsole/example.py
+%%DATADIR%%/hconsole/hconsole.py
+%%DATADIR%%/hconsole/release-notes.txt
%%DATADIR%%/tos.img
share/pixmaps/hatari-icon.png
+@dirrm %%DATADIR%%/hconsole
@dirrm %%DATADIR%%/hatariui
@dirrm %%DATADIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images