aboutsummaryrefslogtreecommitdiff
path: root/emulators/i386-wine
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2020-03-13 21:11:06 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2020-03-13 21:11:06 +0000
commit9bdd8e871b28eaceacf5999517c13960b0fb6af2 (patch)
tree45ed58cb9e79b1a55c895305cc790813406bc531 /emulators/i386-wine
parent7e7fcbf1c51e61076c73204233cb49befbd64149 (diff)
downloadports-9bdd8e871b28eaceacf5999517c13960b0fb6af2.tar.gz
ports-9bdd8e871b28eaceacf5999517c13960b0fb6af2.zip
emulators/i386-wine: Use standard ports infrastructure for ARCH
This commit is the analogous for i386-wine of r528249 that concerns emulators/i386-wine-devel. Until now i386-wine defined its own ARCH variable and manually included Makefile.i386 for i386 systems and Makefile.inc for amd64 systems. This commit makes use of the standard ARCH variable and renames Makefile.inc to Makefile.amd64 so that the proper Makefile.${ARCH} is automatically included. This requires conditional inclusion bsd.ports.pre.mk and bsd.ports.post.mk by emulators/wine [1], master port for i386-wine: those files must be included only if they have not already been included by i386-wine. Approved by: gerald (mentor, maintainer [1])
Notes
Notes: svn path=/head/; revision=528378
Diffstat (limited to 'emulators/i386-wine')
-rw-r--r--emulators/i386-wine/Makefile10
-rw-r--r--emulators/i386-wine/Makefile.amd64 (renamed from emulators/i386-wine/Makefile.inc)7
2 files changed, 2 insertions, 15 deletions
diff --git a/emulators/i386-wine/Makefile b/emulators/i386-wine/Makefile
index 3e65cfa1622b..cd1db887fb57 100644
--- a/emulators/i386-wine/Makefile
+++ b/emulators/i386-wine/Makefile
@@ -5,12 +5,6 @@
# - i386 specific port to be slave to ${PORTSDIR}/emulators/wine
# - amd64 specific port to be normal port (based on binary package)
-.if !defined(ARCH)
-ARCH!= uname -p
-.endif
+ONLY_FOR_ARCHS= i386 amd64
-.if ${ARCH} == i386
-.include "${.CURDIR}/Makefile.i386"
-.else
-.include "${.CURDIR}/Makefile.inc"
-.endif
+.include <bsd.port.mk>
diff --git a/emulators/i386-wine/Makefile.inc b/emulators/i386-wine/Makefile.amd64
index 5bfb0f1d1c9b..4fe63844852c 100644
--- a/emulators/i386-wine/Makefile.inc
+++ b/emulators/i386-wine/Makefile.amd64
@@ -31,8 +31,6 @@ EXTRACT_AFTER_ARGS= -C / --exclude +COMPACT_MANIFEST --exclude +MANIFEST \
--exclude libdata/ldconfig32/${PKGNAMEPREFIX}${PORTNAME} \
-s '|/usr/local|${STAGEDIR}${PREFIX}|gs'
NO_BUILD= yes
-ONLY_FOR_ARCHS= i386 amd64
-ONLY_FOR_ARCHS_REASON= wine only runs on x86 architecture
SLAVEDIR?= ${.CURDIR}
PKGINSTALL= ${SLAVEDIR}/files/pkg-install
PKGDEINSTALL= ${PKGINSTALL}
@@ -47,9 +45,6 @@ MONO_RUN_DEPENDS= ${DATADIR}/mono/wine-mono-4.9.4.msi:emulators/wine-mono
PORTSCOUT= limitw:1,even
-# Included for OPSYS and OSVERSION
-.include <bsd.port.pre.mk>
-
.for osrel in 11 12 13
.if ${OSREL:C/\..*//} == ${osrel}
PLIST_SUB+= OSREL${osrel}=""
@@ -86,5 +81,3 @@ port-update:
${SED} -e '2,$${' -e '/^TIMESTAMP/d' -e '}' distinfo~ > ${SLAVEDIR}/distinfo
python ${FILESDIR}/mergeplist.py ${SLAVEDIR}/pkg-plist.* > ${PLIST}
${RM} ${SLAVEDIR}/distinfo~ ${SLAVEDIR}/pkg-plist.*
-
-.include <bsd.port.post.mk>