aboutsummaryrefslogtreecommitdiff
path: root/emulators/i386-wine
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-03-14 21:00:40 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-03-14 21:00:40 +0000
commitc2ec2ad0dff6033b9dcbad7e220799e3c3c755e7 (patch)
tree1d2a11d1bed1bc9c035f3d7adc40acf1181f97a8 /emulators/i386-wine
parentdccb84610a130e0a805f06e6084d3c11e1757bc5 (diff)
downloadports-c2ec2ad0dff6033b9dcbad7e220799e3c3c755e7.tar.gz
ports-c2ec2ad0dff6033b9dcbad7e220799e3c3c755e7.zip
emulators/i386-wine*: further unbreak poudriere bulk -a
Previous commits uncovered another error: [00:02:28] Warning: (emulators/i386-wine-devel): Error: Duplicated origin for -: emulators/i386-wine-devel AND emulators/i386-wine. Rerun with -v to see which ports are depending on these. This is because PORTNAME and PORTVERSION are not defined. Submitted by: salvadore (maintainer)
Notes
Notes: svn path=/head/; revision=528442
Diffstat (limited to 'emulators/i386-wine')
-rw-r--r--emulators/i386-wine/Makefile8
-rw-r--r--emulators/i386-wine/Makefile.amd647
-rw-r--r--emulators/i386-wine/Makefile.i3865
3 files changed, 9 insertions, 11 deletions
diff --git a/emulators/i386-wine/Makefile b/emulators/i386-wine/Makefile
index 3d7b17d50626..1630dd51bf14 100644
--- a/emulators/i386-wine/Makefile
+++ b/emulators/i386-wine/Makefile
@@ -5,8 +5,16 @@
# - i386 specific port to be slave to ${PORTSDIR}/emulators/wine
# - amd64 specific port to be normal port (based on binary package)
+PORTNAME= wine
+# define a dummy DISTVERSION to avoid errors with poudriere bulk -a
+# on architectures unsupported by this port
+DISTVERSION?= 0
+PKGNAMEPREFIX= i386-
CATEGORIES= emulators
+MAINTAINER= salvadore@FreeBSD.org
+COMMENT= 32-bit Microsoft Windows compatibility environment for 64-bit FreeBSD
+
ONLY_FOR_ARCHS= i386 amd64
.include <bsd.port.mk>
diff --git a/emulators/i386-wine/Makefile.amd64 b/emulators/i386-wine/Makefile.amd64
index 2ed9a93c964c..488c8ec6364b 100644
--- a/emulators/i386-wine/Makefile.amd64
+++ b/emulators/i386-wine/Makefile.amd64
@@ -1,19 +1,14 @@
# Created by: David Naylor <dbn@FreeBSD.org>
# $FreeBSD$
-PORTNAME= wine
-PORTVERSION= 3.0.4
+DISTVERSION= 3.0.4
PORTREVISION= 1
PORTEPOCH= 1
MASTER_SITES= LOCAL/dbn/repos/wine/${DIST_SUBDIR}/
-PKGNAMEPREFIX= i386-
DISTNAME= ${PKGNAME}
EXTRACT_SUFX= .txz
DIST_SUBDIR= freebsd:${OSREL:C/\..*//}:x86:64
-MAINTAINER= salvadore@FreeBSD.org
-COMMENT?= 32-bit Microsoft Windows compatibility environment for 64-bit FreeBSD
-
LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
LICENSE_FILE= ${WRKDIR}/LICENSE
diff --git a/emulators/i386-wine/Makefile.i386 b/emulators/i386-wine/Makefile.i386
index 6736fc604db7..3f117dce07b2 100644
--- a/emulators/i386-wine/Makefile.i386
+++ b/emulators/i386-wine/Makefile.i386
@@ -1,11 +1,6 @@
# Created by: David Naylor <dbn@FreeBSD.org>
# $FreeBSD$
-PKGNAMEPREFIX= i386-
-
-MAINTAINER= salvadore@FreeBSD.org
-COMMENT?= 32-bit Microsoft Windows compatibility environment for 64-bit FreeBSD
-
# Use the wine port to do most of the heavy lifting
SLAVEDIR?= ${.CURDIR}
MASTERDIR= ${SLAVEDIR}/../wine