aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-8
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-12-04 13:12:08 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-12-04 13:12:08 +0000
commit959fd9b593889260cde8984df24af20a36d7fbf9 (patch)
tree377c76708a023067a334e478552ce86d528b34d6 /emulators/linux_base-8
parent96b17e813c46f4b32e80199deb96c752061f474f (diff)
downloadports-959fd9b593889260cde8984df24af20a36d7fbf9.tar.gz
ports-959fd9b593889260cde8984df24af20a36d7fbf9.zip
Notes
Diffstat (limited to 'emulators/linux_base-8')
-rw-r--r--emulators/linux_base-8/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/emulators/linux_base-8/Makefile b/emulators/linux_base-8/Makefile
index ac6ef9999b7a..11e85ad17dac 100644
--- a/emulators/linux_base-8/Makefile
+++ b/emulators/linux_base-8/Makefile
@@ -16,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTVERSION}/os/${ARCH} \
${PORTVERSION}/updates/${ARCH} \
${PORTVERSION}/os/SRPMS \
${PORTVERSION}/updates/SRPMS
-DISTFILES= redhat-release-8.0-8.noarch.rpm \
+BIN_DISTFILES= redhat-release-8.0-8.noarch.rpm \
glibc-common-2.3.2-4.80.8.${ARCH}.rpm \
glibc-2.3.2-4.80.8.${ARCH}.rpm \
setup-2.5.20-1.noarch.rpm \
@@ -52,7 +52,7 @@ DISTFILES= redhat-release-8.0-8.noarch.rpm \
EXTRACT_ONLY=
.if defined(PACKAGE_BUILDING)
-DISTFILES+= acl-2.0.11-2.src.rpm \
+SRC_DISTFILES+= acl-2.0.11-2.src.rpm \
attr-2.0.8-3.src.rpm \
basesystem-8.0-1.src.rpm \
bash-2.05b-5.1.src.rpm \
@@ -84,6 +84,8 @@ DISTFILES+= acl-2.0.11-2.src.rpm \
ALWAYS_KEEP_DISTFILES= yes
.endif
+DISTFILES= ${BIN_DISTFILES} ${SRC_DISTFILES}
+
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Base set of packages needed in Linux mode (for i386/amd64)
@@ -99,9 +101,6 @@ NO_FILTER_SHLIBS= yes
NO_MTREE= yes
MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
-# Let's avoid hardcoding 'en' as the language.
-LANG= en
-
.include <bsd.port.pre.mk>
DBPATH= /var/lib/rpm
@@ -142,7 +141,7 @@ do-install:
# Also, set the ELF fallback brand to Linux, so that we don't have to do
# anything special to run staticly linked binaries.
@/sbin/sysctl -w ${FALLBACK_ELF_MIB}=${LINUX_ELF}
- @for R in ${DISTFILES:S/:ft//}; do \
+ @for R in ${BIN_DISTFILES:S/:ft//}; do \
${ECHO} $$R; \
${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done