aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-c7
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2017-01-14 13:13:31 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2017-01-14 13:13:31 +0000
commit793f920bb34606473f2a19520bd27be6e065a17d (patch)
tree2fb398a3de88629941487684e622f34e537f520e /emulators/linux_base-c7
parent72923f111f4b157b9b67dc6f332472595c44628d (diff)
downloadports-793f920bb34606473f2a19520bd27be6e065a17d.tar.gz
ports-793f920bb34606473f2a19520bd27be6e065a17d.zip
Don't use @dir for directories that may have filesystems mounted. It may
not be possible to change their mode and timestamp like @dir tries to do. PR: 215769 MFH: 2017Q1
Notes
Notes: svn path=/head/; revision=431465
Diffstat (limited to 'emulators/linux_base-c7')
-rw-r--r--emulators/linux_base-c7/Makefile2
-rw-r--r--emulators/linux_base-c7/pkg-plist.i38612
-rw-r--r--emulators/linux_base-c7/pkg-plist.x86_6412
3 files changed, 19 insertions, 7 deletions
diff --git a/emulators/linux_base-c7/Makefile b/emulators/linux_base-c7/Makefile
index c718bbe36e29..3572af5ecfdf 100644
--- a/emulators/linux_base-c7/Makefile
+++ b/emulators/linux_base-c7/Makefile
@@ -2,7 +2,7 @@
PORTNAME= c7
PORTVERSION= ${LINUX_DIST_VER}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators linux
PKGNAMEPREFIX= linux_base-
EXTRACT_ONLY= ${DISTFILES:N*.src.rpm*:Nfilesystem-*}
diff --git a/emulators/linux_base-c7/pkg-plist.i386 b/emulators/linux_base-c7/pkg-plist.i386
index c55282341a76..b159f2a37c3c 100644
--- a/emulators/linux_base-c7/pkg-plist.i386
+++ b/emulators/linux_base-c7/pkg-plist.i386
@@ -2572,7 +2572,7 @@ usr/tmp
@rmtry var/cache/ldconfig/aux-cache
var/db/Makefile
var/mail
-@dir dev/shm
+@dir dev
@dir etc/X11/applnk
@dir etc/X11/fontpath.d
@dir etc/bash_completion.d
@@ -2589,9 +2589,7 @@ var/mail
@dir etc/xinetd.d
@dir mnt
@dir opt
-@dir(,,555) proc
@dir srv
-@dir(,,555) sys
@dir usr/etc
@dir usr/games
@dir usr/include
@@ -3135,4 +3133,12 @@ var/mail
@dir var/spool/mail
@dir var/yp
@dir %%LINUXBASE%%
+@comment These directories may have filesystems mounted and then it may not be
+@comment possible to change their mode and timestamp like @dir tries to do.
+@postexec mkdir -p %D/dev/shm
+@postunexec rmdir %D/dev/shm 2>/dev/null || true
+@postexec mkdir -p %D/proc
+@postunexec rmdir %D/proc 2>/dev/null || true
+@postexec mkdir -p %D/sys
+@postunexec rmdir %D/sys 2>/dev/null || true
@postexec %D/usr/sbin/ldconfig
diff --git a/emulators/linux_base-c7/pkg-plist.x86_64 b/emulators/linux_base-c7/pkg-plist.x86_64
index 049761611dec..59681f1f72f9 100644
--- a/emulators/linux_base-c7/pkg-plist.x86_64
+++ b/emulators/linux_base-c7/pkg-plist.x86_64
@@ -3022,7 +3022,7 @@ usr/tmp
var/db/Makefile
@rmtry var/cache/ldconfig/aux-cache
var/mail
-@dir dev/shm
+@dir dev
@dir etc/X11/applnk
@dir etc/X11/fontpath.d
@dir etc/bash_completion.d
@@ -3039,9 +3039,7 @@ var/mail
@dir etc/xinetd.d
@dir mnt
@dir opt
-@dir(,,555) proc
@dir srv
-@dir(,,555) sys
@dir usr/etc
@dir usr/games
@dir usr/include
@@ -3591,4 +3589,12 @@ var/mail
@dir var/spool/mail
@dir var/yp
@dir %%LINUXBASE%%
+@comment These directories may have filesystems mounted and then it may not be
+@comment possible to change their mode and timestamp like @dir tries to do.
+@postexec mkdir -p %D/dev/shm
+@postunexec rmdir %D/dev/shm 2>/dev/null || true
+@postexec mkdir -p %D/proc
+@postunexec rmdir %D/proc 2>/dev/null || true
+@postexec mkdir -p %D/sys
+@postunexec rmdir %D/sys 2>/dev/null || true
@postexec %D/usr/sbin/ldconfig