aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-suse-9.3/Makefile
diff options
context:
space:
mode:
authorMarcel Moolenaar <marcel@FreeBSD.org>2000-11-21 07:38:23 +0000
committerMarcel Moolenaar <marcel@FreeBSD.org>2000-11-21 07:38:23 +0000
commitda038eb9ee5c737511a8b8dee2f67db6c17fd448 (patch)
treee42a649a62d3856202736cf9cf20ebd7c80bfff4 /emulators/linux_base-suse-9.3/Makefile
parent2ca6f95f206c0c7a4e87b58f487b6f9d2f18e4a3 (diff)
The info package seems to be sensitive about the locale
settings and fails to install if the language is not C. Override any locale settings when running rpm. PR: 16621 Submitted by: Mikhail Teterin <mi@video-collage.com>
Notes
Notes: svn path=/head/; revision=35302
Diffstat (limited to 'emulators/linux_base-suse-9.3/Makefile')
-rw-r--r--emulators/linux_base-suse-9.3/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/emulators/linux_base-suse-9.3/Makefile b/emulators/linux_base-suse-9.3/Makefile
index 116b00f09efd..de80d0cac0c6 100644
--- a/emulators/linux_base-suse-9.3/Makefile
+++ b/emulators/linux_base-suse-9.3/Makefile
@@ -96,6 +96,7 @@ RPM_SET3= setserial-2.15-2.${MACHINE_ARCH}.rpm \
xpm-3.4k-1.${MACHINE_ARCH}.rpm
DBPATH= /var/lib/rpm
+RPM= LC_ALL=C rpm
RPMFLAGS= --ignoreos --root ${LINUXBASE} --dbpath ${DBPATH} \
--nodeps --replacepkgs
RPMDIR= ${DISTDIR}/${DIST_SUBDIR}
@@ -134,7 +135,7 @@ pre-install:
do-install:
@${MKDIR} ${LINUXBASE}/${DBPATH}
@${MKDIR} ${LINUXBASE}/var/tmp
- @rpm --initdb --root ${LINUXBASE} --dbpath ${DBPATH}
+ @${RPM} --initdb --root ${LINUXBASE} --dbpath ${DBPATH}
#
# Make sure we have a /dev/null in the chrooted environment.
#
@@ -152,30 +153,30 @@ do-install:
#
@for R in ${RPM_SET1}; do \
${ECHO} $$R; \
- rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
+ ${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
@${ECHO} ${RPM_LDCONFIG}
- @rpm -U ${RPMFLAGS} --noscripts ${RPMDIR}/${RPM_LDCONFIG}
+ @${RPM} -U ${RPMFLAGS} --noscripts ${RPMDIR}/${RPM_LDCONFIG}
@brandelf -t Linux ${LINUXBASE}/sbin/ldconfig
@${LINUXBASE}/sbin/ldconfig
@${TOUCH} ${LINUXBASE}/etc/ld.so.conf
@for R in ${RPM_SET2}; do \
${ECHO} $$R; \
- rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
+ ${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
@${ECHO} ${RPM_RPM}
- @rpm -U ${RPMFLAGS} --noscripts ${RPMDIR}/${RPM_RPM}
+ @${RPM} -U ${RPMFLAGS} --noscripts ${RPMDIR}/${RPM_RPM}
@brandelf -t Linux ${LINUXBASE}/bin/rpm
@for R in ${RPM_SET3}; do \
${ECHO} $$R; \
- rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
+ ${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
#
# Install updates
#
@for R in ${PATCHFILES}; do \
${ECHO} $$R; \
- rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
+ ${RPM} -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
#
# Install yp.conf as a hint to NIS users