aboutsummaryrefslogtreecommitdiff
path: root/emulators/mame
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-04-09 02:21:52 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-04-09 02:21:52 +0000
commit19f2efc8a4a3e6111a7a83d8c24cbf4e183d7c08 (patch)
tree94f0de8f1bc7345ec9337744c5a58b43f6eb1d7c /emulators/mame
parent316d9f5259f8cf62b4e972cae907a294a32afff4 (diff)
downloadports-19f2efc8a4a3e6111a7a83d8c24cbf4e183d7c08.tar.gz
ports-19f2efc8a4a3e6111a7a83d8c24cbf4e183d7c08.zip
Notes
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile5
-rw-r--r--emulators/mame/distinfo6
-rw-r--r--emulators/mame/files/patch-makefile30
-rw-r--r--emulators/mame/pkg-plist5
4 files changed, 26 insertions, 20 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 025557cdac03..8e65ea02f366 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sdlmame
-PORTVERSION= 0.112u2
+PORTVERSION= 0.114
CATEGORIES= emulators
MASTER_SITES= http://rbelmont.mameworld.info/
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
@@ -25,7 +25,8 @@ SUB_FILES= ${PORTNAME} pkg-message
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
${MKDIR} ${PREFIX}/libexec/${PORTNAME}
-.for f in mame file2str romcmp chdman jedutil
+.for f in obj/mame/file2str obj/mame/png2bdc mame testkeys romcmp chdman \
+ jedutil makemeta regrep srcclean
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/libexec/${PORTNAME}
.endfor
${MKDIR} ${DATADIR}
diff --git a/emulators/mame/distinfo b/emulators/mame/distinfo
index c0c60c9b5540..5b8752ff149e 100644
--- a/emulators/mame/distinfo
+++ b/emulators/mame/distinfo
@@ -1,3 +1,3 @@
-MD5 (sdlmame0112u2.zip) = 3505ed75d9034621ae3774d1d61edc5e
-SHA256 (sdlmame0112u2.zip) = 7796f76494dbf5c6d5628a22b653f7ea8730781cc1f414e4d8e2b4732d9e787a
-SIZE (sdlmame0112u2.zip) = 15437796
+MD5 (sdlmame0114.zip) = decacf02b85b4a6ebd2958780dce55b7
+SHA256 (sdlmame0114.zip) = 44b0d07fa1204552a1f8cef4e9ecb558f3bdb1d110b8d0f401d465f1f16b86f1
+SIZE (sdlmame0114.zip) = 15225632
diff --git a/emulators/mame/files/patch-makefile b/emulators/mame/files/patch-makefile
index 83d38ebdce15..52a8b06c3766 100644
--- a/emulators/mame/files/patch-makefile
+++ b/emulators/mame/files/patch-makefile
@@ -1,17 +1,17 @@
---- ./makefile.orig Sun Feb 18 22:23:18 2007
-+++ ./makefile Fri Feb 23 01:26:35 2007
-@@ -50,7 +50,7 @@
- #
- # NOTE: this makefile now works for MinGW/win32 builds as well!
- #
+--- ./makefile.orig Fri Mar 30 04:03:29 2007
++++ ./makefile Sun Apr 8 19:44:17 2007
+@@ -52,7 +52,7 @@
+ # for SDLMAME, set this to linux, freebsd, win32, or macosx (lowercase is important!)
+ #------------------------------------------------------------------------------------
+
-SUBARCH = linux
+SUBARCH = freebsd
#-------------------------------------------------
-@@ -61,11 +61,13 @@
+@@ -63,11 +63,13 @@
# uncomment next line to include the debugger
- #DEBUG = 1
+ # DEBUG = 1
+ifeq ($(ARCH),i386)
# uncomment next line to use DRC MIPS3 engine
@@ -23,7 +23,7 @@
#-------------------------------------------------
# specify build options; see each option below
-@@ -172,8 +174,8 @@
+@@ -174,8 +176,8 @@
# compiler, linker and utilities
AR = @ar
@@ -34,7 +34,7 @@
MD = -mkdir
RM = @rm -f
-@@ -189,53 +191,12 @@
+@@ -191,53 +193,12 @@
endif
# by default, don't compile for a specific target CPU
@@ -90,7 +90,7 @@
endif
EMULATOR = $(NAME)$(EXE)
-@@ -273,7 +234,7 @@
+@@ -275,7 +236,7 @@
# compile and linking flags
#-------------------------------------------------
@@ -99,7 +99,7 @@
$(OPT_FLAGS) \
-std=gnu89 \
-I$(SRC)/$(TARGET) \
-@@ -284,6 +245,7 @@
+@@ -287,6 +248,7 @@
-I$(SRC)/lib/util \
-I$(SRC)/osd \
-I$(SRC)/osd/$(MAMEOS) \
@@ -107,7 +107,7 @@
ifdef MESS
CFLAGS += \
-@@ -302,7 +264,7 @@
+@@ -305,7 +267,7 @@
endif # PPC
endif # SYMBOLS
@@ -116,7 +116,7 @@
-Wall \
-Wpointer-arith \
-Wbad-function-cast \
-@@ -314,7 +276,7 @@
+@@ -317,7 +279,7 @@
-Wdeclaration-after-statement
ifneq ($(OPTIMIZE),0)
@@ -125,7 +125,7 @@
endif
CFLAGS += -O$(OPTIMIZE)
-@@ -322,11 +284,9 @@
+@@ -325,11 +287,9 @@
# extra options needed *only* for the osd files
CFLAGSOSDEPEND = $(CFLAGS)
diff --git a/emulators/mame/pkg-plist b/emulators/mame/pkg-plist
index 58d99b69856f..1492b34678dc 100644
--- a/emulators/mame/pkg-plist
+++ b/emulators/mame/pkg-plist
@@ -3,8 +3,13 @@ bin/sdlmame
libexec/sdlmame/chdman
libexec/sdlmame/file2str
libexec/sdlmame/jedutil
+libexec/sdlmame/makemeta
libexec/sdlmame/mame
+libexec/sdlmame/png2bdc
+libexec/sdlmame/regrep
libexec/sdlmame/romcmp
+libexec/sdlmame/srcclean
+libexec/sdlmame/testkeys
%%PORTDOCS%%%%DOCSDIR%%/SDLMAME.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/license.txt
%%PORTDOCS%%%%DOCSDIR%%/docs/mame.txt