aboutsummaryrefslogtreecommitdiff
path: root/emulators/mame
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-04-05 03:01:23 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2018-04-05 03:01:23 +0000
commit2e9aa4504557875c5e7d765402e8e17f1e57f488 (patch)
tree60c5c00c3f3cc7fed600d62cee94f142bbff8175 /emulators/mame
parentfeb5c6e240687ce1fdaef3868aec9d133e2a14c3 (diff)
downloadports-2e9aa4504557875c5e7d765402e8e17f1e57f488.tar.gz
ports-2e9aa4504557875c5e7d765402e8e17f1e57f488.zip
- Use compiler:c++14-lang instead of an if statement
- Split USES to a separate block Reported by: jbeich, mat
Notes
Notes: svn path=/head/; revision=466524
Diffstat (limited to 'emulators/mame')
-rw-r--r--emulators/mame/Makefile11
1 files changed, 2 insertions, 9 deletions
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index 73f94b1369fd..1f8729f0838a 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libfreetype.so:print/freetype2
RUN_DEPENDS= liberation-fonts-ttf>=0:x11-fonts/liberation-fonts-ttf
-USES= compiler:c11 gmake jpeg pkgconfig python:2.7,build shebangfix
+USES= compiler:c++14-lang gmake jpeg pkgconfig python:2.7,build shebangfix
+
USE_GITHUB= yes
GH_ACCOUNT= mamedev
GH_PROJECT= mame # explicit (master port)
@@ -27,14 +28,6 @@ GH_TAGNAME= mame${PORTVERSION:S/.//}
OPTIONS_DEFINE= DEBUG DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} < 1100055
-BUILD_DEPENDS+= clang50:devel/llvm50
-CC= clang50
-CXX= clang++50
-.endif
-
SHEBANG_FILES= src/devices/cpu/m6502/m6502make.py \
src/devices/cpu/m6809/m6809make.py \
src/devices/cpu/mcs96/mcs96make.py \