aboutsummaryrefslogtreecommitdiff
path: root/emulators/mednafen
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2014-04-05 21:42:17 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2014-04-05 21:42:17 +0000
commit174f90b907db9d121d307c2c359bc46b376ba5a0 (patch)
tree8ff3f4f2595e1485d38a0b9c2c820dcd00716fa2 /emulators/mednafen
parentcb0e5a80c57b3ec1b92a30f9cfcdf32024a347ab (diff)
downloadports-174f90b907db9d121d307c2c359bc46b376ba5a0.tar.gz
ports-174f90b907db9d121d307c2c359bc46b376ba5a0.zip
- Update to 0.9.33.2
- Add PSX, VB and MD options - Remove obsolete patch file
Notes
Notes: svn path=/head/; revision=350270
Diffstat (limited to 'emulators/mednafen')
-rw-r--r--emulators/mednafen/Makefile12
-rw-r--r--emulators/mednafen/distinfo4
-rw-r--r--emulators/mednafen/files/patch-src-snes-src-lib-nall_property.hpp11
-rw-r--r--emulators/mednafen/files/patch-src__file.cpp29
4 files changed, 22 insertions, 34 deletions
diff --git a/emulators/mednafen/Makefile b/emulators/mednafen/Makefile
index 5d02386aa6ab..911229bd05f6 100644
--- a/emulators/mednafen/Makefile
+++ b/emulators/mednafen/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= mednafen
-PORTVERSION= 0.8.D.3
+PORTVERSION= 0.9.33.2
PORTEPOCH= 1
CATEGORIES= emulators games
MASTER_SITES= SF/${PORTNAME}/Mednafen/${PORTVERSION}
@@ -31,18 +31,21 @@ USES= iconv pkgconfig:build
OPTIONS_DEFINE= NLS DOCS JACK
OPTIONS_MULTI= EMU
-OPTIONS_MULTI_EMU= GB GBA LINX NES NGP PCE PCFX SMS SWAN
-OPTIONS_DEFAULT= GB GBA LINX NES NGP PCE PCFX SMS SWAN
+OPTIONS_MULTI_EMU= GB GBA LINX MD NES NGP PCE PCFX PSX SMS SWAN VB
+OPTIONS_DEFAULT= GB GBA LINX MD NES NGP PCE PCFX PSX SMS SWAN VB
GB_DESC= build with GameBoy emulation
GBA_DESC= build with GameBoy Advance emulation
LINX_DESC= build with Atari Lynx emulation
+MD_DESC= build with Sega Genesis/MegaDrive emulation
NES_DESC= build with Nintendo Entertainment System emulation
NGP_DESC= build with Neo Geo Pocket emulation
PCE_DESC= build with PC Engine (TurboGrafx 16) emulation
PCFX_DESC= build with PC-FX emulation
+PSX_DESC= build with Playstation emulation
SMS_DESC= build with SMS+GG emulation
SWAN_DESC= build with WonderSWan emulation
+VB_DESC= build with Virtual Boy emulation
JACK_DESC= support the JACK audio API
OPTIONS_SUB= yes
@@ -56,12 +59,15 @@ JACK_CONFIGURE_ENABLE=jack
GB_CONFIGURE_ENABLE=gb
GBA_CONFIGURE_ENABLE=gba
LINX_CONFIGURE_ENABLE=lynx
+MD_CONFIGURE_ENABLE=md
NES_CONFIGURE_ENABLE=nes
NGP_CONFIGURE_ENABLE=ngp
PCE_CONFIGURE_ENABLE=pce
PCFX_CONFIGURE_ENABLE=pcfx
+PSX_CONFIGURE_ENABLE=psx
SMS_CONFIGURE_ENABLE=sms
SWAN_CONFIGURE_ENABLE=wswan
+VB_CONFIGURE_ENABLE=vb
BROKEN_sparc64= does not compile due to internal compiler error
diff --git a/emulators/mednafen/distinfo b/emulators/mednafen/distinfo
index bf4497db8eca..fcdd4be05722 100644
--- a/emulators/mednafen/distinfo
+++ b/emulators/mednafen/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mednafen-0.8.D.3.tar.bz2) = d678178f0dc03c89c7a0c83bf0c721af406ee53dfa79295432ab13722ed0eea2
-SIZE (mednafen-0.8.D.3.tar.bz2) = 2442705
+SHA256 (mednafen-0.9.33.2.tar.bz2) = d3125d5b6fe84031c7c7980bea655ec609c2620067988cfd32d2b2c5e6c3ad4e
+SIZE (mednafen-0.9.33.2.tar.bz2) = 4298456
diff --git a/emulators/mednafen/files/patch-src-snes-src-lib-nall_property.hpp b/emulators/mednafen/files/patch-src-snes-src-lib-nall_property.hpp
new file mode 100644
index 000000000000..bb6a378cbcaa
--- /dev/null
+++ b/emulators/mednafen/files/patch-src-snes-src-lib-nall_property.hpp
@@ -0,0 +1,11 @@
+--- src/snes/src/lib/nall/property.hpp 2014-04-05 16:03:07.000000000 -0500
++++ src/snes/src/lib/nall/property.hpp 2014-04-05 16:03:17.000000000 -0500
+@@ -61,7 +61,7 @@
+ operator T&() { return value; }
+ const T& operator=(const T& value_) { return value = value_; }
+ T value;
+- friend class traits<C>::type;
++ friend typename traits<C>::type;
+ };
+
+ template<typename T> struct writeonly {
diff --git a/emulators/mednafen/files/patch-src__file.cpp b/emulators/mednafen/files/patch-src__file.cpp
deleted file mode 100644
index 1012cc3b6eff..000000000000
--- a/emulators/mednafen/files/patch-src__file.cpp
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/file.cpp.orig 2009-05-15 06:12:55.000000000 +0400
-+++ src/file.cpp 2013-06-07 18:52:21.000000000 +0400
-@@ -229,7 +229,7 @@
- goto doret;
- }
-
-- while((howmany = gzread(tz, tmp->data + cur_size, cur_alloced - cur_size)) > 0)
-+ while((howmany = gzread((gzFile)tz, tmp->data + cur_size, cur_alloced - cur_size)) > 0)
- {
- cur_size += howmany;
- cur_alloced <<= 1;
-@@ -282,7 +282,7 @@
- }
- else if(type == MDFN_FILETYPE_GZIP)
- {
-- gzclose(tz);
-+ gzclose((gzFile)tz);
- }
- else if(type == MDFN_FILETYPE_ZIP)
- {
-@@ -444,7 +444,7 @@
-
- if(!(fceufp = MakeMemWrap(t, 1)))
- {
-- gzclose(t);
-+ gzclose((gzFile)t);
- return(0);
- }
-