aboutsummaryrefslogtreecommitdiff
path: root/emulators/mednafen
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-06-11 10:55:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-06-11 10:55:20 +0000
commitb1182b7176c481489eb87e0e25906c891ece12d3 (patch)
tree7bfd88f3ee46254b663cd839fde99f36c79d4a4b /emulators/mednafen
parent84cf703bf09ce9c30d184a392701a7d1b9e6376b (diff)
downloadports-b1182b7176c481489eb87e0e25906c891ece12d3.tar.gz
ports-b1182b7176c481489eb87e0e25906c891ece12d3.zip
Notes
Diffstat (limited to 'emulators/mednafen')
-rw-r--r--emulators/mednafen/Makefile55
-rw-r--r--emulators/mednafen/distinfo3
-rw-r--r--emulators/mednafen/files/pkg-message.in7
-rw-r--r--emulators/mednafen/pkg-descr16
-rw-r--r--emulators/mednafen/pkg-plist5
5 files changed, 86 insertions, 0 deletions
diff --git a/emulators/mednafen/Makefile b/emulators/mednafen/Makefile
new file mode 100644
index 000000000000..3a6e23abd5ca
--- /dev/null
+++ b/emulators/mednafen/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: mednafen
+# Date created: 2006-02-28
+# Whom: Charlie & <root@bsd.org.pe>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mednafen
+PORTVERSION= 0.6.1
+CATEGORIES= emulators games
+MASTER_SITES= http://mednafen.com/releases/
+
+MAINTAINER= acardenas@bsd.org.pe
+COMMENT= Portable multi-system emulator
+
+LIB_DEPENDS= cdio.7:${PORTSDIR}/sysutils/libcdio \
+ sndfile.1:${PORTSDIR}/audio/libsndfile \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_SDL= sdl net
+CPPFLAGS+= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+WRKSRC= ${WRKDIR}/${PORTNAME}
+SUB_FILES= pkg-message
+
+OPTIONS= NLS "Native Language Support" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+FLAG_NLS= true
+.endif
+
+pre-configure:
+ @${REINPLACE_CMD} -e 's|sdl-config|sdl11-config|g' ${WRKSRC}/configure
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/Documentation/mednafen.html ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/mednafen/distinfo b/emulators/mednafen/distinfo
new file mode 100644
index 000000000000..a42a4433939e
--- /dev/null
+++ b/emulators/mednafen/distinfo
@@ -0,0 +1,3 @@
+MD5 (mednafen-0.6.1.tar.bz2) = 4918b570f48f049021ead85b3b40edcb
+SHA256 (mednafen-0.6.1.tar.bz2) = e3021ce4cb60f479a01c963f471df47a6e48d3b1fdbf14875e09774dbc1e9c77
+SIZE (mednafen-0.6.1.tar.bz2) = 1435414
diff --git a/emulators/mednafen/files/pkg-message.in b/emulators/mednafen/files/pkg-message.in
new file mode 100644
index 000000000000..5738413a14c3
--- /dev/null
+++ b/emulators/mednafen/files/pkg-message.in
@@ -0,0 +1,7 @@
+###############################################################################
+
+1) Run mednafen [OPTION] [FILE]
+2) See complete documentation on %%DOCSDIR%%/mednafen.html
+3) Enjoy it ;)
+
+###############################################################################
diff --git a/emulators/mednafen/pkg-descr b/emulators/mednafen/pkg-descr
new file mode 100644
index 000000000000..c4b4fd6e9ee9
--- /dev/null
+++ b/emulators/mednafen/pkg-descr
@@ -0,0 +1,16 @@
+Mednafen is a portable, utilizing OpenGL and SDL, argument(command-line)-driven
+multi-system emulator with many advanced features. The Atari Lynx, GameBoy,
+GameBoy Color, GameBoy Advance, NES, PC Engine(TurboGrafx 16), and SuperGrafx
+are emulated. Mednafen has the ability to remap hotkey functions and virtual
+system inputs to a keyboard, a joystick, or both simultaneously. Save states
+are supported, as is real-time game rewinding. Screen snapshots may be taken at
+the press of a button, and are saved in the popular PNG file format.
+
+Mednafen is distributed under the terms of the GNU GPL.
+
+Due to the threaded model of emulation used in Mednafen, and limitations of SDL
+a joystick is preferred over a keyboard to play games, as the joystick will have
+slightly less latency, although the latency differences may not be perceptible
+to most people.
+
+WWW: http://mednafen.com/
diff --git a/emulators/mednafen/pkg-plist b/emulators/mednafen/pkg-plist
new file mode 100644
index 000000000000..c220b19ff7d5
--- /dev/null
+++ b/emulators/mednafen/pkg-plist
@@ -0,0 +1,5 @@
+bin/mednafen
+%%NLS%%share/locale/es/LC_MESSAGES/mednafen.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/mednafen.mo
+%%PORTDOCS%%%%DOCSDIR%%/mednafen.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%