aboutsummaryrefslogtreecommitdiff
path: root/emulators/mgba
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2022-10-12 09:59:02 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2022-10-12 10:15:38 +0000
commit2729cb84b7af5d19933d8609d6a1a69ba119d521 (patch)
treeffa56457858e230516a7a99e7ad50bf91b04387d /emulators/mgba
parentfb91445edeab0e0d2e6273600ed604da50fb2ee8 (diff)
downloadports-2729cb84b7af5d19933d8609d6a1a69ba119d521.tar.gz
ports-2729cb84b7af5d19933d8609d6a1a69ba119d521.zip
emulators/mgba: update to 0.10.0
Features: - Preliminary Lua scripting support - Presets for Game Boy palettes - Add Super Game Boy palettes for original Game Boy games - Tool for converting scanned pictures of e-Reader cards to raw dotcode data - Options for muting when inactive, minimized, or for different players in multiplayer - Cheat code support in homebrew ports - Acclerometer and gyro support for controllers on PC - Support for combo "Super Game Boy Color" SGB + GBC ROM hacks - Improved support for HuC-3 mapper, including RTC - Support for 64 kiB SRAM saves used in some bootlegs - Discord Rich Presence now supports time elapsed - Additional scaling shaders - Support for GameShark Advance SP (.gsv) save file importing - Support for multiple saves per game using .sa2, .sa3, etc. - Support for GBX format Game Boy ROMs - New unlicensed GB mappers: NT (newer type), Sachen (MMC1, MMC2) Emulation fixes: - ARM7: Fix unsigned multiply timing - GB: Copy logo from ROM if not running the BIOS intro (fixes mgba.io/i/2378) - GB: Fix HALT breaking M-cycle alignment (fixes mgba.io/i/250) - GB Audio: Fix channel 1/2 reseting edge cases (fixes mgba.io/i/1925) - GB Audio: Properly apply per-model audio differences - GB Audio: Revamp channel rendering - GB Audio: Fix APU re-enable timing glitch - GB I/O: Fix writing to WAVE RAM behavior (fixes mgba.io/i/1334) - GB MBC: Fix edge case with Pocket Cam register accesses (fixes mgba.io/i/2557) - GB Memory: Add cursory cartridge open bus emulation (fixes mgba.io/i/2032) - GB Serialize: Fix loading MBC1 states that affect bank 0 (fixes mgba.io/i/2402) - GB SIO: Fix bidirectional transfer starting (fixes mgba.io/i/2290) - GB Video: Draw SGB border pieces that overlap GB graphics (fixes mgba.io/i/1339) - GBA: Improve timing when not booting from BIOS - GBA: Fix expected entry point for multiboot ELFs (fixes mgba.io/i/2450) - GBA: Fix booting multiboot ROMs with no JOY entrypoint - GBA: Fix 1 MiB ROM mirroring to only mirror 4 times - GBA Audio: Adjust PSG sampling rate with SOUNDBIAS - GBA Audio: Sample FIFOs at SOUNDBIAS-set frequency - GBA BIOS: Work around IRQ handling hiccup in Mario & Luigi (fixes mgba.io/i/1059) - GBA BIOS: Initial HLE timing estimation of UnLz77 functions (fixes mgba.io/i/2141) - GBA DMA: Fix DMA source direction bits being cleared (fixes mgba.io/i/2410) - GBA I/O: Redo internal key input, enabling edge-based key IRQs - GBA I/O: Disable open bus behavior on invalid register 06A - GBA Memory: Fix misaligned 32-bit I/O loads (fixes mgba.io/i/2307) - GBA Video: Fix OpenGL rendering on M1 Macs - GBA Video: Ignore horizontally off-screen sprite timing (fixes mgba.io/i/2391) - GBA Video: Fix Hblank timing (fixes mgba.io/i/2131, mgba.io/i/2310) - GBA Video: Fix rare crash in modes 3-5 - GBA Video: Fix sprites with mid-frame palette changes in GL (fixes mgba.io/i/2476) - GBA Video: Fix OBJ tile wrapping with 2D char mapping (fixes mgba.io/i/2443) - GBA Video: Fix horizontal lines in GL when charbase is changed (fixes mgba.io/i/1631) - GBA Video: Fix sprite layer priority updating in GL Other fixes: - ARM: Disassemble Thumb mov pseudo-instruction properly - ARM: Disassemble ARM asr/lsr #32 properly - ARM: Disassemble ARM movs properly - Core: Don't attempt to restore rewind diffs past start of rewind - Core: Fix the runloop resuming after a game has crashed (fixes mgba.io/i/2451) - Core: Fix crash if library can't be opened - Debugger: Fix crash with extremely long CLI strings - Debugger: Fix multiple conditional watchpoints at the same address - FFmpeg: Fix crash when encoding audio with some containers - FFmpeg: Fix GIF recording (fixes mgba.io/i/2393) - GB: Fix temporary saves - GB: Fix replacing the ROM crashing when accessing ROM base - GB: Don't try to map a 0-byte SRAM (fixes mgba.io/i/2668) - GB, GBA: Save writeback-pending masked saves on unload (fixes mgba.io/i/2396) - mGUI: Fix FPS counter after closing menu - Qt: Fix some hangs when using the debugger console - Qt: Fix crash when clicking past last tile in viewer - Qt: Fix preloading for ROM replacing - Qt: Fix screen not displaying on Wayland (fixes mgba.io/i/2190) - Qt: Fix crash when selecting 256-color sprite in sprite view - Qt: Fix coloration of swatches on styles with distinct frame backgrounds - VFS: Failed file mapping should return NULL on POSIX Misc: - Core: Suspend runloop when a core crashes - Core: Add wallclock offset RTC type - Debugger: Save and restore CLI history - Debugger: GDB now works while the game is paused - Debugger: Add command to load external symbol file (fixes mgba.io/i/2480) - FFmpeg: Support dynamic audio sample rate - GB: Support CGB0 boot ROM loading - GB Audio: Increase sample rate - GB MBC: Filter out MBC errors when cartridge is yanked (fixes mgba.io/i/2488) - GB MBC: Partially implement TAMA5 RTC - GB Video: Add default SGB border - GBA: Automatically skip BIOS if ROM has invalid logo - GBA: Refine multiboot detection (fixes mgba.io/i/2192) - GBA Cheats: Implement "never" type codes (closes mgba.io/i/915) - GBA DMA: Enhanced logging (closes mgba.io/i/2454) - GBA Memory: Implement adjustable EWRAM waitstates (closes mgba.io/i/1276) - GBA Savedata: Store RTC data in savegames (closes mgba.io/i/240) - GBA Video: Implement layer placement for OpenGL renderer (fixes mgba.io/i/1962) - GBA Video: Fix highlighting for sprites with mid-frame palette changes - mGUI: Add margin to right-aligned menu text (fixes mgba.io/i/871) - mGUI: Autosave less frequently when fast-forwarding - Qt: Rearrange menus some - Qt: Clean up cheats dialog - Qt: Only set default controller bindings if loading fails (fixes mgba.io/i/799) - Qt: Save converter now supports importing GameShark Advance saves - Qt: Save positions of multiplayer windows (closes mgba.io/i/2128) - Qt: Add optional frame counter to OSD (closes mgba.io/i/1728) - Qt: Add optional emulation-related information on reset (closes mgba.io/i/1780) - Qt: Add QOpenGLWidget cross-thread codepath for macOS (fixes mgba.io/i/1754) - Qt: Enable -b for Boot BIOS menu option (fixes mgba.io/i/2074) - Qt: Add tile range selection to tile viewer (closes mgba.io/i/2455) - Qt: Show warning if XQ audio is toggled while loaded (fixes mgba.io/i/2295) - Qt: Add e-Card passing to the command line (closes mgba.io/i/2474) - Qt: Boot both a multiboot image and ROM with CLI args (closes mgba.io/i/1941) - Qt: Improve cheat parsing (fixes mgba.io/i/2297) - Qt: Change lossless setting to use WavPack audio - Qt: Use FFmpeg to convert additional camera formats, if available - Qt: Resume crashed game when loading a save state - Qt: Include cheats in bug report - SDL: Support exposing an axis directly as the gyro value (closes mgba.io/i/2531) - Windows: Attach to console if present - VFS: Early return NULL if attempting to map 0 bytes from a file - Vita: Add bilinear filtering option (closes mgba.io/i/344)
Diffstat (limited to 'emulators/mgba')
-rw-r--r--emulators/mgba/Makefile2
-rw-r--r--emulators/mgba/distinfo6
-rw-r--r--emulators/mgba/pkg-plist54
3 files changed, 41 insertions, 21 deletions
diff --git a/emulators/mgba/Makefile b/emulators/mgba/Makefile
index 92645f796b8a..3d1ad7a499df 100644
--- a/emulators/mgba/Makefile
+++ b/emulators/mgba/Makefile
@@ -1,5 +1,5 @@
PORTNAME= mgba
-DISTVERSION= 0.9.3
+DISTVERSION= 0.10.0
CATEGORIES= emulators
MAINTAINER= pkubaj@FreeBSD.org
diff --git a/emulators/mgba/distinfo b/emulators/mgba/distinfo
index 85056f07dde0..ee5c4e0317a8 100644
--- a/emulators/mgba/distinfo
+++ b/emulators/mgba/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1641449053
-SHA256 (mgba-emu-mgba-0.9.3_GH0.tar.gz) = 692ff0ac50e18380df0ff3ee83071f9926715200d0dceedd9d16a028a59537a0
-SIZE (mgba-emu-mgba-0.9.3_GH0.tar.gz) = 12763090
+TIMESTAMP = 1665554331
+SHA256 (mgba-emu-mgba-0.10.0_GH0.tar.gz) = e2d66d9ce7c51b1ef3b339b04e871287bf166f6a1d7125ef112dbf53ab8bbd48
+SIZE (mgba-emu-mgba-0.10.0_GH0.tar.gz) = 14302653
diff --git a/emulators/mgba/pkg-plist b/emulators/mgba/pkg-plist
index 796f69e91f46..2f52a1a65fc2 100644
--- a/emulators/mgba/pkg-plist
+++ b/emulators/mgba/pkg-plist
@@ -3,6 +3,7 @@ bin/mgba
include/mgba-util/circle-buffer.h
include/mgba-util/common.h
include/mgba-util/configuration.h
+include/mgba-util/convolve.h
include/mgba-util/crc32.h
include/mgba-util/dllexports.h
include/mgba-util/elf-read.h
@@ -14,6 +15,7 @@ include/mgba-util/gui/font-metrics.h
include/mgba-util/gui/font.h
include/mgba-util/gui/menu.h
include/mgba-util/hash.h
+include/mgba-util/macros.h
include/mgba-util/math.h
include/mgba-util/memory.h
include/mgba-util/patch.h
@@ -63,6 +65,7 @@ include/mgba/core/version.h
include/mgba/debugger/debugger.h
include/mgba/feature/commandline.h
include/mgba/feature/thread-proxy.h
+include/mgba/feature/updater.h
include/mgba/feature/video-logger.h
include/mgba/flags.h
include/mgba/gb/core.h
@@ -87,6 +90,7 @@ include/mgba/internal/debugger/gdb-stub.h
include/mgba/internal/debugger/parser.h
include/mgba/internal/debugger/stack-trace.h
include/mgba/internal/debugger/symbols.h
+include/mgba/internal/defines.h
include/mgba/internal/gb/audio.h
include/mgba/internal/gb/cheats.h
include/mgba/internal/gb/debugger/debugger.h
@@ -109,15 +113,17 @@ include/mgba/internal/gb/timer.h
include/mgba/internal/gb/video.h
include/mgba/internal/gba/audio.h
include/mgba/internal/gba/bios.h
+include/mgba/internal/gba/cart/ereader.h
+include/mgba/internal/gba/cart/gpio.h
+include/mgba/internal/gba/cart/matrix.h
+include/mgba/internal/gba/cart/vfame.h
include/mgba/internal/gba/cheats.h
include/mgba/internal/gba/dma.h
include/mgba/internal/gba/extra/audio-mixer.h
include/mgba/internal/gba/extra/cli.h
include/mgba/internal/gba/gba.h
-include/mgba/internal/gba/hardware.h
include/mgba/internal/gba/input.h
include/mgba/internal/gba/io.h
-include/mgba/internal/gba/matrix.h
include/mgba/internal/gba/memory.h
include/mgba/internal/gba/overrides.h
include/mgba/internal/gba/renderers/cache-set.h
@@ -130,10 +136,12 @@ include/mgba/internal/gba/serialize.h
include/mgba/internal/gba/sharkport.h
include/mgba/internal/gba/sio.h
include/mgba/internal/gba/sio/dolphin.h
+include/mgba/internal/gba/sio/gbp.h
include/mgba/internal/gba/sio/lockstep.h
include/mgba/internal/gba/timer.h
-include/mgba/internal/gba/vfame.h
include/mgba/internal/gba/video.h
+include/mgba/internal/script/lua.h
+include/mgba/internal/script/socket.h
include/mgba/internal/sm83/debugger/cli-debugger.h
include/mgba/internal/sm83/debugger/debugger.h
include/mgba/internal/sm83/debugger/memory-debugger.h
@@ -141,13 +149,14 @@ include/mgba/internal/sm83/decoder.h
include/mgba/internal/sm83/emitter-sm83.h
include/mgba/internal/sm83/isa-sm83.h
include/mgba/internal/sm83/sm83.h
+include/mgba/script/context.h
+include/mgba/script/macros.h
+include/mgba/script/types.h
lib/libmgba.so
-lib/libmgba.so.0.9
-lib/libmgba.so.0.9.3
+lib/libmgba.so.0.10
+lib/libmgba.so.0.10.0
%%LIBRETRO%%lib/libretro/mgba_libretro.so
-%%QT5%%share/man/man6/mgba-qt.6.gz
-share/man/man6/mgba.6.gz
-%%QT5%%share/applications/mgba-qt.desktop
+%%QT5%%share/applications/io.mgba.mGBA.desktop
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/LICENSE
%%PORTDOCS%%%%DOCSDIR%%/README.md
@@ -156,16 +165,21 @@ share/man/man6/mgba.6.gz
%%PORTDOCS%%%%DOCSDIR%%/README_ZH_CN.md
%%PORTDOCS%%%%DOCSDIR%%/licenses/blip_buf.txt
%%PORTDOCS%%%%DOCSDIR%%/licenses/inih.txt
-share/icons/hicolor/128x128/apps/mgba.png
-share/icons/hicolor/16x16/apps/mgba.png
-share/icons/hicolor/24x24/apps/mgba.png
-share/icons/hicolor/256x256/apps/mgba.png
-share/icons/hicolor/32x32/apps/mgba.png
-share/icons/hicolor/48x48/apps/mgba.png
-share/icons/hicolor/512x512/apps/mgba.png
-share/icons/hicolor/64x64/apps/mgba.png
-share/icons/hicolor/96x96/apps/mgba.png
+share/icons/hicolor/128x128/apps/io.mgba.mGBA.png
+share/icons/hicolor/16x16/apps/io.mgba.mGBA.png
+share/icons/hicolor/24x24/apps/io.mgba.mGBA.png
+share/icons/hicolor/256x256/apps/io.mgba.mGBA.png
+share/icons/hicolor/32x32/apps/io.mgba.mGBA.png
+share/icons/hicolor/48x48/apps/io.mgba.mGBA.png
+share/icons/hicolor/512x512/apps/io.mgba.mGBA.png
+share/icons/hicolor/64x64/apps/io.mgba.mGBA.png
+share/icons/hicolor/96x96/apps/io.mgba.mGBA.png
+%%QT5%%share/man/man6/mgba-qt.6.gz
+share/man/man6/mgba.6.gz
%%QT5%%%%DATADIR%%/nointro.dat
+%%QT5%%%%DATADIR%%/scripts/pokemon.lua
+%%QT5%%%%DATADIR%%/scripts/socketserver.lua
+%%QT5%%%%DATADIR%%/scripts/sockettest.lua
%%QT5%%%%DATADIR%%/shaders/agb001.shader/agb001.fs
%%QT5%%%%DATADIR%%/shaders/agb001.shader/manifest.ini
%%QT5%%%%DATADIR%%/shaders/ags001.shader/ags001-light.fs
@@ -180,10 +194,16 @@ share/icons/hicolor/96x96/apps/mgba.png
%%QT5%%%%DATADIR%%/shaders/motion_blur.shader/manifest.ini
%%QT5%%%%DATADIR%%/shaders/motion_blur.shader/motion_blur.fs
%%QT5%%%%DATADIR%%/shaders/pixelate.shader/manifest.ini
+%%QT5%%%%DATADIR%%/shaders/scale2x.shader/manifest.ini
+%%QT5%%%%DATADIR%%/shaders/scale2x.shader/scale2x.fs
+%%QT5%%%%DATADIR%%/shaders/scale4x.shader/manifest.ini
+%%QT5%%%%DATADIR%%/shaders/scale4x.shader/scale4x.fs
%%QT5%%%%DATADIR%%/shaders/scanlines.shader/manifest.ini
%%QT5%%%%DATADIR%%/shaders/scanlines.shader/scanlines.fs
%%QT5%%%%DATADIR%%/shaders/soften.shader/manifest.ini
%%QT5%%%%DATADIR%%/shaders/soften.shader/soften.fs
+%%QT5%%%%DATADIR%%/shaders/tv-mode.shader/manifest.ini
+%%QT5%%%%DATADIR%%/shaders/tv-mode.shader/tv.fs
%%QT5%%%%DATADIR%%/shaders/vba_pixelate.shader/manifest.ini
%%QT5%%%%DATADIR%%/shaders/vba_pixelate.shader/vba_pixelate.fs
%%QT5%%%%DATADIR%%/shaders/vignette.shader/manifest.ini