aboutsummaryrefslogtreecommitdiff
path: root/emulators/mtools
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2004-10-12 12:35:37 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2004-10-12 12:35:37 +0000
commit42b1f6af412667bc4bca50da73f39bb0c69c97a0 (patch)
tree3fccae90407d0e19c48ed60eea39d3737b956cac /emulators/mtools
parentad54e7379b4db6ff4cebfe0fdbe1a11c1bcc60b3 (diff)
downloadports-42b1f6af412667bc4bca50da73f39bb0c69c97a0.tar.gz
ports-42b1f6af412667bc4bca50da73f39bb0c69c97a0.zip
Update default devices names.
Submitted by: joerg
Notes
Notes: svn path=/head/; revision=118989
Diffstat (limited to 'emulators/mtools')
-rw-r--r--emulators/mtools/Makefile2
-rw-r--r--emulators/mtools/files/patch-252
2 files changed, 27 insertions, 27 deletions
diff --git a/emulators/mtools/Makefile b/emulators/mtools/Makefile
index 316b58938c5e..bbb160f2b5a9 100644
--- a/emulators/mtools/Makefile
+++ b/emulators/mtools/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mtools
PORTVERSION= 3.9.8
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.tux.org/pub/knaff/mtools/ \
http://mtools.linux.lu/
diff --git a/emulators/mtools/files/patch-2 b/emulators/mtools/files/patch-2
index 51c3804452ce..215f92ef082e 100644
--- a/emulators/mtools/files/patch-2
+++ b/emulators/mtools/files/patch-2
@@ -1,6 +1,6 @@
---- mtools.conf.orig Sun Jan 4 10:29:32 1998
-+++ mtools.conf Mon Apr 9 01:14:50 2001
-@@ -1,6 +1,84 @@
+--- mtools.conf.orig Sun May 20 20:18:12 2001
++++ mtools.conf Thu Oct 7 22:14:36 2004
+@@ -1,6 +1,67 @@
# Example mtools.conf files. Uncomment the lines which correspond to
# your architecture and comment out the "SAMPLE FILE" line below
-SAMPLE FILE
@@ -22,7 +22,7 @@
+# Floppy disks. Here, A: and B: use automatic size detection.
+#
+# Example: To prepare drive A: for use as a 1.44M floppy on FreeBSD:
-+# [1] low level format with ......... fdformat /dev/fd0.1440
++# [1] low level format with ......... fdformat -f 1440 /dev/fd0
+# [2] write a file system with ...... newfs_msdos -f 1440 /dev/fd0
+# [3] then use mcopy/mdir etc. in the usual way.
+#
@@ -33,28 +33,11 @@
+drive a: file="/dev/fd0"
+drive b: file="/dev/fd1"
+
-+# Drive T: is a 1.72M floppy format with 82 cylinders, double sided (2 heads),
-+# and 21 sectors of size 512 bytes per track. It uses the same
-+# floppy disk drive (fd0) as drive A: above.
++# FreeBSD automatically detects a number of common floppy densities, like
++# 720 KB and 1440 KB MS-DOS formatted media.
+#
-+# Example: To prepare and use a 1.72M floppy on FreeBSD:
-+# [1] low level format with ......... fdformat /dev/fd0.1720
-+# [2] write a file system with ...... mformat -t 82 -h 2 -n 21 t:
-+# [3] then use mcopy/mdir etc. in the usual way.
-+#
-+# The above note on access permissions applies to /dev/fd0.1720 as well.
-+drive t: file="/dev/fd0.1720"
-+
-+# Drive S: is a 720K floppy format with 80 cylinders, double sided (2 heads),
-+# and 43 sectors of size 256 bytes per track. It uses the same
-+# floppy disk drive (fd0) as drive A: above.
-+#
-+# Example: To prepare and use a 720K floppy on FreeBSD:
-+# [1] low level format with ......... fdformat /dev/fd0.720
-+# [2] write a file system with ...... newfs_msdos -f 720 /dev/fd0
-+# [3] then use mcopy/mdir etc. in the usual way.
-+#
-+drive s: file="/dev/fd0.720"
++# To change the density of FreeBSD floppy devices to something unusual,
++# use fdcontrol(8).
+
+# LS120 (ATAPI) floppy disk (extra parameters allow easy mformat)
+#
@@ -86,9 +69,26 @@
# # Linux floppy drives
# drive a: file="/dev/fd0" exclusive
-@@ -61,4 +139,4 @@
+@@ -61,4 +122,4 @@
# # uncomment the following line to display all file names in lower
# # case by default
-# mtools_lower_case=1
+mtools_lower_case=1
+--- devices.c.orig Thu Oct 7 22:12:00 2004
++++ devices.c Thu Oct 7 22:16:46 2004
+@@ -790,10 +790,10 @@
+ #ifdef OS_freebsd
+ #define predefined_devices
+ struct device devices[] = {
+- {"/dev/fd0.1440", 'A', FHD312},
+- {"/dev/fd0.720", 'A', FDD312},
+- {"/dev/fd1.1200", 'B', MHD514},
+- {"/dev/sd0s1", 'C', GENHD},
++ {"/dev/fd0", 'A', FHD312},
++ {"/dev/fd0", 'A', FDD312},
++ {"/dev/fd1", 'B', MHD514},
++ {"/dev/da0s1", 'C', GENHD},
+ REMOTE
+ };
+ #endif /* __FreeBSD__ */