aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-core/files
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-01-03 17:06:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-01-03 17:06:49 +0000
commit32d56ae68ad7efb4b83498c52a7f820e54887b87 (patch)
tree0c4d0c1f381f4e3e76b7e77408205f35afe358fa /emulators/mupen64plus-core/files
parent83e003bfd421cc4ecbb8824e54e6e3e53f32f8c4 (diff)
downloadports-32d56ae68ad7efb4b83498c52a7f820e54887b87.tar.gz
ports-32d56ae68ad7efb4b83498c52a7f820e54887b87.zip
Assume "pkg-config zlib" works after 9.x reached EOL
Many ports passed ZLIB_CFLAGS="-I/usr/include" ZLIB_LIBS="-L/usr/lib -lz" which is unsafe at least with lang/gcc* that override some system headers and have newer libgcc_s.so that our old version in base may not be forward-compatible with.
Notes
Notes: svn path=/head/; revision=430483
Diffstat (limited to 'emulators/mupen64plus-core/files')
-rw-r--r--emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile26
1 files changed, 0 insertions, 26 deletions
diff --git a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile b/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
deleted file mode 100644
index 04a8ee08832f..000000000000
--- a/emulators/mupen64plus-core/files/patch-source_mupen64plus-core_projects_unix_Makefile
+++ /dev/null
@@ -1,26 +0,0 @@
---- source/mupen64plus-core/projects/unix/Makefile 2015-04-26 17:42:49.000000000 -0500
-+++ source/mupen64plus-core/projects/unix/Makefile 2015-06-12 17:54:03.000000000 -0500
-@@ -227,6 +227,10 @@
- ZLIB_LDLIBS += -lz
- endif
-
-+ifeq ($(OS), FREEBSD) # use system zlib on FreeBSD
-+ ZLIB_LDLIBS += -lz
-+endif
-+
- ifeq ($(origin ZLIB_CFLAGS) $(origin ZLIB_LDLIBS), undefined undefined)
- ifeq ($(shell $(PKG_CONFIG) --modversion zlib 2>/dev/null),)
- $(error No zlib development libraries found!)
-@@ -247,6 +251,12 @@
- CFLAGS += $(LIBPNG_CFLAGS)
- LDLIBS += $(LIBPNG_LDLIBS)
-
-+ifeq ($(OS), FREEBSD)
-+ SDL_CFLAGS += $(shell $(SDL2_CONFIG) --cflags)
-+ SDL_LDLIBS += $(shell $(SDL2_CONFIG) --libs)
-+endif
-+
-+
- # test for presence of SDL
- ifeq ($(origin SDL_CFLAGS) $(origin SDL_LDLIBS), undefined undefined)
- SDL_CONFIG = $(CROSS_COMPILE)sdl2-config