aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-qt
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-06-16 04:11:43 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-06-16 04:11:43 +0000
commitd5f6d47742fc73d99c15d6b78d1b9c9da560f521 (patch)
treef309df34bd84117b9590b0ea0ac5df6c330d5ed3 /emulators/mupen64plus-qt
parent9e32c44f29240cde11efd8e5784efaeeeee41c54 (diff)
downloadports-d5f6d47742fc73d99c15d6b78d1b9c9da560f521.tar.gz
ports-d5f6d47742fc73d99c15d6b78d1b9c9da560f521.zip
* Add mupen64plus-qt 1.10, basic launcher for Mupen64Plus.
Mupen64Plus-Qt is a basic launcher for the mupen64plus-ui-console frontend. It was adapted from CEN64-Qt to work with Mupen64Plus. See the README at https://www.github.com/dh4/mupen64plus-qt for a detailed description of its features and usage. WWW: https://www.github.com/dh4/mupen64plus-qt PR: 203642 Sumitted by: Dan <dan465@mail.com> (maintainer) Reviewed by: matthew (mentor) Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D11198
Notes
Notes: svn path=/head/; revision=443667
Diffstat (limited to 'emulators/mupen64plus-qt')
-rw-r--r--emulators/mupen64plus-qt/Makefile41
-rw-r--r--emulators/mupen64plus-qt/distinfo3
-rw-r--r--emulators/mupen64plus-qt/pkg-descr7
3 files changed, 51 insertions, 0 deletions
diff --git a/emulators/mupen64plus-qt/Makefile b/emulators/mupen64plus-qt/Makefile
new file mode 100644
index 000000000000..9bbfb751b514
--- /dev/null
+++ b/emulators/mupen64plus-qt/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= mupen64plus-qt
+PORTVERSION= 1.10
+CATEGORIES= emulators
+
+MAINTAINER= dan@hasting.info
+COMMENT= Basic launcher for Mupen64Plus
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libquazip.so:archivers/quazip
+RUN_DEPENDS= mupen64plus:emulators/mupen64plus
+
+USES= qmake
+USE_QT4= corelib gui moc_build network rcc_build sql sql-sqlite3_run uic_build xml
+
+USE_GITHUB= yes
+GH_ACCOUNT= dh4
+
+PORTDOCS= README.md
+
+PLIST_FILES= bin/mupen64plus-qt \
+ man/man6/mupen64plus-qt.6.gz \
+ share/applications/mupen64plus-qt.desktop \
+ share/pixmaps/mupen64plus-qt.png
+
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= DOCS
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/resources/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/resources/images/mupen64plus.png ${STAGEDIR}${PREFIX}/share/pixmaps/${PORTNAME}.png
+ ${INSTALL_MAN} ${WRKSRC}/resources/${PORTNAME}.6 ${STAGEDIR}${MANPREFIX}/man/man6
+
+do-install-DOCS-on:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
+
+.include <bsd.port.mk>
diff --git a/emulators/mupen64plus-qt/distinfo b/emulators/mupen64plus-qt/distinfo
new file mode 100644
index 000000000000..3f936fe96b3c
--- /dev/null
+++ b/emulators/mupen64plus-qt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1497469597
+SHA256 (dh4-mupen64plus-qt-1.10_GH0.tar.gz) = 526fa06e481ba4db84024a72535fc0c40dc06332bdb2985e90023948cbabac83
+SIZE (dh4-mupen64plus-qt-1.10_GH0.tar.gz) = 120137
diff --git a/emulators/mupen64plus-qt/pkg-descr b/emulators/mupen64plus-qt/pkg-descr
new file mode 100644
index 000000000000..ca8fb36f92d0
--- /dev/null
+++ b/emulators/mupen64plus-qt/pkg-descr
@@ -0,0 +1,7 @@
+Mupen64Plus-Qt is a basic launcher for the mupen64plus-ui-console frontend. It
+was adapted from CEN64-Qt to work with Mupen64Plus.
+
+See the README at https://www.github.com/dh4/mupen64plus-qt for a detailed
+description of its features and usage.
+
+WWW: https://www.github.com/dh4/mupen64plus-qt