aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-video-glide64
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-24 12:02:35 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-24 12:52:37 +0000
commit535e95b34caa282ca070c65f3b7df4056eccb77f (patch)
treed29bd67717f9d8883f3be1a332d4a87b6bd9e1a7 /emulators/mupen64plus-video-glide64
parent0b6102ed18e864ce2a58f332dca096db34f82dce (diff)
downloadports-535e95b34caa282ca070c65f3b7df4056eccb77f.tar.gz
ports-535e95b34caa282ca070c65f3b7df4056eccb77f.zip
emulators/mupen64plus-video-glide64: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'emulators/mupen64plus-video-glide64')
-rw-r--r--emulators/mupen64plus-video-glide64/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/emulators/mupen64plus-video-glide64/Makefile b/emulators/mupen64plus-video-glide64/Makefile
index b192f0b7c25f..62e87098597a 100644
--- a/emulators/mupen64plus-video-glide64/Makefile
+++ b/emulators/mupen64plus-video-glide64/Makefile
@@ -6,20 +6,21 @@ COMMENT= Glide64 video plugin for Mupen64Plus
LIB_DEPENDS= libmupen64plus.so.2:emulators/mupen64plus-core
-USES+= gl sdl
+USES+= gl localbase:ldflags sdl
+USE_CXXSTD= c++14
USE_GL= gl
USE_SDL= sdl2
-MASTERDIR= ${.CURDIR}/../mupen64plus-core
-
-OPTIONS_DEFINE= #
+CFLAGS+= -I${LOCALBASE}/include/${PORTNAME}
-CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
-LDFLAGS+= -L${LOCALBASE}/lib
-
-DISTINFO_FILE= ${.CURDIR}/distinfo
+MASTERDIR= ${.CURDIR}/../mupen64plus-core
EXTRACT_AFTER_ARGS= #
+
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
WRKSRC= ${WRKDIR}
+DISTINFO_FILE= ${.CURDIR}/distinfo
+
+OPTIONS_DEFINE= #
+
.include "${MASTERDIR}/Makefile"