aboutsummaryrefslogtreecommitdiff
path: root/emulators/open-vm-tools
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2018-02-25 15:35:07 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2018-02-25 15:35:07 +0000
commit2715780414c46d9af9a95d090bf543f96763bb78 (patch)
treed5644f57216766aac09a3dd0ed1f1e5748c1e375 /emulators/open-vm-tools
parentde0cd10fe2df46eaebd18405a6924031137aaa54 (diff)
downloadports-2715780414c46d9af9a95d090bf543f96763bb78.tar.gz
ports-2715780414c46d9af9a95d090bf543f96763bb78.zip
Backport a fix from upstream that broke UFS
Reported by: dim Obtained from: VMware
Notes
Notes: svn path=/head/; revision=462960
Diffstat (limited to 'emulators/open-vm-tools')
-rw-r--r--emulators/open-vm-tools/Makefile2
-rw-r--r--emulators/open-vm-tools/files/patch-lib_wiper_wiperPosix.c10
2 files changed, 11 insertions, 1 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 0a95daa073e2..85b8198febd0 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -4,7 +4,7 @@
PORTNAME= open-vm-tools
PORTVERSION= ${RELEASE_VER}
DISTVERSIONPREFIX= stable-
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= emulators
diff --git a/emulators/open-vm-tools/files/patch-lib_wiper_wiperPosix.c b/emulators/open-vm-tools/files/patch-lib_wiper_wiperPosix.c
new file mode 100644
index 000000000000..487eaadde1d4
--- /dev/null
+++ b/emulators/open-vm-tools/files/patch-lib_wiper_wiperPosix.c
@@ -0,0 +1,10 @@
+--- lib/wiper/wiperPosix.c.orig 2018-02-24 17:51:48 UTC
++++ lib/wiper/wiperPosix.c
+@@ -143,6 +143,7 @@ static const PartitionInfo gKnownPartitions[] = {
+ { "ntfs", PARTITION_NTFS, NULL, TRUE },
+ { "pcfs", PARTITION_PCFS, NULL, TRUE },
+ { "reiserfs", PARTITION_REISERFS, NULL, TRUE },
++ { "ufs", PARTITION_UFS, NULL, TRUE },
+ { "vfat", PARTITION_FAT, NULL, TRUE },
+ { "zfs", PARTITION_ZFS, NULL, FALSE },
+ { "xfs", PARTITION_XFS, NULL, TRUE },