aboutsummaryrefslogtreecommitdiff
path: root/emulators/open-vm-tools
diff options
context:
space:
mode:
authorJosh Paetzel <jpaetzel@FreeBSD.org>2018-03-13 14:20:24 +0000
committerJosh Paetzel <jpaetzel@FreeBSD.org>2018-03-13 14:20:24 +0000
commit9caf09de924ad51e1af16d5c29d08fd20c77919b (patch)
tree31554831a1485b435e5abfa512da58abb8d077c8 /emulators/open-vm-tools
parent241359a3e1f4cc6dae6ef394a106a99919e9a757 (diff)
downloadports-9caf09de924ad51e1af16d5c29d08fd20c77919b.tar.gz
ports-9caf09de924ad51e1af16d5c29d08fd20c77919b.zip
Reintegrate accidentally removed patch
Along the way remove a patch that is no longer needed. Reported by: John Wolfe <jwolfe@vmware.com> Pointyhat: jpaetzel
Notes
Notes: svn path=/head/; revision=464378
Diffstat (limited to 'emulators/open-vm-tools')
-rw-r--r--emulators/open-vm-tools/Makefile2
-rw-r--r--emulators/open-vm-tools/files/patch-lib_hgfsServer_hgfsServerLinux.c15
-rw-r--r--emulators/open-vm-tools/files/patch-services_plugins_vix_vixTools.c33
3 files changed, 31 insertions, 19 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 948293642891..0c25bc0995c6 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -4,7 +4,7 @@
PORTNAME= open-vm-tools
PORTVERSION= ${RELEASE_VER}
DISTVERSIONPREFIX= stable-
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 2
CATEGORIES= emulators
diff --git a/emulators/open-vm-tools/files/patch-lib_hgfsServer_hgfsServerLinux.c b/emulators/open-vm-tools/files/patch-lib_hgfsServer_hgfsServerLinux.c
deleted file mode 100644
index 0bb2f96044d0..000000000000
--- a/emulators/open-vm-tools/files/patch-lib_hgfsServer_hgfsServerLinux.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- lib/hgfsServer/hgfsServerLinux.c.orig 2017-07-28 21:59:15 UTC
-+++ lib/hgfsServer/hgfsServerLinux.c
-@@ -178,6 +178,12 @@ getdents_linux(unsigned int fd,
- # endif
- }
- # define getdents getdents_linux
-+#elif defined(__FreeBSD__) && defined(__INO64)
-+#define getdents(fd, dirp, count) \
-+({ \
-+ off_t basep; \
-+ getdirentries(fd, dirp, count, &basep); \
-+})
- #elif defined(__FreeBSD__)
- #define getdents(fd, dirp, count) \
- ({ \
diff --git a/emulators/open-vm-tools/files/patch-services_plugins_vix_vixTools.c b/emulators/open-vm-tools/files/patch-services_plugins_vix_vixTools.c
index 0cfdbb7397e4..625c38af033a 100644
--- a/emulators/open-vm-tools/files/patch-services_plugins_vix_vixTools.c
+++ b/emulators/open-vm-tools/files/patch-services_plugins_vix_vixTools.c
@@ -1,6 +1,33 @@
---- services/plugins/vix/vixTools.c.orig 2018-02-24 17:50:37 UTC
+--- services/plugins/vix/vixTools.c.orig 2017-12-15 21:11:49 UTC
+++ services/plugins/vix/vixTools.c
-@@ -10135,7 +10135,7 @@ abort:
+@@ -52,6 +52,7 @@
+ #include <stdarg.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <limits.h>
+
+ #ifdef _WIN32
+ #include <WTypes.h>
+@@ -7330,7 +7331,7 @@ VixToolsRunScript(VixCommandRequestHeader *requestMsg,
+ goto abort;
+ }
+ }
+- for (var = 0; var <= 0xFFFFFFFF; var++) {
++ for (var = 0; ; var++) {
+ free(tempScriptFilePath);
+ tempScriptFilePath = Str_SafeAsprintf(NULL,
+ "%s"DIRSEPS"%s%d%s",
+@@ -7373,6 +7374,9 @@ VixToolsRunScript(VixCommandRequestHeader *requestMsg,
+ */
+ break;
+ }
++ if (var == INT_MAX) {
++ break;
++ }
+ }
+ if (fd < 0) {
+ /*
+@@ -10131,7 +10135,7 @@ abort:
struct passwd pwd;
struct passwd *ppwd = &pwd;
char *buffer = NULL; // a pool of memory for Posix_Getpwnam_r() to use.
@@ -9,7 +36,7 @@
/*
* For POSIX systems, look up the uid of 'username', and compare
-@@ -10148,9 +10148,15 @@ abort:
+@@ -10144,9 +10148,15 @@ abort:
* Multiply by 4 to compensate for the conversion to UTF-8 by
* the Posix_Getpwnam_r() wrapper.
*/