aboutsummaryrefslogtreecommitdiff
path: root/emulators/openmsx
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-12 10:18:21 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-12 10:18:21 +0000
commit7b00ecf4cd3d50566eec6ab9a37e9f0d4740b995 (patch)
tree3a1816ce4ce75ed555e3611c875fb021fb117db2 /emulators/openmsx
parente55dea6a7bb62d08ef9962be2137ed1e12ee5657 (diff)
downloadports-7b00ecf4cd3d50566eec6ab9a37e9f0d4740b995.tar.gz
ports-7b00ecf4cd3d50566eec6ab9a37e9f0d4740b995.zip
- Define LICENSE, place build-related MAKE_ARGS knob below USES/USE_* block
- Remove BROKEN on Tier-2 systems statement: it builds fine at least on PowerPC, which indicates that "uses i386-specific asm" reason is probably bogus everywhere else, and should be replaced with adequate BROKEN line even if it's indeed broken there. While here, convert to options helpers
Notes
Notes: svn path=/head/; revision=396739
Diffstat (limited to 'emulators/openmsx')
-rw-r--r--emulators/openmsx/Makefile28
1 files changed, 10 insertions, 18 deletions
diff --git a/emulators/openmsx/Makefile b/emulators/openmsx/Makefile
index 54bdfb172f61..91ad8da8571b 100644
--- a/emulators/openmsx/Makefile
+++ b/emulators/openmsx/Makefile
@@ -9,36 +9,34 @@ MASTER_SITES= SF
MAINTAINER= johans@FreeBSD.org
COMMENT= Open source MSX emulator
+LICENSE= GPLv2
+
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png \
libogg.so:${PORTSDIR}/audio/libogg \
libvorbis.so:${PORTSDIR}/audio/libvorbis \
libtheora.so:${PORTSDIR}/multimedia/libtheora \
libao.so:${PORTSDIR}/audio/libao
-MAKE_ARGS+= INSTALL_BINARY_DIR=${PREFIX}/bin \
- INSTALL_SHARE_DIR=${DATADIR} \
- INSTALL_DOC_DIR=${DOCSDIR} \
- OPENMSX_CXX=${CXX} \
- CXXFLAGS="${CXXFLAGS}"
-
MAKEFILE= GNUmakefile
USES= gmake python tcl
USE_GCC= yes
USE_GL= glew
USE_SDL= sdl ttf
+MAKE_ARGS= INSTALL_BINARY_DIR=${PREFIX}/bin \
+ INSTALL_SHARE_DIR=${DATADIR} \
+ INSTALL_DOC_DIR=${DOCSDIR} \
+ OPENMSX_CXX=${CXX} \
+ CXXFLAGS="${CXXFLAGS}"
+
PLIST_FILES= bin/openmsx
PORTDATA= *
PORTDOCS= *
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
-.if !${PORT_OPTIONS:MDOCS}
# Use dummy target rather than rewriting makefile
-MAKE_ARGS+= INSTALL_DOC_DIR=${WRKSRC}/dummy
-.endif
+DOCS_MAKE_ARGS_OFF= INSTALL_DOC_DIR=${WRKSRC}/dummy
post-patch:
@${REINPLACE_CMD} -e 's/{TCL_LIB_SPEC}/& $${TCL_LD_FLAGS}/' \
@@ -46,10 +44,4 @@ post-patch:
@${REINPLACE_CMD} -e '/^SYMLINK_FOR_BINARY/s/true/false/' \
${WRKSRC}/build/custom.mk
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not compile on ia64, powerpc, or sparc64: uses i386-specific asm
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>