aboutsummaryrefslogtreecommitdiff
path: root/emulators/pcsxr
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2011-06-24 09:33:58 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2011-06-24 09:33:58 +0000
commit6ab033ea12515d99483b09d1d8acb08b66ac0f5a (patch)
treedf57b8216a69b3f80e7c33a4b5296dd4fedfcdb5 /emulators/pcsxr
parent9a9d42d22e00b7e9ffe8f7c877852815efdb9cc3 (diff)
downloadports-6ab033ea12515d99483b09d1d8acb08b66ac0f5a.tar.gz
ports-6ab033ea12515d99483b09d1d8acb08b66ac0f5a.zip
- Fix build with clang
- Remove useless CPPFLAGS in CONFIGURE_ENV
Notes
Notes: svn path=/head/; revision=276186
Diffstat (limited to 'emulators/pcsxr')
-rw-r--r--emulators/pcsxr/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index c072aca7c740..d494da11aa97 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -31,7 +31,8 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+USE_CSTD= gnu89
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-opengl --enable-libcdio
USE_LDCONFIG= yes