aboutsummaryrefslogtreecommitdiff
path: root/emulators/pcsxr
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2011-11-03 13:32:58 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2011-11-03 13:32:58 +0000
commitb9b0e0b58c9ca629d15fbf89eeb0d872ef675008 (patch)
tree48da89890324b294e6fdcf1c59245a0b2c927b40 /emulators/pcsxr
parentb7d6b008a28f824404676334127a880b096d0891 (diff)
downloadports-b9b0e0b58c9ca629d15fbf89eeb0d872ef675008.tar.gz
ports-b9b0e0b58c9ca629d15fbf89eeb0d872ef675008.zip
- Fix dfbinimage2 CD handling (program identification)
- Swap LICENSE and *DEPENDS to make portlint happy
Notes
Notes: svn path=/head/; revision=284978
Diffstat (limited to 'emulators/pcsxr')
-rw-r--r--emulators/pcsxr/Makefile6
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfbinimage2-CDInterface.hpp12
-rw-r--r--emulators/pcsxr/files/patch-plugins-dfbinimage2-Utils.cpp11
3 files changed, 26 insertions, 3 deletions
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index 75aa67f0b238..af104fd8ae2f 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pcsxr
PORTVERSION= 1.9.92.r68256
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@@ -18,12 +18,12 @@ EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= martymac@FreeBSD.org
COMMENT= Playstation (PSX) emulator
+LICENSE= GPLv2
+
BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
cdio.12:${PORTSDIR}/sysutils/libcdio
-LICENSE= GPLv2
-
ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= yes
diff --git a/emulators/pcsxr/files/patch-plugins-dfbinimage2-CDInterface.hpp b/emulators/pcsxr/files/patch-plugins-dfbinimage2-CDInterface.hpp
new file mode 100644
index 000000000000..0e663bcf6535
--- /dev/null
+++ b/emulators/pcsxr/files/patch-plugins-dfbinimage2-CDInterface.hpp
@@ -0,0 +1,12 @@
+--- plugins/dfbinimage2/CDInterface.hpp.orig 2011-07-20 07:24:23.758738346 +0200
++++ plugins/dfbinimage2/CDInterface.hpp 2011-07-20 07:26:37.053050612 +0200
+@@ -46,7 +46,8 @@
+ // track info. fyi, tester is my testing/development program.
+ std::string programName = getProgramName();
+ if ( programName == "epsxe" || programName == "pcsx" ||
+- programName == "pcsx2" || programName == "tester" )
++ programName == "pcsx2" || programName == "tester"||
++ programName == "pcsxr" )
+ tdtnformat = fsmint;
+ else
+ tdtnformat = msfbcd;
diff --git a/emulators/pcsxr/files/patch-plugins-dfbinimage2-Utils.cpp b/emulators/pcsxr/files/patch-plugins-dfbinimage2-Utils.cpp
new file mode 100644
index 000000000000..b01304bb386b
--- /dev/null
+++ b/emulators/pcsxr/files/patch-plugins-dfbinimage2-Utils.cpp
@@ -0,0 +1,11 @@
+--- plugins/dfbinimage2/Utils.cpp.orig 2011-07-20 07:24:34.070495566 +0200
++++ plugins/dfbinimage2/Utils.cpp 2011-07-20 07:24:48.493222477 +0200
+@@ -124,7 +124,7 @@
+ #else
+ char* buf = getenv("_");
+ if (buf == NULL)
+- return "pcsx";
++ return "pcsxr";
+ #endif
+ else
+ toReturn = buf;