aboutsummaryrefslogtreecommitdiff
path: root/emulators/py-unicorn
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-12-19 23:07:25 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2016-12-19 23:07:25 +0000
commit04d13a03c861eaa8caa2ae588ff7b0df394b0a4c (patch)
treecd713f793f885311999f1dea6ce2291f4490650b /emulators/py-unicorn
parenta64e36a3a280c4734c787960d8e9ec8406b38278 (diff)
downloadports-04d13a03c861eaa8caa2ae588ff7b0df394b0a4c.tar.gz
ports-04d13a03c861eaa8caa2ae588ff7b0df394b0a4c.zip
New port: emulators/py-unicorn
Python bindings for Unicorn CPU emulator framework
Notes
Notes: svn path=/head/; revision=428964
Diffstat (limited to 'emulators/py-unicorn')
-rw-r--r--emulators/py-unicorn/Makefile27
-rw-r--r--emulators/py-unicorn/distinfo3
-rw-r--r--emulators/py-unicorn/files/patch-setup.py22
-rw-r--r--emulators/py-unicorn/pkg-descr3
4 files changed, 55 insertions, 0 deletions
diff --git a/emulators/py-unicorn/Makefile b/emulators/py-unicorn/Makefile
new file mode 100644
index 000000000000..2462a5a44b6b
--- /dev/null
+++ b/emulators/py-unicorn/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= unicorn
+PORTVERSION= 0.9
+CATEGORIES= emulators python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Python bindings for Unicorn CPU emulator framework
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libunicorn.so:emulators/unicorn
+
+USE_GITHUB= yes
+GH_ACCOUNT= unicorn-engine
+
+USES= python
+USE_PYTHON= distutils autoplist
+WRKSRC_SUBDIR= bindings/python
+
+do-test:
+ @(cd ${WRKSRC}; for sample in sample_*.py; do \
+ ${SETENV} ${TEST_ENV} ${PYTHON_CMD} $${sample}; \
+ done)
+
+.include <bsd.port.mk>
diff --git a/emulators/py-unicorn/distinfo b/emulators/py-unicorn/distinfo
new file mode 100644
index 000000000000..77d344f5d9b6
--- /dev/null
+++ b/emulators/py-unicorn/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481841704
+SHA256 (unicorn-engine-unicorn-0.9_GH0.tar.gz) = 1ca03b1c8f6360335567b528210713461e839d47c4eb7c676ba3aa4f72b8cf10
+SIZE (unicorn-engine-unicorn-0.9_GH0.tar.gz) = 2576109
diff --git a/emulators/py-unicorn/files/patch-setup.py b/emulators/py-unicorn/files/patch-setup.py
new file mode 100644
index 000000000000..3b24004f84da
--- /dev/null
+++ b/emulators/py-unicorn/files/patch-setup.py
@@ -0,0 +1,22 @@
+# Do not bundle libunicorn.so
+
+--- setup.py.orig 2015-10-15 16:22:04 UTC
++++ setup.py
+@@ -166,17 +166,4 @@ setup(
+ 'Programming Language :: Python :: 3',
+ ],
+ requires=['ctypes'],
+- cmdclass=dict(
+- build_clib=custom_build_clib,
+- sdist=custom_sdist,
+- ),
+-
+- libraries=[(
+- 'unicorn', dict(
+- package='unicorn',
+- sources=dummy_src()
+- ),
+- )],
+-
+- data_files=[(SITE_PACKAGES, SETUP_DATA_FILES)],
+ )
diff --git a/emulators/py-unicorn/pkg-descr b/emulators/py-unicorn/pkg-descr
new file mode 100644
index 000000000000..c0efe63017dc
--- /dev/null
+++ b/emulators/py-unicorn/pkg-descr
@@ -0,0 +1,3 @@
+Python bindings for Unicorn CPU emulator framework.
+
+WWW: http://www.unicorn-engine.org/