aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-cheri/Makefile
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2017-03-29 20:10:08 +0000
committerBrooks Davis <brooks@FreeBSD.org>2017-03-29 20:10:08 +0000
commit61e882d6eb5ed6a8791b4989d7e813c836d7d21e (patch)
tree49634484f2a56067561fd29c7f25db93b6ad599c /emulators/qemu-cheri/Makefile
parent8a36c9788a56b7e7474043fb6cb027d512f5255d (diff)
downloadports-61e882d6eb5ed6a8791b4989d7e813c836d7d21e.tar.gz
ports-61e882d6eb5ed6a8791b4989d7e813c836d7d21e.zip
Notes
Diffstat (limited to 'emulators/qemu-cheri/Makefile')
-rw-r--r--emulators/qemu-cheri/Makefile23
1 files changed, 20 insertions, 3 deletions
diff --git a/emulators/qemu-cheri/Makefile b/emulators/qemu-cheri/Makefile
index e74223324769..327be2586492 100644
--- a/emulators/qemu-cheri/Makefile
+++ b/emulators/qemu-cheri/Makefile
@@ -8,31 +8,48 @@ PKGNAMESUFFIX?= -cheri
MAINTAINER= brooks@FreeBSD.org
COMMENT?= QEMU emulator with CHERI CPU support
+# XXX: disabling gnutls doesn't work so depend on it to avoid breakage.
+LIB_DEPENDS= libgnutls.so:security/gnutls \
+ libnettle.so:security/nettle
+RUN_DEPENDS= qemu-system-i386:emulators/qemu
+
+LICENSE= GPLv2
+
USE_GITHUB= yes
GH_ACCOUNT= CTSRD-CHERI
GH_TAGNAME= ${QEMU_COMMIT}
HAS_CONFIGURE= yes
-USES= gmake libtool makeinfo pkgconfig python:2,build
+USES= gettext-runtime gmake libtool makeinfo pkgconfig python:2,build
USE_XORG= pixman
USE_GNOME+= glib20
#MAKE_ENV+= BSD_MAKE="${MAKE}"
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
-CONFLICTS_INSTALL= qemu-[0-9]* qemu-devel-[0-9]* qemu-sbruno-[0-9]*
-
.include "Makefile.snapshot"
CONFIGURE_ARGS+= \
--target-list=cheri-softmmu \
+ --disable-curl \
--disable-gtk \
+ --disable-libssh2 \
--disable-linux-user \
--disable-linux-aio \
--disable-kvm \
+ --disable-vnc-png \
+ --disable-sdl \
--disable-smartcard-nss \
--disable-vte \
--disable-xen \
--extra-cflags="-g ${EXTRA_CFLAGS}" \
--localstatedir=/var
+QEMU_SYSTEM_CHERI?= qemu-system${PKGNAMESUFFIX}
+PLIST= /dev/null
+PLIST_FILES= bin/${QEMU_SYSTEM_CHERI}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/cheri-softmmu/qemu-system-cheri \
+ ${STAGEDIR}${PREFIX}/bin/${QEMU_SYSTEM_CHERI}
+
.include <bsd.port.mk>