aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-cheri/Makefile
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2018-02-07 01:03:29 +0000
committerBrooks Davis <brooks@FreeBSD.org>2018-02-07 01:03:29 +0000
commitb070a6fbcbbcb62899982fd257a111ecf2c79623 (patch)
tree582dd05f627a4d6154d5b21d26f6bbdeea6a056d /emulators/qemu-cheri/Makefile
parentab3c499753b73a95bcad4ba97a761e4b71d53087 (diff)
downloadports-b070a6fbcbbcb62899982fd257a111ecf2c79623.tar.gz
ports-b070a6fbcbbcb62899982fd257a111ecf2c79623.zip
Notes
Diffstat (limited to 'emulators/qemu-cheri/Makefile')
-rw-r--r--emulators/qemu-cheri/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/emulators/qemu-cheri/Makefile b/emulators/qemu-cheri/Makefile
index 327be2586492..601c282e5842 100644
--- a/emulators/qemu-cheri/Makefile
+++ b/emulators/qemu-cheri/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qemu
PORTVERSION= 0.d${SNAPDATE}
CATEGORIES= emulators devel
-PKGNAMESUFFIX?= -cheri
+PKGNAMESUFFIX= -cheri
MAINTAINER= brooks@FreeBSD.org
COMMENT?= QEMU emulator with CHERI CPU support
@@ -20,16 +20,15 @@ GH_ACCOUNT= CTSRD-CHERI
GH_TAGNAME= ${QEMU_COMMIT}
HAS_CONFIGURE= yes
-USES= gettext-runtime gmake libtool makeinfo pkgconfig python:2,build
+USES= gettext-runtime gmake libtool makeinfo pkgconfig python:2.7,build
USE_XORG= pixman
USE_GNOME+= glib20
-#MAKE_ENV+= BSD_MAKE="${MAKE}"
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
.include "Makefile.snapshot"
CONFIGURE_ARGS+= \
- --target-list=cheri-softmmu \
+ --target-list=cheri128-softmmu,cheri128magic-softmmu,cheri256-softmmu \
--disable-curl \
--disable-gtk \
--disable-libssh2 \
@@ -38,7 +37,6 @@ CONFIGURE_ARGS+= \
--disable-kvm \
--disable-vnc-png \
--disable-sdl \
- --disable-smartcard-nss \
--disable-vte \
--disable-xen \
--extra-cflags="-g ${EXTRA_CFLAGS}" \
@@ -46,10 +44,14 @@ CONFIGURE_ARGS+= \
QEMU_SYSTEM_CHERI?= qemu-system${PKGNAMESUFFIX}
PLIST= /dev/null
-PLIST_FILES= bin/${QEMU_SYSTEM_CHERI}
+PLIST_FILES= bin/qemu-system-cheri128 \
+ bin/qemu-system-cheri128magic \
+ bin/qemu-system-cheri256
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cheri-softmmu/qemu-system-cheri \
- ${STAGEDIR}${PREFIX}/bin/${QEMU_SYSTEM_CHERI}
+ ${INSTALL_PROGRAM} ${WRKSRC}/cheri128-softmmu/qemu-system-cheri128 \
+ ${WRKSRC}/cheri128magic-softmmu/qemu-system-cheri128magic \
+ ${WRKSRC}/cheri256-softmmu/qemu-system-cheri256 \
+ ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>