aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-cheri
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2019-12-12 00:02:20 +0000
committerBrooks Davis <brooks@FreeBSD.org>2019-12-12 00:02:20 +0000
commit4c58611fb5416706f48d470888073db679780088 (patch)
tree67a3bec90064be57e677d95bae519d0d636c3ee4 /emulators/qemu-cheri
parent16e7c07459675b366a9c7a7c398100f6f806c7e3 (diff)
downloadports-4c58611fb5416706f48d470888073db679780088.tar.gz
ports-4c58611fb5416706f48d470888073db679780088.zip
Update to fresh qemu-cheri and llvm-cheri snapshots.
Notes
Notes: svn path=/head/; revision=519848
Diffstat (limited to 'emulators/qemu-cheri')
-rw-r--r--emulators/qemu-cheri/Makefile7
-rw-r--r--emulators/qemu-cheri/Makefile.snapshot5
-rw-r--r--emulators/qemu-cheri/distinfo8
-rw-r--r--emulators/qemu-cheri/files/gen-Makefile.snapshot.sh8
4 files changed, 17 insertions, 11 deletions
diff --git a/emulators/qemu-cheri/Makefile b/emulators/qemu-cheri/Makefile
index f9ee4eaa8f5b..d80adfece3e1 100644
--- a/emulators/qemu-cheri/Makefile
+++ b/emulators/qemu-cheri/Makefile
@@ -20,9 +20,9 @@ RUN_DEPENDS= qemu-system-i386:emulators/qemu
LICENSE= GPLv2
USE_GITHUB= yes
-GH_ACCOUNT= CTSRD-CHERI
-GH_TAGNAME= ${QEMU_COMMIT}
-GH_TUPLE= qemu:keycodemapdb:6b3d716:qemu/ui/keycodemapdb
+GH_TUPLE= CTSRD-CHERI:qemu:${QEMU_COMMIT} \
+ CTSRD-CHERI:libslirp:${LIBSLIRP_COMMIT}:libslirp/slirp \
+ qemu:keycodemapdb:6b3d716:qemu/ui/keycodemapdb \
HAS_CONFIGURE= yes
USES= compiler:c11 gettext-runtime gl gmake gnome libtool makeinfo pkgconfig \
@@ -41,7 +41,6 @@ CONFIGURE_ARGS+= \
--disable-curl \
--disable-git-update \
--disable-gtk \
- --disable-libssh2 \
--disable-linux-user \
--disable-linux-aio \
--disable-kvm \
diff --git a/emulators/qemu-cheri/Makefile.snapshot b/emulators/qemu-cheri/Makefile.snapshot
index ce52774e817a..3158b2ac671e 100644
--- a/emulators/qemu-cheri/Makefile.snapshot
+++ b/emulators/qemu-cheri/Makefile.snapshot
@@ -4,6 +4,7 @@
#
# Generated by: files/gen-Makefile.snapshot.sh.
#
-SNAPDATE= 20190831
+SNAPDATE= 20191209
-QEMU_COMMIT= cab2ad32531f0a1aa9cef9332169f7e2825a98c6
+QEMU_COMMIT= 74235a2879944724c88ad8b400170b8e2b0a6147
+LIBSLIRP_COMMIT= 6651ba26c4e94f64d6448a2db4991269ce553bd9
diff --git a/emulators/qemu-cheri/distinfo b/emulators/qemu-cheri/distinfo
index fdf94e760aae..07a2f43a8158 100644
--- a/emulators/qemu-cheri/distinfo
+++ b/emulators/qemu-cheri/distinfo
@@ -1,5 +1,7 @@
-TIMESTAMP = 1570639000
-SHA256 (CTSRD-CHERI-qemu-0.d20190831-cab2ad32531f0a1aa9cef9332169f7e2825a98c6_GH0.tar.gz) = 583f9331057a3b8c4e8ae62ba37a4818840bd566f9705462072f7c42509ff600
-SIZE (CTSRD-CHERI-qemu-0.d20190831-cab2ad32531f0a1aa9cef9332169f7e2825a98c6_GH0.tar.gz) = 18941063
+TIMESTAMP = 1576015343
+SHA256 (CTSRD-CHERI-qemu-0.d20191209-74235a2879944724c88ad8b400170b8e2b0a6147_GH0.tar.gz) = facff8aca23b47d443dad98fa6ece3971636cf0a7d2fb79eaadbff5ddb4bf348
+SIZE (CTSRD-CHERI-qemu-0.d20191209-74235a2879944724c88ad8b400170b8e2b0a6147_GH0.tar.gz) = 29444613
+SHA256 (CTSRD-CHERI-libslirp-6651ba26c4e94f64d6448a2db4991269ce553bd9_GH0.tar.gz) = aaffa33addd3aec53b5def83c4735275c9f501425bb0d8706494a7724875d8a6
+SIZE (CTSRD-CHERI-libslirp-6651ba26c4e94f64d6448a2db4991269ce553bd9_GH0.tar.gz) = 121465
SHA256 (qemu-keycodemapdb-6b3d716_GH0.tar.gz) = c9d3412510aac999865d01aaa14b1fa8dc0385db55c5cf6c4d95d160bd0eaee9
SIZE (qemu-keycodemapdb-6b3d716_GH0.tar.gz) = 47905
diff --git a/emulators/qemu-cheri/files/gen-Makefile.snapshot.sh b/emulators/qemu-cheri/files/gen-Makefile.snapshot.sh
index 0bf4935790ef..065b9baba2d9 100644
--- a/emulators/qemu-cheri/files/gen-Makefile.snapshot.sh
+++ b/emulators/qemu-cheri/files/gen-Makefile.snapshot.sh
@@ -11,7 +11,8 @@ tmpfile=`mktemp -t gen-Makefile.snapshot`
query_repo()
{
- curl ${REPOS_URL}/$1/branches/qemu-cheri > $tmpfile
+ branch=${2:-master}
+ curl ${REPOS_URL}/$1/branches/${branch} > $tmpfile
# Accumulate the dates of the last commits to find the snapshot date
committime=`jq -r '.commit.commit.committer.date' $tmpfile`
@@ -28,8 +29,10 @@ query_repo()
SHA=`jq -r '.commit.sha' $tmpfile`
}
-query_repo qemu
+query_repo qemu qemu-cheri
QEMU_COMMIT=$SHA
+query_repo libslirp
+LIBSLIRP_COMMIT=$SHA
cat <<EOF > Makefile.snapshot
# \$FreeBSD\$
@@ -41,6 +44,7 @@ cat <<EOF > Makefile.snapshot
SNAPDATE= ${MAX_DATE}
QEMU_COMMIT= ${QEMU_COMMIT}
+LIBSLIRP_COMMIT= ${LIBSLIRP_COMMIT}
EOF
rm -f $tmpfile