aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2008-08-02 18:29:39 +0000
committerJuergen Lock <nox@FreeBSD.org>2008-08-02 18:29:39 +0000
commit4cbdac07e0d26fae1fb5e7aae8daa113ad881c02 (patch)
tree0543df9c014c5992ed5bf7948093d469e5f1ea01 /emulators/qemu-devel/Makefile
parentcc604161fca1bbfe78b951ce68358eae610b9678 (diff)
downloadports-4cbdac07e0d26fae1fb5e7aae8daa113ad881c02.tar.gz
ports-4cbdac07e0d26fae1fb5e7aae8daa113ad881c02.zip
Notes
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index da497ceb3f47..3cd4951c5614 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qemu
PORTVERSION= 0.9.1s.20080620
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://bellard.org/qemu/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
@@ -36,6 +37,7 @@ OPTIONS= KQEMU "Build with (alpha!) accelerator module" Off \
SAMBA "samba dependency (for -smb)" Off \
SDL "SDL/X dependency (graphical output)" On \
GNUTLS "gnutls dependency (vnc encryption)" On \
+ PCAP "pcap dependency (networking with bpf)" On \
CDROM_DMA "IDE CDROM DMA" On \
ALL_TARGETS "Also build dyngen targets (requires gcc34)" On
@@ -71,6 +73,10 @@ CONFIGURE_ARGS+= --disable-vnc-tls
LIB_DEPENDS+= gnutls:${PORTSDIR}/security/gnutls
.endif
+.if defined(WITH_PCAP)
+CONFIGURE_ARGS+= --enable-pcap
+.endif
+
.if defined(WITH_SAMBA)
RUN_DEPENDS+= ${LOCALBASE}/sbin/smbd:${PORTSDIR}/net/samba3
.endif
@@ -105,6 +111,9 @@ post-patch:
.if defined(WITH_RTL8139_TIMER)
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/rtl8139-re-patch
.endif
+.if defined(WITH_PCAP)
+ @cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/pcap-patch
+.endif
.if defined(WITHOUT_CDROM_DMA)
@cd ${WRKSRC} && ${PATCH} --quiet < ${FILESDIR}/cdrom-dma-patch
.endif