aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-devel/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-09-27 17:55:47 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-09-27 17:55:47 +0000
commit4ece99d6b2f49f27badd8ae18ddaa599517521b1 (patch)
tree8deb3031b295ca18efce0921f7c6c6d5b0486093 /emulators/qemu-devel/Makefile
parent0dc8ba193b3809a75a5fdb4a8b52e9cc84e5561d (diff)
downloadports-4ece99d6b2f49f27badd8ae18ddaa599517521b1.tar.gz
ports-4ece99d6b2f49f27badd8ae18ddaa599517521b1.zip
Notes
Diffstat (limited to 'emulators/qemu-devel/Makefile')
-rw-r--r--emulators/qemu-devel/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index b4ffaf8a4b99..81a2c4700f80 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 4.0.0
+PORTVERSION= 4.1.0
CATEGORIES= emulators
MASTER_SITES= https://download.qemu.org/
PKGNAMESUFFIX= -devel
@@ -21,7 +21,7 @@ LIB_DEPENDS= libnettle.so:security/nettle \
libepoxy.so:graphics/libepoxy \
libpcre2-8.so:devel/pcre2
-USES= bison cpe gmake gnome iconv:wchar_t perl5 pkgconfig python:build tar:xz
+USES= bison cpe gmake gnome iconv:wchar_t perl5 pkgconfig python:build tar:xz xorg
USE_GNOME= cairo glib20 libxml2
USE_PERL5= build
USE_XORG= pixman
@@ -90,12 +90,12 @@ DOCS_USES= makeinfo
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=1
PORTDOCS= docs interop/.buildinfo interop/* qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
- qemu-qmp-ref.html qemu-qmp-ref.txt
+ qemu-qmp-ref.html qemu-qmp-ref.txt specs/.buildinfo specs/*
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CONFIGURE_ARGS= --localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
- --extra-ldflags=-L\"${LOCALBASE}/lib\" --disable-libssh2 --enable-debug \
+ --extra-ldflags=-L\"${LOCALBASE}/lib\" --enable-debug \
--prefix=${PREFIX} --cc=${CC} --enable-netmap --enable-docs --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
--enable-debug-info --python=${PYTHON_CMD} \