aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-powernv
diff options
context:
space:
mode:
authorKevin Bowling <kbowling@FreeBSD.org>2018-11-28 09:37:30 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2018-11-28 09:37:30 +0000
commit32d5de27333fcbc857fd7488f3c59c8a2839b245 (patch)
tree3e651807f7aa8bc3a1b1a20dd6c8ad14c51881e8 /emulators/qemu-powernv
parentb55b7723fe771d888aeef2915ece798321300f71 (diff)
downloadports-32d5de27333fcbc857fd7488f3c59c8a2839b245.tar.gz
ports-32d5de27333fcbc857fd7488f3c59c8a2839b245.zip
emulators/qemu-powernv: rename from emulators/qemu-ppcnv and update to POWER9
Update to benh's qemu power9 branch which adds support for features like radix mmu and phb. Take maintainership of this port with Mark's permission from IRC conversation. Approved by: krion (mentor) Sponsored by: BBOX.io Differential Revision: https://reviews.freebsd.org/D17862
Notes
Notes: svn path=/head/; revision=486085
Diffstat (limited to 'emulators/qemu-powernv')
-rw-r--r--emulators/qemu-powernv/Makefile55
-rw-r--r--emulators/qemu-powernv/distinfo3
-rw-r--r--emulators/qemu-powernv/pkg-descr3
3 files changed, 61 insertions, 0 deletions
diff --git a/emulators/qemu-powernv/Makefile b/emulators/qemu-powernv/Makefile
new file mode 100644
index 000000000000..84360ffd5882
--- /dev/null
+++ b/emulators/qemu-powernv/Makefile
@@ -0,0 +1,55 @@
+# $FreeBSD$
+
+PORTNAME= qemu-powernv
+PORTVERSION= 3.0.50
+CATEGORIES= emulators
+MASTER_SITES= http://people.freebsd.org/~kbowling/distfiles/
+
+MAINTAINER= kbowling@FreeBSD.org
+COMMENT= Fork of QEMU with experimental PowerNV emulation support
+
+LICENSE= GPLv2
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libfdt.so:sysutils/dtc
+
+USES= bison:build gmake libtool makeinfo pkgconfig python:2.7,build
+USE_XORG= pixman
+USE_GNOME= glib20
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+=--target-list=ppc64-softmmu \
+ --cc=${CC} \
+ --disable-curl \
+ --disable-docs \
+ --disable-gtk \
+ --disable-gcrypt \
+ --disable-kvm \
+ --disable-libssh2 \
+ --disable-linux-aio \
+ --disable-linux-user \
+ --disable-vnc \
+ --disable-sdl \
+ --disable-nettle \
+ --disable-gnutls \
+ --disable-vte \
+ --disable-xen \
+ --extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\" \
+ --extra-ldflags=-L\"${LOCALBASE}/lib\" \
+ --localstatedir=/var \
+ --datadir=${DATADIR} \
+ --python=${PYTHON_CMD}
+
+PLIST_FILES= bin/qemu-system-powernv \
+ ${DATADIR}/qemu/skiboot.lid \
+ ${DATADIR}/qemu/slof.bin \
+ ${DATADIR}/qemu/spapr-rtas.bin
+
+# remap names to avoid conflicts with mainline port
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ppc64-softmmu/qemu-system-ppc64 ${STAGEDIR}${PREFIX}/bin/qemu-system-powernv
+ ${MKDIR} ${STAGEDIR}${DATADIR}/qemu
+ ${INSTALL_DATA} ${WRKSRC}/pc-bios/skiboot.lid ${STAGEDIR}${DATADIR}/qemu/skiboot.lid
+ ${INSTALL_DATA} ${WRKSRC}/pc-bios/slof.bin ${STAGEDIR}${DATADIR}/qemu/slof.bin
+ ${INSTALL_DATA} ${WRKSRC}/pc-bios/spapr-rtas.bin ${STAGEDIR}${DATADIR}/qemu/spapr-rtas.bin
+
+.include <bsd.port.mk>
diff --git a/emulators/qemu-powernv/distinfo b/emulators/qemu-powernv/distinfo
new file mode 100644
index 000000000000..39596fa1c47a
--- /dev/null
+++ b/emulators/qemu-powernv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1541490377
+SHA256 (qemu-powernv-3.0.50.tar.gz) = 6935e4b4b5def6c5b1cc1ac1717bae56323e673193ab587978929db9f8849b52
+SIZE (qemu-powernv-3.0.50.tar.gz) = 17249849
diff --git a/emulators/qemu-powernv/pkg-descr b/emulators/qemu-powernv/pkg-descr
new file mode 100644
index 000000000000..c531f52f007d
--- /dev/null
+++ b/emulators/qemu-powernv/pkg-descr
@@ -0,0 +1,3 @@
+Fork of QEMU with experimental PowerNV emulation support.
+
+WWW: https://github.com/ozbenh/qemu/tree/power9