aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-user-static-devel/Makefile
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-12-04 02:35:41 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-12-04 02:35:41 +0000
commit0f2a95fa2ed4511da999755667c35eb1f1a9d84e (patch)
tree4d16018bc87a5338d19ba298a13b966e3996319a /emulators/qemu-user-static-devel/Makefile
parent5518e5006132640c9025d3541955adc861f9cc10 (diff)
downloadports-0f2a95fa2ed4511da999755667c35eb1f1a9d84e.tar.gz
ports-0f2a95fa2ed4511da999755667c35eb1f1a9d84e.zip
Notes
Diffstat (limited to 'emulators/qemu-user-static-devel/Makefile')
-rw-r--r--emulators/qemu-user-static-devel/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/emulators/qemu-user-static-devel/Makefile b/emulators/qemu-user-static-devel/Makefile
index b78d20bf44a7..e3ab027800aa 100644
--- a/emulators/qemu-user-static-devel/Makefile
+++ b/emulators/qemu-user-static-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= qemu
PORTVERSION= 3.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
PKGNAMESUFFIX= -user-static-devel
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -18,7 +18,7 @@ CONFLICTS_INSTALL= qemu-user-static-[0-9]*
USES= bison compiler:c11 gmake perl5 pkgconfig python:build
USE_GITHUB= yes
-GH_TUPLE= seanbruno:qemu-bsd-user:ed53c04a13 \
+GH_TUPLE= seanbruno:qemu-bsd-user:74de8c0708 \
qemu:keycodemapdb:10739aa:keycodemapdb/ui/keycodemapdb
HAS_CONFIGURE= yes
USE_PERL5= build
@@ -62,21 +62,12 @@ CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC} --enable-docs \
--disable-sdl --disable-gtk --disable-vte --disable-gnutls --disable-vnc \
--disable-curl --disable-opengl --disable-usb-redir --disable-pcap \
--disable-docs --disable-tools --disable-system --disable-guest-agent \
+ --disable-capstone \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
QEMU_ARCH= ${ARCH:C/amd64/x86_64/:C/powerpc/ppc/}
MAKE_ARGS+= ARCH=${QEMU_ARCH}
-post-patch:
- @${REINPLACE_CMD} -E \
- -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing|" \
- -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
- ${WRKSRC}/Makefile.target
- @${REINPLACE_CMD} -E \
- -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing -I.|" \
- -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
- ${WRKSRC}/Makefile
-
post-install:
@${MV} ${STAGEDIR}${PREFIX}/etc/rc.d ${WRKDIR}
@${RM} -r ${STAGEDIR}${PREFIX}/etc