aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu50
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-22 13:20:56 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-10-22 13:20:56 +0000
commit238aa3b315d7356fc47912e6317f0ce82c6a6580 (patch)
tree3c3013ba36de6a4bf8aeb446e66116349abf20a4 /emulators/qemu50
parent0831c9ff54eb6e71fc93957f032e55ae4d59c3e9 (diff)
downloadports-238aa3b315d7356fc47912e6317f0ce82c6a6580.tar.gz
ports-238aa3b315d7356fc47912e6317f0ce82c6a6580.zip
emulators/qemu50: fix build on GCC architectures
Adding -L/usr/lib make gcc from ports prefer /usr/lib instead of its own /usr/local/lib/gcc9, which makes build fail: /usr/local/bin/ld: accel/tcg/tcg-runtime.o: in function `clrsb32': /wrkdirs/usr/ports/emulators/qemu50/work/qemu-5.0.0/include/qemu/host-utils.h:211: undefined reference to `__clrsbdi2' Tested for no breakage on 12.1/i386, 12.2/amd64 and 13.0/powerpc64. MFH: 2020Q4 (fix build blanket)
Notes
Notes: svn path=/head/; revision=552973
Diffstat (limited to 'emulators/qemu50')
-rw-r--r--emulators/qemu50/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/emulators/qemu50/Makefile b/emulators/qemu50/Makefile
index 15c19adab4b7..c4a704ec03c1 100644
--- a/emulators/qemu50/Makefile
+++ b/emulators/qemu50/Makefile
@@ -102,7 +102,7 @@ PORTDOCS= docs index.html interop/.buildinfo interop/* qemu-ga-ref.html qemu-ga-
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
CFLAGS_amd64+= -fPIC
-CONFIGURE_ARGS= --localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
+CONFIGURE_ARGS= --localstatedir=/var \
--extra-ldflags=-L\"${LOCALBASE}/lib\" --enable-debug \
--prefix=${PREFIX} --cc=${CC} --enable-netmap --enable-docs --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \