aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-10-26 01:30:57 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-10-26 01:30:57 +0000
commit5238ef4e5a75e61d628b7e4b82a422239f675bdb (patch)
treeca8d1795b18b5bf9c97da240e1d6acad7e44acba /emulators/qemu
parent37b780c2a62d114e2c78e0410a905cd2022c5ef5 (diff)
downloadports-5238ef4e5a75e61d628b7e4b82a422239f675bdb.tar.gz
ports-5238ef4e5a75e61d628b7e4b82a422239f675bdb.zip
emulators/qemu: Update version 4.2.1=>5.0.1
- Add OPTION DEBUG
Notes
Notes: svn path=/head/; revision=553312
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile32
-rw-r--r--emulators/qemu/distinfo10
-rw-r--r--emulators/qemu/files/patch-Makefile31
-rw-r--r--emulators/qemu/files/patch-configure85
-rw-r--r--emulators/qemu/files/patch-include_qemu_atomic.h21
-rw-r--r--emulators/qemu/files/patch-qemu-doc.texi21
-rw-r--r--emulators/qemu/pkg-plist4
7 files changed, 71 insertions, 133 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 8dae4c44e400..fd6170cfb9eb 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -2,11 +2,13 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 4.2.1
+PORTVERSION= 5.0.1
CATEGORIES= emulators
MASTER_SITES= https://download.qemu.org/
DIST_SUBDIR= qemu/${PORTVERSION}
+PATCH_SITES= https://github.com/${PORTNAME}/${PORTNAME}/commit/
+
MAINTAINER?= bofh@FreeBSD.org
COMMENT?= QEMU CPU Emulator
@@ -17,7 +19,11 @@ LIB_DEPENDS?= libnettle.so:security/nettle \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libepoxy.so:graphics/libepoxy \
- libpcre2-8.so:devel/pcre2
+ libpcre2-8.so:devel/pcre2 \
+ libzstd.so:archivers/zstd
+
+PATCHFILES+= 55765822804f.patch:-p1
+PATCHFILES+= aa4d30f6618d.patch:-p1
.if !defined(PKGNAMESUFFIX) || (${PKGNAMESUFFIX} != "-utils" && ${PKGNAMESUFFIX} != "-guest-agent")
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64
@@ -29,14 +35,14 @@ USE_GNOME= cairo glib20 libxml2
USE_PERL5= build
-PORTSCOUT= limit:^4\.2\.
+PORTSCOUT= limit:^5\.0\.
HAS_CONFIGURE= yes
MAKE_ENV+= BSD_MAKE="${MAKE}" V=1
OPTIONS_DEFINE= SAMBA X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CURL \
VDE CDROM_DMA PCAP USBREDIR X86_TARGETS \
- STATIC_LINK DOCS ISCSI CAPSTONE
+ STATIC_LINK DOCS ISCSI CAPSTONE DEBUG
OPTIONS_SINGLE= NCURSES
OPTIONS_SINGLE_NCURSES= NCURSES_DEFAULT NCURSES_BASE NCURSES_PORT
CDROM_DMA_DESC= IDE CDROM DMA
@@ -62,7 +68,9 @@ CAPSTONE_CONFIGURE_OFF= --disable-capstone
CAPSTONE_LIB_DEPENDS= libcapstone.so:devel/capstone4
CURL_CONFIGURE_OFF= --disable-curl
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
-DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html
+DEBUG_CONFIGURE_ON= --enable-debug
+DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html \
+ sphinx-build:textproc/py-sphinx
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=1
DOCS_USES= makeinfo
GNUTLS_CONFIGURE_OFF= --disable-gnutls
@@ -107,16 +115,18 @@ X86_TARGETS_USES_OFF= xorg
INSTALLS_ICONS= yes
.endif
-PORTDOCS?= docs interop/.buildinfo interop/* qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
- qemu-qmp-ref.html qemu-qmp-ref.txt specs/.buildinfo specs/*
+PORTDOCS?= docs index.html interop/.buildinfo interop/* qemu-ga-ref.html qemu-ga-ref.txt \
+ qemu-qmp-ref.html qemu-qmp-ref.txt specs/.buildinfo specs/* system/.buildinfo \
+ system/* tools/.buildinfo tools/* user/.buildinfo user/*
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
-CONFIGURE_ARGS?= --localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
- --extra-ldflags=-L\"${LOCALBASE}/lib\" --disable-libssh --enable-debug \
- --prefix=${PREFIX} --cc=${CC} --enable-netmap --enable-docs --disable-kvm \
+CFLAGS_amd64+= -fPIC
+CONFIGURE_ARGS?=--localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
+ --extra-ldflags=-L\"${LOCALBASE}/lib\" --disable-libssh \
+ --prefix=${PREFIX} --cc=${CC} --enable-netmap --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
- --enable-debug-info --python=${PYTHON_CMD} \
+ --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
.include <bsd.port.options.mk>
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index e728598d2052..d5f50ec2c84a 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,3 +1,7 @@
-TIMESTAMP = 1594330010
-SHA256 (qemu/4.2.1/qemu-4.2.1.tar.xz) = 7e331163b72e7bcf63bd35cb85cba87b48d12fab3f264b94c23f7d3991094207
-SIZE (qemu/4.2.1/qemu-4.2.1.tar.xz) = 62225124
+TIMESTAMP = 1603483758
+SHA256 (qemu/5.0.1/qemu-5.0.1.tar.xz) = 135fab4c3699a378c9584b3453927e2f5002e440311f21efa66fc189d4bb4982
+SIZE (qemu/5.0.1/qemu-5.0.1.tar.xz) = 62430168
+SHA256 (qemu/5.0.1/55765822804f.patch) = 10c2cc93ad01b02d854e26a9e445ba22bb5434dda1ef25baeb979be6292fa8ef
+SIZE (qemu/5.0.1/55765822804f.patch) = 2271
+SHA256 (qemu/5.0.1/aa4d30f6618d.patch) = eeddc5f5e08a460d2c133b4193d115fa1f00f206e0833f33ec66379981473efe
+SIZE (qemu/5.0.1/aa4d30f6618d.patch) = 2211
diff --git a/emulators/qemu/files/patch-Makefile b/emulators/qemu/files/patch-Makefile
index 909ac1e5beb7..abddaa8e630f 100644
--- a/emulators/qemu/files/patch-Makefile
+++ b/emulators/qemu/files/patch-Makefile
@@ -1,35 +1,38 @@
---- Makefile.orig 2019-12-12 18:20:47 UTC
+--- Makefile.orig 2020-04-28 16:49:25 UTC
+++ Makefile
-@@ -342,9 +342,14 @@ MANUAL_BUILDDIR := docs
+@@ -362,6 +362,10 @@ MANUAL_BUILDDIR := docs
endif
ifdef BUILD_DOCS
+ifdef NOPORTDOCS
-+DOCS=qemu.1 qemu-img.1 qemu-nbd.8 $(MANUAL_BUILDDIR)/interop/qemu-ga.8
++DOCS=qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
+DOCS+=docs/interop/qemu-qmp-ref.7 docs/interop/qemu-ga-ref.7
+else
- DOCS=qemu-doc.html qemu-doc.txt qemu.1 qemu-img.1 qemu-nbd.8 $(MANUAL_BUILDDIR)/interop/qemu-ga.8
+ DOCS+=$(MANUAL_BUILDDIR)/system/qemu.1
+ DOCS+=$(MANUAL_BUILDDIR)/tools/qemu-img.1
+ DOCS+=$(MANUAL_BUILDDIR)/tools/qemu-nbd.8
+@@ -369,6 +373,7 @@ DOCS+=$(MANUAL_BUILDDIR)/interop/qemu-ga.8
+ ifeq ($(CONFIG_LINUX)$(CONFIG_SECCOMP)$(CONFIG_LIBCAP_NG),yyy)
+ DOCS+=$(MANUAL_BUILDDIR)/tools/virtiofsd.1
+ endif
++endif
+ DOCS+=$(MANUAL_BUILDDIR)/system/qemu-block-drivers.7
DOCS+=docs/interop/qemu-qmp-ref.html docs/interop/qemu-qmp-ref.txt docs/interop/qemu-qmp-ref.7
DOCS+=docs/interop/qemu-ga-ref.html docs/interop/qemu-ga-ref.txt docs/interop/qemu-ga-ref.7
-+endif
- DOCS+=docs/qemu-block-drivers.7
- DOCS+=docs/qemu-cpu-models.7
- ifdef CONFIG_VIRTFS
-@@ -819,11 +824,13 @@ install-sphinxdocs: sphinxdocs
- $(call install-manual,specs)
+@@ -878,10 +883,12 @@ install-sphinxdocs: sphinxdocs
+ $(call install-manual,user)
install-doc: $(DOCS) install-sphinxdocs
+ifndef NOPORTDOCS
$(INSTALL_DIR) "$(DESTDIR)$(qemu_docdir)"
- $(INSTALL_DATA) qemu-doc.html "$(DESTDIR)$(qemu_docdir)"
- $(INSTALL_DATA) qemu-doc.txt "$(DESTDIR)$(qemu_docdir)"
+ $(INSTALL_DATA) $(MANUAL_BUILDDIR)/index.html "$(DESTDIR)$(qemu_docdir)"
$(INSTALL_DATA) docs/interop/qemu-qmp-ref.html "$(DESTDIR)$(qemu_docdir)"
$(INSTALL_DATA) docs/interop/qemu-qmp-ref.txt "$(DESTDIR)$(qemu_docdir)"
+endif
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
- $(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1"
-@@ -841,8 +848,10 @@ ifdef CONFIG_TRACE_SYSTEMTAP
+ $(INSTALL_DATA) $(MANUAL_BUILDDIR)/system/qemu.1 "$(DESTDIR)$(mandir)/man1"
+@@ -899,8 +906,10 @@ ifdef CONFIG_TRACE_SYSTEMTAP
endif
ifneq (,$(findstring qemu-ga,$(TOOLS)))
$(INSTALL_DATA) $(MANUAL_BUILDDIR)/interop/qemu-ga.8 "$(DESTDIR)$(mandir)/man8"
diff --git a/emulators/qemu/files/patch-configure b/emulators/qemu/files/patch-configure
index d62730814b28..9e6b9cf678c6 100644
--- a/emulators/qemu/files/patch-configure
+++ b/emulators/qemu/files/patch-configure
@@ -1,15 +1,15 @@
---- configure.orig 2019-12-12 18:20:47 UTC
+--- configure.orig 2020-04-28 16:49:25 UTC
+++ configure
-@@ -405,7 +405,7 @@ DSOSUF=".so"
- LDFLAGS_SHARED="-shared"
+@@ -408,7 +408,7 @@ LDFLAGS_SHARED="-shared"
modules="no"
+ module_upgrades="no"
prefix="/usr/local"
-mandir="\${prefix}/share/man"
+mandir="\${prefix}/man"
datadir="\${prefix}/share"
firmwarepath="\${prefix}/share/qemu-firmware"
qemu_docdir="\${prefix}/share/doc/qemu"
-@@ -489,6 +489,9 @@ numa=""
+@@ -493,6 +493,9 @@ numa=""
tcmalloc="no"
jemalloc="no"
replication="yes"
@@ -19,7 +19,7 @@
vxhs=""
bochs="yes"
cloop="yes"
-@@ -1125,6 +1128,10 @@ for opt do
+@@ -1168,6 +1171,10 @@ for opt do
;;
--enable-vnc-png) vnc_png="yes"
;;
@@ -30,7 +30,7 @@
--disable-slirp) slirp="no"
;;
--enable-slirp=git) slirp="git"
-@@ -3023,6 +3030,14 @@ if ! check_include "ifaddrs.h" ; then
+@@ -3137,6 +3144,14 @@ if ! check_include "ifaddrs.h" ; then
fi
##########################################
@@ -45,7 +45,7 @@
# VTE probe
if test "$vte" != "no"; then
-@@ -3710,7 +3725,7 @@ for i in $glib_modules; do
+@@ -3806,7 +3821,7 @@ for i in $glib_modules; do
glib_libs=$($pkg_config --libs $i)
QEMU_CFLAGS="$glib_cflags $QEMU_CFLAGS"
LIBS="$glib_libs $LIBS"
@@ -54,19 +54,22 @@
else
error_exit "glib-$glib_req_ver $i is required to compile QEMU"
fi
-@@ -4802,11 +4817,6 @@ has_sphinx_build() {
- if test "$docs" != "no" ; then
- if has makeinfo && has pod2man && has_sphinx_build; then
+@@ -4957,14 +4972,6 @@ if test "$docs" != "no" ; then
+ fi
+ if has makeinfo && has pod2man && test "$sphinx_ok" = "yes"; then
docs=yes
- else
- if test "$docs" = "yes" ; then
-- feature_not_found "docs" "Install texinfo, Perl/perl-podlators and python-sphinx"
+- if has $sphinx_build && test "$sphinx_ok" != "yes"; then
+- echo "Warning: $sphinx_build exists but it is either too old or uses too old a Python version" >&2
+- fi
+- feature_not_found "docs" "Install texinfo, Perl/perl-podlators and a Python 3 version of python-sphinx"
- fi
- docs=no
fi
fi
-@@ -4940,7 +4950,7 @@ fi
+@@ -5098,7 +5105,7 @@ fi
# check for libusb
if test "$libusb" != "no" ; then
@@ -75,7 +78,7 @@
libusb="yes"
libusb_cflags=$($pkg_config --cflags libusb-1.0)
libusb_libs=$($pkg_config --libs libusb-1.0)
-@@ -5330,7 +5340,51 @@ if test "$debug_stack_usage" = "yes"; then
+@@ -5501,7 +5508,51 @@ if test "$debug_stack_usage" = "yes"; then
fi
fi
@@ -127,57 +130,7 @@
##########################################
# check if we have open_by_handle_at
-@@ -6352,27 +6406,30 @@ if ( [ "$linux_user" = yes ] || [ "$bsd_user" = yes ]
- cat > $TMPC <<EOF
- int main(void) { return 0; }
- EOF
-- textseg_ldflags="-Wl,-Ttext-segment=$textseg_addr"
-+ textseg_ldflags="-Wl,--image-base=$textseg_addr"
- if ! compile_prog "" "$textseg_ldflags"; then
-- # In case ld does not support -Ttext-segment, edit the default linker
-- # script via sed to set the .text start addr. This is needed on FreeBSD
-- # at least.
-- if ! $ld --verbose >/dev/null 2>&1; then
-- error_exit \
-- "We need to link the QEMU user mode binaries at a" \
-- "specific text address. Unfortunately your linker" \
-- "doesn't support either the -Ttext-segment option or" \
-- "printing the default linker script with --verbose." \
-- "If you don't want the user mode binaries, pass the" \
-- "--disable-user option to configure."
-- fi
-+ textseg_ldflags="-Wl,-Ttext-segment=$textseg_addr"
-+ if ! compile_prog "" "$textseg_ldflags"; then
-+ # In case ld does not support -Ttext-segment, edit the default linker
-+ # script via sed to set the .text start addr. This is needed on FreeBSD
-+ # at least.
-+ if ! $ld --verbose >/dev/null 2>&1; then
-+ error_exit \
-+ "We need to link the QEMU user mode binaries at a" \
-+ "specific text address. Unfortunately your linker" \
-+ "doesn't support either the -Ttext-segment option or" \
-+ "printing the default linker script with --verbose." \
-+ "If you don't want the user mode binaries, pass the" \
-+ "--disable-user option to configure."
-+ fi
-
-- $ld --verbose | sed \
-- -e '1,/==================================================/d' \
-- -e '/==================================================/,$d' \
-- -e "s/[.] = [0-9a-fx]* [+] SIZEOF_HEADERS/. = $textseg_addr + SIZEOF_HEADERS/" \
-- -e "s/__executable_start = [0-9a-fx]*/__executable_start = $textseg_addr/" > config-host.ld
-- textseg_ldflags="-Wl,-T../config-host.ld"
-+ $ld --verbose | sed \
-+ -e '1,/==================================================/d' \
-+ -e '/==================================================/,$d' \
-+ -e "s/[.] = [0-9a-fx]* [+] SIZEOF_HEADERS/. = $textseg_addr + SIZEOF_HEADERS/" \
-+ -e "s/__executable_start = [0-9a-fx]*/__executable_start = $textseg_addr/" > config-host.ld
-+ textseg_ldflags="-Wl,-T../config-host.ld"
-+ fi
- fi
- fi
- fi
-@@ -6497,6 +6554,7 @@ echo "Audio drivers $audio_drv_list"
+@@ -6627,6 +6678,7 @@ echo "Audio drivers $audio_drv_list"
echo "Block whitelist (rw) $block_drv_rw_whitelist"
echo "Block whitelist (ro) $block_drv_ro_whitelist"
echo "VirtFS support $virtfs"
@@ -185,7 +138,7 @@
echo "Multipath support $mpath"
echo "VNC support $vnc"
if test "$vnc" = "yes" ; then
-@@ -6739,6 +6797,15 @@ fi
+@@ -6864,6 +6916,15 @@ fi
if test "$want_tools" = "yes" ; then
echo "CONFIG_TOOLS=y" >> $config_host_mak
fi
@@ -201,7 +154,7 @@
if test "$slirp" != "no"; then
echo "CONFIG_SLIRP=y" >> $config_host_mak
echo "CONFIG_SMBD_COMMAND=\"$smbd\"" >> $config_host_mak
-@@ -6986,6 +7053,9 @@ fi
+@@ -7120,6 +7181,9 @@ fi
# if this macro is set.
if test "$have_fsxattr" = "yes" ; then
echo "HAVE_FSXATTR=y" >> $config_host_mak
diff --git a/emulators/qemu/files/patch-include_qemu_atomic.h b/emulators/qemu/files/patch-include_qemu_atomic.h
index 1885cef97c57..384ef52bfd3c 100644
--- a/emulators/qemu/files/patch-include_qemu_atomic.h
+++ b/emulators/qemu/files/patch-include_qemu_atomic.h
@@ -1,19 +1,6 @@
---- include/qemu/atomic.h.orig 2020-06-25 18:12:17 UTC
+--- include/qemu/atomic.h.orig 2020-04-28 16:49:24 UTC
+++ include/qemu/atomic.h
-@@ -208,10 +208,12 @@
- /* Provide shorter names for GCC atomic builtins, return old value */
- #define atomic_fetch_inc(ptr) __atomic_fetch_add(ptr, 1, __ATOMIC_SEQ_CST)
- #define atomic_fetch_dec(ptr) __atomic_fetch_sub(ptr, 1, __ATOMIC_SEQ_CST)
-+#ifndef __cplusplus
- #define atomic_fetch_add(ptr, n) __atomic_fetch_add(ptr, n, __ATOMIC_SEQ_CST)
- #define atomic_fetch_sub(ptr, n) __atomic_fetch_sub(ptr, n, __ATOMIC_SEQ_CST)
- #define atomic_fetch_and(ptr, n) __atomic_fetch_and(ptr, n, __ATOMIC_SEQ_CST)
- #define atomic_fetch_or(ptr, n) __atomic_fetch_or(ptr, n, __ATOMIC_SEQ_CST)
-+#endif
- #define atomic_fetch_xor(ptr, n) __atomic_fetch_xor(ptr, n, __ATOMIC_SEQ_CST)
-
- #define atomic_inc_fetch(ptr) __atomic_add_fetch(ptr, 1, __ATOMIC_SEQ_CST)
-@@ -225,10 +227,12 @@
+@@ -228,10 +228,12 @@
/* And even shorter names that return void. */
#define atomic_inc(ptr) ((void) __atomic_fetch_add(ptr, 1, __ATOMIC_SEQ_CST))
#define atomic_dec(ptr) ((void) __atomic_fetch_sub(ptr, 1, __ATOMIC_SEQ_CST))
@@ -26,7 +13,7 @@
#define atomic_xor(ptr, n) ((void) __atomic_fetch_xor(ptr, n, __ATOMIC_SEQ_CST))
#else /* __ATOMIC_RELAXED */
-@@ -400,10 +404,12 @@
+@@ -406,10 +408,12 @@
#define atomic_inc_fetch(ptr) __sync_add_and_fetch(ptr, 1)
#define atomic_dec_fetch(ptr) __sync_add_and_fetch(ptr, -1)
@@ -39,7 +26,7 @@
#define atomic_xor_fetch(ptr, n) __sync_xor_and_fetch(ptr, n)
#define atomic_cmpxchg(ptr, old, new) __sync_val_compare_and_swap(ptr, old, new)
-@@ -412,10 +418,12 @@
+@@ -418,10 +422,12 @@
/* And even shorter names that return void. */
#define atomic_inc(ptr) ((void) __sync_fetch_and_add(ptr, 1))
#define atomic_dec(ptr) ((void) __sync_fetch_and_add(ptr, -1))
diff --git a/emulators/qemu/files/patch-qemu-doc.texi b/emulators/qemu/files/patch-qemu-doc.texi
deleted file mode 100644
index 6a5f1f921c5a..000000000000
--- a/emulators/qemu/files/patch-qemu-doc.texi
+++ /dev/null
@@ -1,21 +0,0 @@
---- qemu-doc.texi.orig 2020-06-25 18:12:17 UTC
-+++ qemu-doc.texi
-@@ -205,7 +205,7 @@ VGA BIOS.
- QEMU uses YM3812 emulation by Tatsuyuki Satoh.
-
- QEMU uses GUS emulation (GUSEMU32 @url{http://www.deinmeister.de/gusemu/})
--by Tibor "TS" Schütz.
-+by Tibor "TS" Schuetz.
-
- Note that, by default, GUS shares IRQ(7) with parallel ports and so
- QEMU must be told to not have parallel ports to have working GUS.
-@@ -573,7 +573,8 @@ Send the escape character to the frontend
-
- @c man begin SEEALSO
- The HTML documentation of QEMU for more precise information and Linux
--user mode emulator invocation.
-+user mode emulator invocation, as well as the FreeBSD host notes in
-+@file{pkg-message} in the relevant qemu port directory.
- @c man end
-
- @c man begin AUTHOR
diff --git a/emulators/qemu/pkg-plist b/emulators/qemu/pkg-plist
index a49ffde6a5c3..c757443833ac 100644
--- a/emulators/qemu/pkg-plist
+++ b/emulators/qemu/pkg-plist
@@ -6,6 +6,7 @@ bin/qemu-img
bin/qemu-io
%%GTK3%%bin/qemu-keymap
bin/qemu-nbd
+bin/qemu-storage-daemon
%%NO_X86_TARGETS%%bin/qemu-sparc
%%NO_X86_TARGETS%%bin/qemu-sparc64
%%NO_X86_TARGETS%%bin/qemu-system-aarch64
@@ -29,6 +30,7 @@ bin/qemu-system-i386
%%NO_X86_TARGETS%%bin/qemu-system-ppc64
%%NO_X86_TARGETS%%bin/qemu-system-riscv32
%%NO_X86_TARGETS%%bin/qemu-system-riscv64
+bin/qemu-system-rx
%%NO_X86_TARGETS%%bin/qemu-system-s390x
%%NO_X86_TARGETS%%bin/qemu-system-sh4
%%NO_X86_TARGETS%%bin/qemu-system-sh4eb
@@ -86,12 +88,12 @@ man/man8/qemu-nbd.8.gz
%%DATADIR%%/openbios-ppc
%%DATADIR%%/openbios-sparc32
%%DATADIR%%/openbios-sparc64
+%%DATADIR%%/opensbi-riscv32-sifive_u-fw_jump.bin
%%DATADIR%%/opensbi-riscv32-virt-fw_jump.bin
%%DATADIR%%/opensbi-riscv64-sifive_u-fw_jump.bin
%%DATADIR%%/opensbi-riscv64-virt-fw_jump.bin
%%DATADIR%%/palcode-clipper
%%DATADIR%%/petalogix-ml605.dtb
-%%DATADIR%%/ppc_rom.bin
%%DATADIR%%/pxe-e1000.rom
%%DATADIR%%/pxe-eepro100.rom
%%DATADIR%%/pxe-ne2k_pci.rom