aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2017-08-04 13:45:29 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2017-08-04 13:45:29 +0000
commit7896bf95c6dec8bd39d01c1d522b9fd14d0d8976 (patch)
treedba6059a6bc0ea20fd7f841c600a061db1c47e4c /emulators/qemu
parentccafca607e8d11d085b5bf90b4a57d1558bf6470 (diff)
downloadports-7896bf95c6dec8bd39d01c1d522b9fd14d0d8976.tar.gz
ports-7896bf95c6dec8bd39d01c1d522b9fd14d0d8976.zip
emulators/qemu: Update version 2.8.1=>2.9.0
- Reorder LIB_DEPENDS - Add VDE Networking OPTION [1] - Move SAMBA CONFIGURE options to new clause from default - Fix CONFIGURE failure [2] PR: 220836[1], 220835[2] submitted by: holindho@saunalahti.fi [1][2] Relnotes: https://wiki.qemu.org/index.php/ChangeLog/2.9
Notes
Notes: svn path=/head/; revision=447330
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile28
-rw-r--r--emulators/qemu/distinfo8
-rw-r--r--emulators/qemu/files/patch-Makefile16
-rw-r--r--emulators/qemu/files/patch-configure4
-rw-r--r--emulators/qemu/files/patch-include_qemu_atomic.h4
-rw-r--r--emulators/qemu/files/patch-qemu-char.c19
-rw-r--r--emulators/qemu/files/pcap-patch40
-rw-r--r--emulators/qemu/pkg-plist5
8 files changed, 68 insertions, 56 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 502f17252212..6fc68a641374 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 2.8.1
-PORTREVISION= 1
+PORTVERSION= 2.9.0
CATEGORIES= emulators
MASTER_SITES= http://wiki.qemu.org/download/
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -13,6 +12,10 @@ COMMENT?= QEMU CPU Emulator
LICENSE= GPLv2
+LIB_DEPENDS?= libnettle.so:security/nettle \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2
+
HAS_CONFIGURE= yes
USES?= cpe gmake pkgconfig bison perl5 python:2,build tar:bzip2
USE_PERL5= build
@@ -26,7 +29,7 @@ ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 # XXX someone wants to debug sparc6
BROKEN_powerpc64= fails to compile: In function aio_bh_poll: internal compiler error: Segmentation fault
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
- CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
+ VDE CDROM_DMA PCAP USBREDIR GNS3 X86_TARGETS \
STATIC_LINK DOCS NCURSES
SAMBA_DESC= samba dependency (for -smb)
GNUTLS_DESC= gnutls dependency (vnc encryption)
@@ -39,7 +42,8 @@ USBREDIR_DESC= usb device network redirection (experimental!)
GNS3_DESC= gns3 patches (promiscuous multicast)
X86_TARGETS_DESC= Build only x86 system targets
STATIC_LINK_DESC= Statically link the executables
-OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP GNS3 NCURSES
+VDE_DESC= vde dependency (for vde networking)
+OPTIONS_DEFAULT=X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP GNS3 NCURSES VDE
OPTIONS_SUB= yes
X11_USE= SDL=sdl XORG=x11,xext GNOME=gdkpixbuf2
X11_CONFIGURE_ENABLE= sdl
@@ -64,16 +68,20 @@ USBREDIR_CONFIGURE_OFF= --disable-usb-redir
PCAP_CONFIGURE_ON= --enable-pcap
PCAP_EXTRA_PATCHES= ${FILESDIR}/pcap-patch ${FILESDIR}/pcap-patch-net_net.c \
${FILESDIR}/pcap-patch-net_clients.h
+VDE_LIB_DEPENDS= libvdeplug.so:net/vde2
+VDE_CONFIGURE_OFF= --disable-vde
STATIC_LINK_CONFIGURE_ON= --static
STATIC_LINK_PREVENTS= GTK2 X11
STATIC_LINK_PREVENTS_MSG= X11 ui cannot be built static
NCURSES_USES= ncurses:base
SAMBA_USES= samba:run # smbd
+SAMBA_CONFIGURE_ON= --smbd=${LOCALBASE}/sbin/smbd
DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html
DOCS_USES= makeinfo
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=1
-PORTDOCS?= docs qemu-doc.html qmp-commands.txt
+PORTDOCS?= docs qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
+ qemu-qmp-ref.html qemu-qmp-ref.txt
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
CFLAGS:= ${CFLAGS:C/-fno-tree-vrp//}
@@ -81,13 +89,9 @@ CONFIGURE_ARGS?=--localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
--extra-ldflags=-L\"${LOCALBASE}/lib\" --disable-libssh2 --enable-debug \
--prefix=${PREFIX} --cc=${CC} --enable-docs --disable-kvm \
--disable-linux-user --disable-linux-aio --disable-xen \
- --smbd=${LOCALBASE}/sbin/smbd --enable-debug-info --python=${PYTHON_CMD} \
+ --enable-debug-info --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
-LIB_DEPENDS?= libnettle.so:security/nettle \
- libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
-
.include <bsd.port.options.mk>
.if !defined(STRIP) || ${STRIP} == ""
@@ -112,9 +116,9 @@ CONFIGURE_ARGS+= --sparc_cpu=v9
# clang in freebsd 10 is unable to assemble linuxboot_dma.bin
.if (${OSVERSION} < 1100000)
-PLIST_SUB+= LINUXBOOT_DMA="@comment "
+PLIST_SUB+= LINUXBOOT_DMA="@comment "
.else
-PLIST_SUB+= LINUXBOOT_DMA=""
+PLIST_SUB+= LINUXBOOT_DMA=""
.endif
# -lprocstat actually only _needs_ -lelf after r249666 or r250870 (MFC)
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index e4d70d8c508d..1702a18b76cc 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,3 +1,5 @@
-TIMESTAMP = 1492017956
-SHA256 (qemu/2.8.1/qemu-2.8.1.tar.bz2) = 018e4c7ed22c220395cf41f835d01505e49d0e579a548bd3d72b03809442bbcd
-SIZE (qemu/2.8.1/qemu-2.8.1.tar.bz2) = 28366270
+TIMESTAMP = 1500663832
+SHA256 (qemu/2.9.0/qemu-2.9.0.tar.bz2) = 00bfb217b1bb03c7a6c3261b819cfccbfb5a58e3e2ceff546327d271773c6c14
+SIZE (qemu/2.9.0/qemu-2.9.0.tar.bz2) = 28720490
+SHA256 (qemu/2.9.0/dtc-v1.4.0.tar.gz) = 39d0713efd82a27adc065ecb9ef36401c53d5ee87ae1764e2bb243fcd97488e3
+SIZE (qemu/2.9.0/dtc-v1.4.0.tar.gz) = 131893
diff --git a/emulators/qemu/files/patch-Makefile b/emulators/qemu/files/patch-Makefile
index 51430ac1db69..0a8a735a7072 100644
--- a/emulators/qemu/files/patch-Makefile
+++ b/emulators/qemu/files/patch-Makefile
@@ -1,25 +1,29 @@
---- Makefile.orig 2016-12-20 13:16:43.000000000 -0700
-+++ Makefile 2017-03-05 08:08:54.529466000 -0700
-@@ -90,7 +90,11 @@
+--- Makefile.orig 2017-04-20 14:57:00 UTC
++++ Makefile
+@@ -206,9 +206,13 @@ LIBS+=-lz $(LIBS_TOOLS)
HELPERS-$(CONFIG_LINUX) = qemu-bridge-helper$(EXESUF)
ifdef BUILD_DOCS
+ifdef NOPORTDOCS
+DOCS=qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
+else
- DOCS=qemu-doc.html qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
+ DOCS=qemu-doc.html qemu-doc.txt qemu.1 qemu-img.1 qemu-nbd.8 qemu-ga.8
+ DOCS+=docs/qemu-qmp-ref.html docs/qemu-qmp-ref.txt docs/qemu-qmp-ref.7
+ DOCS+=docs/qemu-ga-ref.html docs/qemu-ga-ref.txt docs/qemu-ga-ref.7
+endif
ifdef CONFIG_VIRTFS
DOCS+=fsdev/virtfs-proxy-helper.1
endif
-@@ -429,9 +433,11 @@
+@@ -558,11 +562,13 @@ BLOBS=
endif
install-doc: $(DOCS)
+ifndef NOPORTDOCS
$(INSTALL_DIR) "$(DESTDIR)$(qemu_docdir)"
$(INSTALL_DATA) qemu-doc.html "$(DESTDIR)$(qemu_docdir)"
- $(INSTALL_DATA) $(SRC_PATH)/docs/qmp-commands.txt "$(DESTDIR)$(qemu_docdir)"
+ $(INSTALL_DATA) qemu-doc.txt "$(DESTDIR)$(qemu_docdir)"
+ $(INSTALL_DATA) docs/qemu-qmp-ref.html "$(DESTDIR)$(qemu_docdir)"
+ $(INSTALL_DATA) docs/qemu-qmp-ref.txt "$(DESTDIR)$(qemu_docdir)"
+endif
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
diff --git a/emulators/qemu/files/patch-configure b/emulators/qemu/files/patch-configure
index 8c38e10124df..7fea44e56c8b 100644
--- a/emulators/qemu/files/patch-configure
+++ b/emulators/qemu/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2016-12-20 13:16:44.000000000 -0700
-+++ configure 2017-03-05 08:10:46.513171000 -0700
+--- configure.orig 2017-04-20 14:57:00 UTC
++++ configure
@@ -247,7 +247,7 @@
LDFLAGS_SHARED="-shared"
modules="no"
diff --git a/emulators/qemu/files/patch-include_qemu_atomic.h b/emulators/qemu/files/patch-include_qemu_atomic.h
index aa8cedb90224..c1f3819a413a 100644
--- a/emulators/qemu/files/patch-include_qemu_atomic.h
+++ b/emulators/qemu/files/patch-include_qemu_atomic.h
@@ -1,5 +1,5 @@
---- include/qemu/atomic.h.orig 2016-12-20 13:16:47.000000000 -0700
-+++ include/qemu/atomic.h 2017-03-05 08:15:48.793780000 -0700
+--- include/qemu/atomic.h.orig 2017-04-20 14:57:00 UTC
++++ include/qemu/atomic.h
@@ -182,10 +182,12 @@
/* Provide shorter names for GCC atomic builtins, return old value */
#define atomic_fetch_inc(ptr) __atomic_fetch_add(ptr, 1, __ATOMIC_SEQ_CST)
diff --git a/emulators/qemu/files/patch-qemu-char.c b/emulators/qemu/files/patch-qemu-char.c
deleted file mode 100644
index 40a9b529f3b9..000000000000
--- a/emulators/qemu/files/patch-qemu-char.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- qemu-char.c.orig 2015-12-16 00:54:18 UTC
-+++ qemu-char.c
-@@ -1507,10 +1507,14 @@ static void tty_serial_init(int fd, int
- cfsetospeed(&tty, spd);
-
- tty.c_iflag &= ~(IGNBRK|BRKINT|PARMRK|ISTRIP
-- |INLCR|IGNCR|ICRNL|IXON);
-- tty.c_oflag |= OPOST;
-+ |INLCR|IGNCR|ICRNL|IXON|IMAXBEL);
-+ tty.c_oflag &= ~OPOST; /* Don't do any output processing! */
- tty.c_lflag &= ~(ECHO|ECHONL|ICANON|IEXTEN|ISIG);
- tty.c_cflag &= ~(CSIZE|PARENB|PARODD|CRTSCTS|CSTOPB);
-+#ifdef __FreeBSD__
-+ cfmakeraw(&tty);
-+#endif
-+
- switch(data_bits) {
- default:
- case 8:
diff --git a/emulators/qemu/files/pcap-patch b/emulators/qemu/files/pcap-patch
index d0771e128377..1565a2416c0f 100644
--- a/emulators/qemu/files/pcap-patch
+++ b/emulators/qemu/files/pcap-patch
@@ -1,17 +1,26 @@
---- qapi-schema.json.orig 2016-12-20 13:16:49.000000000 -0700
-+++ qapi-schema.json 2017-03-05 08:45:39.490366000 -0700
-@@ -2543,6 +2543,10 @@
- ##
- { 'command': 'netdev_del', 'data': {'id': 'str'} }
+--- qapi-schema.json.orig 2017-07-24 12:07:10 UTC
++++ qapi-schema.json
+@@ -3882,6 +3882,19 @@
+ '*helper': 'str' } }
+ ##
++# @NetdevPcapOptions:
++#
++# Use ifname as a source to capture
++#
++# @ifname: #required to determine which interface to capture
++#
++# Since: 1.2
++##
+{ 'struct': 'NetdevPcapOptions',
+ 'data': {
+ '*ifname': 'str' } }
+
- ##
- # @object-add:
++##
+ # @NetdevHubPortOptions:
#
-@@ -2966,7 +2970,7 @@
+ # Connect two or more net clients through a software hub.
+@@ -3944,7 +3957,7 @@
##
{ 'enum': 'NetClientDriver',
'data': [ 'none', 'nic', 'user', 'tap', 'l2tpv3', 'socket', 'vde', 'dump',
@@ -20,7 +29,7 @@
##
# @Netdev:
-@@ -2989,6 +2993,7 @@
+@@ -3967,6 +3980,7 @@
'nic': 'NetLegacyNicOptions',
'user': 'NetdevUserOptions',
'tap': 'NetdevTapOptions',
@@ -28,11 +37,20 @@
'l2tpv3': 'NetdevL2TPv3Options',
'socket': 'NetdevSocketOptions',
'vde': 'NetdevVdeOptions',
-@@ -3033,6 +3038,7 @@
+@@ -4005,7 +4019,7 @@
+ ##
+ { 'enum': 'NetLegacyOptionsType',
+ 'data': ['none', 'nic', 'user', 'tap', 'l2tpv3', 'socket', 'vde',
+- 'dump', 'bridge', 'netmap', 'vhost-user'] }
++ 'dump', 'bridge', 'netmap', 'vhost-user', 'pcap' ] }
+
+ ##
+ # @NetLegacyOptions:
+@@ -4022,6 +4036,7 @@
'nic': 'NetLegacyNicOptions',
'user': 'NetdevUserOptions',
'tap': 'NetdevTapOptions',
-+ 'pcap': 'NetdevPcapOptions',
++ 'pcap': 'NetdevPcapOptions',
'l2tpv3': 'NetdevL2TPv3Options',
'socket': 'NetdevSocketOptions',
'vde': 'NetdevVdeOptions',
diff --git a/emulators/qemu/pkg-plist b/emulators/qemu/pkg-plist
index 18ca80e66201..4ac2c5019cec 100644
--- a/emulators/qemu/pkg-plist
+++ b/emulators/qemu/pkg-plist
@@ -21,7 +21,8 @@ bin/qemu-system-i386
%%NO_X86_TARGETS%%bin/qemu-system-mips64el
%%NO_X86_TARGETS%%bin/qemu-system-mipsel
%%NO_X86_TARGETS%%bin/qemu-system-moxie
-%%NO_X86_TARGETS%%bin/qemu-system-or32
+%%NO_X86_TARGETS%%bin/qemu-system-nios2
+%%NO_X86_TARGETS%%bin/qemu-system-or1k
%%NO_X86_TARGETS%%bin/qemu-system-ppc
%%NO_X86_TARGETS%%bin/qemu-system-ppc64
%%NO_X86_TARGETS%%bin/qemu-system-ppcemb
@@ -38,6 +39,8 @@ bin/qemu-system-x86_64
bin/qemu-x86_64
man/man1/qemu.1.gz
man/man1/qemu-img.1.gz
+man/man7/qemu-ga-ref.7.gz
+man/man7/qemu-qmp-ref.7.gz
man/man8/qemu-ga.8.gz
man/man8/qemu-nbd.8.gz
@sample etc/qemu-ifup.sample