aboutsummaryrefslogtreecommitdiff
path: root/emulators/qmc2
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2020-05-31 12:42:19 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2020-05-31 12:42:19 +0000
commitb01da5e68f95f5133fcdc04abb0b62432acc69f2 (patch)
treefb0a0729ecf1149877f3ba3f2f26f5ae9b2ef1f3 /emulators/qmc2
parent4ea034dc857df509d0b26d20e11370ca20009015 (diff)
downloadports-b01da5e68f95f5133fcdc04abb0b62432acc69f2.tar.gz
ports-b01da5e68f95f5133fcdc04abb0b62432acc69f2.zip
Notes
Diffstat (limited to 'emulators/qmc2')
-rw-r--r--emulators/qmc2/Makefile10
-rw-r--r--emulators/qmc2/files/patch-qmc2_lzma_7zTypes.h23
2 files changed, 31 insertions, 2 deletions
diff --git a/emulators/qmc2/Makefile b/emulators/qmc2/Makefile
index 58015706e4a5..b2dc5311bd4a 100644
--- a/emulators/qmc2/Makefile
+++ b/emulators/qmc2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qmc2
PORTVERSION= 0.195
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= SF
@@ -17,7 +17,7 @@ OPTIONS_DEFINE= DOCS
NO_WRKSUBDIR= yes
-USES= compiler:c++11-lang gl gmake qt:5 sdl tar:bzip2 xorg
+USES= compiler:c++11-lang dos2unix gl gmake qt:5 sdl tar:bzip2 xorg
USE_XORG= x11 xmu
USE_GL= gl glu
USE_QT= buildtools_build core declarative gui multimedia \
@@ -40,6 +40,12 @@ DESKTOP_ENTRIES="QMC2" "MAME frontend" "${DATADIR}/img/mame.png" \
"CHDMAN GUI" "Qt CHDMAN GUI" "${DATADIR}/img/qchdman.png" \
"qchdman" "Game;Emulator;Qt;" "true" \
+# This seems to be third-party, and has DOS line-endings. It also
+# needs to be patched because of a confusing build error: #define True 1
+# is a bad idea in C++ code that *also* uses True as an identifier
+# in some scopes.
+DOS2UNIX_FILES= qmc2/lzma/7zTypes.h
+
post-patch:
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
@(cd ${WRKSRC}/qmc2/inst; ${SED} -e 's|DATADIR|${PREFIX}/share|' \
diff --git a/emulators/qmc2/files/patch-qmc2_lzma_7zTypes.h b/emulators/qmc2/files/patch-qmc2_lzma_7zTypes.h
new file mode 100644
index 000000000000..03ea8278da17
--- /dev/null
+++ b/emulators/qmc2/files/patch-qmc2_lzma_7zTypes.h
@@ -0,0 +1,23 @@
+This avoids errors list the following, where True is a C++
+identifier used in scoped context; the #define eats it.
+
+/usr/local/include/qt5/QtCore/qcborstreamreader.h:143:76: error: expected unqualified-id
+ bool isFalse() const { return isSimpleType(QCborSimpleType::False); }
+ ^
+lzma/7zTypes.h:98:15: note: expanded from macro 'False'
+#define False 0
+
+--- qmc2/lzma/7zTypes.h.orig 2020-05-30 14:14:41 UTC
++++ qmc2/lzma/7zTypes.h
+@@ -94,8 +94,11 @@ typedef size_t SizeT;
+ #endif
+
+ typedef int Bool_7z;
++#ifndef __cplusplus
++/* Only for library internals */
+ #define True 1
+ #define False 0
++#endif
+
+
+ #ifdef _WIN32