aboutsummaryrefslogtreecommitdiff
path: root/emulators/scummvm/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-26 19:28:47 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-26 19:28:47 +0000
commit5d3ebef53def78529aa54b0070360073a8f04fe0 (patch)
treef751679f6f2d3419d786a297e5814edd47b632f3 /emulators/scummvm/Makefile
parent092f407f34cab07e56dc8f9a8c8e3d51c8129e6d (diff)
downloadports-5d3ebef53def78529aa54b0070360073a8f04fe0.tar.gz
ports-5d3ebef53def78529aa54b0070360073a8f04fe0.zip
Notes
Diffstat (limited to 'emulators/scummvm/Makefile')
-rw-r--r--emulators/scummvm/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/emulators/scummvm/Makefile b/emulators/scummvm/Makefile
new file mode 100644
index 000000000000..f365203e2c84
--- /dev/null
+++ b/emulators/scummvm/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: scummvm
+# Date created: Tue Mar 26 13:05:21 CET 2002
+# Whom: Miguel Mendez <flynn@energyhq.homeip.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scummvm
+PORTVERSION= 0.1.0
+CATEGORIES= games emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}b
+
+MAINTAINER= flynn@energyhq.homeip.net
+
+LIB_DEPENDS= SDL-1.1.3:${PORTSDIR}/devel/sdl12
+
+USE_ZIP= yes
+USE_GMAKE= yes
+NO_WRKSUBDIR= yes
+
+pre-patch:
+ @${FIND} -E ${WRKSRC} -type f -iregex ".*\.(cpp|h|txt)" \
+ -exec ${PERL} -pi -ne 's!\r\n!\n!' {} 1>/dev/null 2>&1 \;
+ @${PERL} -pi -e 's|\r\n|\n|' ${WRKSRC}/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/scummvm ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docs in copying.txt readme.txt whatsnew.txt
+ @${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>