aboutsummaryrefslogtreecommitdiff
path: root/emulators/simh-hpdoc
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2020-05-05 10:06:08 +0000
committerKurt Jaeger <pi@FreeBSD.org>2020-05-05 10:06:08 +0000
commit7cbc7596858edbe3fcbb30d6a98d2b7fbfb4d38a (patch)
tree1ba0d593591901f977a7d847e2025e5f6c6adfc3 /emulators/simh-hpdoc
parentb8306318616c225d2d7f5680ebcbdce26154c755 (diff)
downloadports-7cbc7596858edbe3fcbb30d6a98d2b7fbfb4d38a.tar.gz
ports-7cbc7596858edbe3fcbb30d6a98d2b7fbfb4d38a.zip
Notes
Diffstat (limited to 'emulators/simh-hpdoc')
-rw-r--r--emulators/simh-hpdoc/Makefile55
-rw-r--r--emulators/simh-hpdoc/distinfo9
-rw-r--r--emulators/simh-hpdoc/files/LICENSE23
-rw-r--r--emulators/simh-hpdoc/files/hpdoc.1.in28
-rw-r--r--emulators/simh-hpdoc/pkg-descr5
-rw-r--r--emulators/simh-hpdoc/pkg-plist5
6 files changed, 125 insertions, 0 deletions
diff --git a/emulators/simh-hpdoc/Makefile b/emulators/simh-hpdoc/Makefile
new file mode 100644
index 000000000000..779ffd48a9f6
--- /dev/null
+++ b/emulators/simh-hpdoc/Makefile
@@ -0,0 +1,55 @@
+# $FreeBSD$
+
+PORTNAME= hpdoc
+DISTVERSION= 3.11.0
+CATEGORIES= emulators
+MASTER_SITES= http://simh.trailing-edge.com/hp/releases/:src \
+ http://simh.trailing-edge.com/hp/docs/:app \
+ http://www.ml1.org.uk/distfiles/:src \
+ http://www.ml1.org.uk/distfiles/:app
+PKGNAMEPREFIX= simh-
+DISTFILES= HP2100-source-release-29.zip:src \
+ HP3000-source-release-8.zip:src \
+ running_hp_2000_tsb.pdf:app \
+ hp_1000_io_simulation.pdf:app
+DIST_SUBDIR= simh-hp
+EXTRACT_ONLY= HP2100-source-release-29.zip \
+ HP3000-source-release-8.zip
+
+MAINTAINER= bob@eager.cx
+COMMENT= Documentation for emulators of classic HP 2100 and HP 3000 computers
+
+LICENSE= SIMHv1
+LICENSE_NAME= SIMH License
+LICENSE_FILE= ${FILESDIR}/LICENSE
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+USES= zip
+
+NO_WRKSUBDIR= yes
+
+CONFLICTS_INSTALL= simh-3.[789]*
+
+OPTIONS_DEFINE= APPNOTES
+OPTIONS_DEFAULT= APPNOTES
+OPTIONS_SUB= yes
+APPNOTES_DESC= Install application notes
+
+SUB_FILES= hpdoc.1
+
+.include <bsd.port.pre.mk>
+
+do-build: # nothing to do
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/SCP/doc/simh_doc.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/SCP/doc/simh_supplement.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKDIR}/hpdoc.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+do-install-APPNOTES-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${DISTDIR}/${DIST_SUBDIR}/running_hp_2000_tsb.pdf ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${DISTDIR}/${DIST_SUBDIR}/hp_1000_io_simulation.pdf ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/simh-hpdoc/distinfo b/emulators/simh-hpdoc/distinfo
new file mode 100644
index 000000000000..9d444ecc7e76
--- /dev/null
+++ b/emulators/simh-hpdoc/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1582556365
+SHA256 (simh-hp/HP2100-source-release-29.zip) = e381eb51cdbea84a729fe0fa45001b7a864adcbf97438af0c788696b0c18c0bf
+SIZE (simh-hp/HP2100-source-release-29.zip) = 1890682
+SHA256 (simh-hp/HP3000-source-release-8.zip) = 2c003841b8c189299d45253520fd687694687c0a023aae9c79650234948b5a66
+SIZE (simh-hp/HP3000-source-release-8.zip) = 1412655
+SHA256 (simh-hp/running_hp_2000_tsb.pdf) = 905f8748d38b60a2f128961126086268f5f1485d625572333fee418beec85300
+SIZE (simh-hp/running_hp_2000_tsb.pdf) = 111280
+SHA256 (simh-hp/hp_1000_io_simulation.pdf) = 64a523a8237ed6143614c1b0747f5aa933b8e77e2cf5daf9fe62a3845aea8dc8
+SIZE (simh-hp/hp_1000_io_simulation.pdf) = 272289
diff --git a/emulators/simh-hpdoc/files/LICENSE b/emulators/simh-hpdoc/files/LICENSE
new file mode 100644
index 000000000000..c613c9a7c183
--- /dev/null
+++ b/emulators/simh-hpdoc/files/LICENSE
@@ -0,0 +1,23 @@
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject
+to the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+Except as contained in this notice, the names of the authors shall not
+be used in advertising or otherwise to promote the sale, use or other
+dealings in this Software without prior written authorization from the
+authors.
diff --git a/emulators/simh-hpdoc/files/hpdoc.1.in b/emulators/simh-hpdoc/files/hpdoc.1.in
new file mode 100644
index 000000000000..1ab201cd32b7
--- /dev/null
+++ b/emulators/simh-hpdoc/files/hpdoc.1.in
@@ -0,0 +1,28 @@
+.Dd February 23, 2020
+.Dt HPDOC 1 CON
+.Os
+.Sh NAME
+.Nm hpdoc
+.Nd Documentation for HP 21xx/1000 and HP3000 computers
+.Sh DESCRIPTION
+.Xr hp2100
+and
+.Xr hp3000
+are simulators for a number of HP computers.
+See the appropriate manual pages for more details.
+.Pp
+Much of the documentation is simulator specific, but there
+is also some generic documentation.
+.Pp
+It can be found at
+.Pa %%DOCSDIR%% ,
+.br
+and also at
+.Pa http://simh.trailing-edge.com/hp/#Documentation .
+.Sh SEE ALSO
+.Xr hp2100 1 ,
+.Xr hp3000 1 .
+.Sh AUTHORS
+.An "J. David Bryan, Robert M. Supnik and others" .
+.Fx "port maintenance, and this manual page, by"
+.An "Bob Eager" Aq bob@eager.cx .
diff --git a/emulators/simh-hpdoc/pkg-descr b/emulators/simh-hpdoc/pkg-descr
new file mode 100644
index 000000000000..adfb02f70838
--- /dev/null
+++ b/emulators/simh-hpdoc/pkg-descr
@@ -0,0 +1,5 @@
+This is the generic documentation for the HP 2100 and HP 3000
+simulators. It is packaged separately to avoid conflicts and
+duplications between the individual simulator packages.
+
+WWW: http://simh.trailing-edge.com/hp/
diff --git a/emulators/simh-hpdoc/pkg-plist b/emulators/simh-hpdoc/pkg-plist
new file mode 100644
index 000000000000..2922e72c05b9
--- /dev/null
+++ b/emulators/simh-hpdoc/pkg-plist
@@ -0,0 +1,5 @@
+man/man1/hpdoc.1.gz
+%%DOCSDIR%%/simh_doc.pdf
+%%DOCSDIR%%/simh_supplement.pdf
+%%APPNOTES%%%%DOCSDIR%%/hp_1000_io_simulation.pdf
+%%APPNOTES%%%%DOCSDIR%%/running_hp_2000_tsb.pdf