aboutsummaryrefslogtreecommitdiff
path: root/emulators/snes9x-gtk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:20:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:20:28 +0000
commitf53196ebc931edf54afe56ab65deddc4f2d5b8fb (patch)
tree17f3405d36f74dd57d11bda9e7ecc80c2929914c /emulators/snes9x-gtk
parent02ad6b1271fd43ec6fd524c9a6957530cd83d262 (diff)
downloadports-f53196ebc931edf54afe56ab65deddc4f2d5b8fb.tar.gz
ports-f53196ebc931edf54afe56ab65deddc4f2d5b8fb.zip
Convert emulators to new options framework
Notes
Notes: svn path=/head/; revision=316753
Diffstat (limited to 'emulators/snes9x-gtk')
-rw-r--r--emulators/snes9x-gtk/Makefile40
1 files changed, 17 insertions, 23 deletions
diff --git a/emulators/snes9x-gtk/Makefile b/emulators/snes9x-gtk/Makefile
index 69d8746915da..d3e793e56c7a 100644
--- a/emulators/snes9x-gtk/Makefile
+++ b/emulators/snes9x-gtk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: snes9x-gtk
-# Date created: 2009-12-12
-# Whom: okeeblow <root@cooltrainer.org>
-#
+# Created by: okeeblow <root@cooltrainer.org>
# $FreeBSD$
-#
PORTNAME= snes9x
PORTVERSION= 1.52r79
@@ -32,65 +28,63 @@ CONFIGURE_ARGS+= --without-alsa
WRKSRC= ${WRKDIR}/${DISTNAME}/gtk
-OPTIONS= DEBUG "Enable debug information" off \
- OPENGL "Enable OpenGL support" off \
- X86_ASM "Use i386 optimization (only for i386)" on \
- MMX "Enable MMX (only for i386)" off \
- JMA "Enable JMA archive decompression support" on \
- NETPLAY "Enable network support" on \
- XV "Enable XVideo output on GTK" on \
- XRANDR "Enable XRandR support on GTK" on
+OPTIONS_DEFINE= DEBUG OPENGL JMA NETPLAY XV XRANDR
+OPTIONS_DEFAULT= JMA NETPLAY XV XRANDR
+OPTIONS_DEFINE_i386= ASM MMX
+OPTIONS_DEFAULT_i386= ASM
+JMA_DESC= Enable JMA archive decompression support
+NETPLAY_DESC= Enable network support
+XV_DESC= Enable XVideo output on GTK
+XRANDR_DESC= Enable XRandR support on GTK
.include <bsd.port.pre.mk>
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --with-debug
.else
CONFIGURE_ARGS+= --without-debug
.endif
-.if ${ARCH} == "i386"
-.if !defined(WITHOUT_X86_ASM)
+.if ${PORT_OPTIONS:MASM}
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
CONFIGURE_ARGS+= --with-assembler
.else
CONFIGURE_ARGS+= --without-assembler
.endif
-.if defined(WITH_MMX) && !defined(PACKAGE_BUILDING)
+.if ${PORT_OPTIONS:MMMX} && !defined(PACKAGE_BUILDING)
CONFIGURE_ARGS+= --with-mmx
.else
CONFIGURE_ARGS+= --without-mmx
.endif
-.endif
-.if !defined(WITHOUT_OPENGL)
+.if ${PORT_OPTIONS:MOPENGL}
CONFIGURE_ARGS+= --with-opengl
USE_GL= glu
.else
CONFIGURE_ARGS+= --without-opengl
.endif
-.if !defined(WITHOUT_JMA)
+.if ${PORT_OPTIONS:MJMA}
CONFIGURE_ARGS+= --with-jma-decomp
.else
CONFIGURE_ARGS+= --without-jma-decomp
.endif
-.if !defined(WITHOUT_NETPLAY)
+.if ${PORT_OPTIONS:MNETPLAY}
CONFIGURE_ARGS+= --with-netplay
.else
CONFIGURE_ARGS+= --without-netplay
.endif
-.if !defined(WITHOUT_XV)
+.if ${PORT_OPTIONS:MXV}
CONFIGURE_ARGS+= --with-xv
USE_XORG+= xv
.else
CONFIGURE_ARGS+= --without-xv
.endif
-.if !defined(WITHOUT_XRANDR)
+.if ${PORT_OPTIONS:MXRANDR}
CONFIGURE_ARGS+= --with-xrandr
USE_XORG+= xrandr
.else