aboutsummaryrefslogtreecommitdiff
path: root/emulators/spim
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2006-07-17 14:23:11 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2006-07-17 14:23:11 +0000
commit9caec493c732c82c65f457724998a51eea1bec73 (patch)
tree900d9e7657869805730c6246682d608b202679cb /emulators/spim
parentcdddf348ff8f3655560b5a4ec252121578eeed1a (diff)
downloadports-9caec493c732c82c65f457724998a51eea1bec73.tar.gz
ports-9caec493c732c82c65f457724998a51eea1bec73.zip
Propagate ${PREFIX} and other environment variables to child sub-makes.
Notes
Notes: svn path=/head/; revision=168079
Diffstat (limited to 'emulators/spim')
-rw-r--r--emulators/spim/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/emulators/spim/Makefile b/emulators/spim/Makefile
index 4bea5bbec688..74bccc93cc43 100644
--- a/emulators/spim/Makefile
+++ b/emulators/spim/Makefile
@@ -8,6 +8,7 @@
PORTNAME= spim
PORTVERSION= 7.2.1
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://www.cs.wisc.edu/~larus/SPIM/
@@ -36,15 +37,21 @@ MAN1+= xspim.1
do-configure:
do-build:
- cd ${WRKSRC}/spim && ${MAKE}
+ cd ${WRKSRC}/spim && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE}
.if defined(WITH_GUI)
- cd ${WRKSRC}/xspim && ${XMKMF} && ${MAKE}
+ cd ${WRKSRC}/xspim && ${XMKMF} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE}
.endif
do-install:
- cd ${WRKSRC}/spim && ${MAKE} ${INSTALL_TARGET}
+ cd ${WRKSRC}/spim && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${INSTALL_TARGET}
.if defined(WITH_GUI)
- cd ${WRKSRC}/xspim && ${MAKE} ${INSTALL_TARGET}
+ cd ${WRKSRC}/xspim && \
+ ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} \
+ ${INSTALL_TARGET}
${INSTALL_MAN} ${WRKSRC}/Documentation/xspim.man ${PREFIX}/man/man1/xspim.1
.endif