aboutsummaryrefslogtreecommitdiff
path: root/emulators/tme
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-10-03 21:44:11 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-10-03 21:44:11 +0000
commit6d3721a17aef5b76c0343ef7bd391c5cae548af6 (patch)
tree939f5278951822e1c4e4196aef1af748e8195a8d /emulators/tme
parentc166489a460f5e315dec681b3b16215e68d4ad5a (diff)
downloadports-6d3721a17aef5b76c0343ef7bd391c5cae548af6.tar.gz
ports-6d3721a17aef5b76c0343ef7bd391c5cae548af6.zip
Convert to USES=autoreconf
Notes
Notes: svn path=/head/; revision=369938
Diffstat (limited to 'emulators/tme')
-rw-r--r--emulators/tme/Makefile7
-rw-r--r--emulators/tme/files/patch-configure.in18
2 files changed, 20 insertions, 5 deletions
diff --git a/emulators/tme/Makefile b/emulators/tme/Makefile
index 8cb07ed089af..556af0403c19 100644
--- a/emulators/tme/Makefile
+++ b/emulators/tme/Makefile
@@ -15,9 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
-USES= compiler gettext gmake iconv libtool perl5 pkgconfig
-USE_AUTOTOOLS= libtoolize aclocal autoconf autoheader automake
-AUTOMAKE_ARGS= -a -c -f
+USES= autoreconf compiler gettext gmake iconv libtool perl5 pkgconfig
USE_GNOME= gdkpixbuf2 gtk20
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -37,6 +35,9 @@ CFLAGS+= -fbracket-depth=1024
.endif
post-patch:
+ @${RM} -r ${WRKSRC}/libltdl
+ @${REINPLACE_CMD} 's/LTDL_SHLIBPATH_VAR/LT_MODULE_PATH_VAR/' \
+ ${WRKSRC}/libtme/Makefile.am ${WRKSRC}/libtme/module.c
@${REINPLACE_CMD} -e '/^#ifdef/s|\*/||' \
${WRKSRC}/libtme/misc.c
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
diff --git a/emulators/tme/files/patch-configure.in b/emulators/tme/files/patch-configure.in
index 31e2e1c66d65..c30979246962 100644
--- a/emulators/tme/files/patch-configure.in
+++ b/emulators/tme/files/patch-configure.in
@@ -1,6 +1,6 @@
--- configure.in.orig
+++ configure.in
-@@ -599,7 +599,7 @@
+@@ -599,18 +599,16 @@
esac
changequote([, ])dnl
AC_MSG_RESULT([${misc_hosts}])
@@ -9,7 +9,21 @@
misc_hosts=
fi
-@@ -683,11 +683,8 @@
+ dnl Configure for libtool.
+-AC_LIBLTDL_INSTALLABLE
++LT_CONFIG_LTDL_DIR([libltdl])
++LT_INIT([dlopen])
++LTDL_INIT([installable])
+ AC_SUBST(INCLTDL)
+ AC_SUBST(LIBLTDL)
+-AC_LIBTOOL_DLOPEN
+-AM_PROG_LIBTOOL
+-AC_SUBST(LTLIBOBJS)
+-AC_CONFIG_SUBDIRS(libltdl)
+ TME_PREOPEN=
+ if test $enable_shared = no; then
+ TME_PREOPEN='`sort -u $(top_builddir)/tme-preopen.txt`'
+@@ -683,11 +681,8 @@
#define _TMECONFIG_H
TMEEOF