aboutsummaryrefslogtreecommitdiff
path: root/emulators/tuxnes
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-07 19:13:05 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-07 19:13:05 +0000
commitd208cc8f7d50a64e981bd6aa633739b011de301a (patch)
tree5b4346808d7bc89cacbe8b44a564397beccfa0da /emulators/tuxnes
parent419b58ecc3f9fbf513bb272702e83b327234c1fc (diff)
downloadports-d208cc8f7d50a64e981bd6aa633739b011de301a.tar.gz
ports-d208cc8f7d50a64e981bd6aa633739b011de301a.zip
Fix build with gcc-3.4.2
Support PLIST_FILES PR: ports/70115 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=115567
Diffstat (limited to 'emulators/tuxnes')
-rw-r--r--emulators/tuxnes/Makefile12
-rw-r--r--emulators/tuxnes/files/patch-emu.c38
-rw-r--r--emulators/tuxnes/pkg-plist2
3 files changed, 45 insertions, 7 deletions
diff --git a/emulators/tuxnes/Makefile b/emulators/tuxnes/Makefile
index 9b61fd3754b8..ffca9b163c67 100644
--- a/emulators/tuxnes/Makefile
+++ b/emulators/tuxnes/Makefile
@@ -15,11 +15,13 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Nintendo Entertainment System 8-bit emulator
-USE_GETOPT_LONG=yes
-USE_GMAKE= YES
-USE_X_PREFIX= YES
-GNU_CONFIGURE= YES
-
ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+USE_GETOPT_LONG= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/romfixer bin/tuxnes
+
.include <bsd.port.mk>
diff --git a/emulators/tuxnes/files/patch-emu.c b/emulators/tuxnes/files/patch-emu.c
new file mode 100644
index 000000000000..e31930bae6c9
--- /dev/null
+++ b/emulators/tuxnes/files/patch-emu.c
@@ -0,0 +1,38 @@
+--- emu.c.orig Thu Apr 12 06:45:47 2001
++++ emu.c Wed Aug 4 18:34:38 2004
+@@ -890,7 +890,7 @@
+ len = strlen(palfile) + 1;
+ if (! (buffer = malloc(len)))
+ {
+- perror (__FUNCTION__ ": malloc");
++ perror ("loadpal 892: malloc");
+ return;
+ }
+ memcpy (buffer, palfile, len);
+@@ -912,7 +912,7 @@
+ len = strlen(filename) + 1;
+ if (! (buffer = malloc(len)))
+ {
+- perror (__FUNCTION__ ": malloc");
++ perror ("loadpal 914: malloc");
+ return;
+ }
+ memcpy (buffer, filename, len);
+@@ -924,7 +924,7 @@
+ return;
+ if (!(palfile = malloc ((len = strlen (filename)) + 11)))
+ {
+- perror (__FUNCTION__ ": malloc");
++ perror ("loadpal 933: malloc");
+ return;
+ }
+ strcpy (palfile, filename);
+@@ -1602,7 +1602,7 @@
+
+ if (! (basefilename = malloc(baseend - basestart + 1)))
+ {
+- perror (__FUNCTION__ ": malloc");
++ perror ("main: malloc");
+ exit (1);
+ }
+
diff --git a/emulators/tuxnes/pkg-plist b/emulators/tuxnes/pkg-plist
deleted file mode 100644
index d7c4bc0eeae4..000000000000
--- a/emulators/tuxnes/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/romfixer
-bin/tuxnes