aboutsummaryrefslogtreecommitdiff
path: root/emulators/tuxnes
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-01-19 13:49:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-01-19 13:49:20 +0000
commiteab3437cdb612058db7491fdb97d0feb29a7a3fb (patch)
tree2b9f583831a83520a1fc2f57af3ebd9895366145 /emulators/tuxnes
parente45a96b5be2fcb4d9f343bae9747fae2b7c6c25a (diff)
downloadports-eab3437cdb612058db7491fdb97d0feb29a7a3fb.tar.gz
ports-eab3437cdb612058db7491fdb97d0feb29a7a3fb.zip
- Fix build with clang
- Add LICENSE - Add DESKTOP_ENTRIES PR: 185310 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=340296
Diffstat (limited to 'emulators/tuxnes')
-rw-r--r--emulators/tuxnes/Makefile31
1 files changed, 25 insertions, 6 deletions
diff --git a/emulators/tuxnes/Makefile b/emulators/tuxnes/Makefile
index fc7a8869ac60..2d16b07c417f 100644
--- a/emulators/tuxnes/Makefile
+++ b/emulators/tuxnes/Makefile
@@ -3,21 +3,40 @@
PORTNAME= tuxnes
PORTVERSION= 0.75
-PORTREVISION= 4
+PORTREVISION= 6
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/TuxNES/TuxNES%20v${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Nintendo Entertainment System 8-bit emulator
+COMMENT= Nintendo Entertainment System 8-bit emulator
+
+LICENSE= GPLv2
ONLY_FOR_ARCHS= i386
ONLY_FOR_ARCHS_REASON= uses i386 assembly code
+USES= compiler gmake
USE_XORG= x11 ice sm xext xpm
-USE_GMAKE= yes
+USE_BINUTILS= yes
GNU_CONFIGURE= yes
-PLIST_FILES= bin/romfixer bin/tuxnes
+PLIST_FILES= bin/romfixer bin/tuxnes share/pixmaps/tuxnes.xpm
+
+DESKTOP_ENTRIES="TuxNES" "" "${PREFIX}/share/pixmaps/tuxnes.xpm" \
+ "${PORTNAME}" "" ""
+
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == "clang"
+CPPFLAGS+= -no-integrated-as
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^CFLAGS=|#CFLAGS=|' ${WRKSRC}/configure
+
+post-install:
+ (cd ${WRKSRC} && ${INSTALL_DATA} tuxnes.xpm \
+ ${STAGEDIR}${PREFIX}/share/pixmaps)
-NO_STAGE= yes
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>