aboutsummaryrefslogtreecommitdiff
path: root/emulators/twin/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-08-05 21:01:05 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-08-05 21:01:05 +0000
commit20012ff070b9a07e5b955384e3d5da81842de09e (patch)
tree95fe792928713d4be3bdef7a4d82f2424ef38808 /emulators/twin/Makefile
parent2e02d4439dfe42ad57fb7b469e257f18a7772ea6 (diff)
downloadports-20012ff070b9a07e5b955384e3d5da81842de09e.tar.gz
ports-20012ff070b9a07e5b955384e3d5da81842de09e.zip
Notes
Diffstat (limited to 'emulators/twin/Makefile')
-rw-r--r--emulators/twin/Makefile44
1 files changed, 27 insertions, 17 deletions
diff --git a/emulators/twin/Makefile b/emulators/twin/Makefile
index 3ff3558e69d7..c94440b6c0f3 100644
--- a/emulators/twin/Makefile
+++ b/emulators/twin/Makefile
@@ -6,35 +6,45 @@
#
PORTNAME= twin
-PORTVERSION= 1999.12.30
+PORTVERSION= 3.1.14
+PORTEPOCH= 1
CATEGORIES= emulators devel
-MASTER_SITES= ftp://ftp.willows.com/pub/development/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
+MASTER_SITES= ftp://ftp.willows.com/pub/twin/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-WRKSRC= $(WRKDIR)/twin
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
USE_XLIB= yes
-INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-debugger
ALL_TARGET= depend world
-CONFIGURE_ARGS=
+PLIST_SUB= LIBVER="${LIBVER}"
+INSTALLS_SHLIB= yes
-# This hack is in order to avoid a build error with optimizations on,
-# a real bugfix will surely come soon.
-pre-patch:
- ${CP} $(WRKSRC)/windows/if32.s $(WRKSRC)/windows/if32.S
+FMT?= /usr/bin/fmt
-pre-configure:
- ${ECHO} "configure_args = ${CONFIGURE_ARGS}"
- ${ECHO} "configure_env = ${CONFIGURE_ENV}"
+LIBRARIES= libadvapi32.so libcomctl32.so libcomm.so \
+ libcommdlg.so libddeml.so libkeyboard.so \
+ liblzexpand.so libmmsystem.so libmsvcrt.so \
+ libolecli.so libolesvr.so libpe32.so \
+ libshell.so libsound.so libsystem.so \
+ libtoolhelp.so libtwin32.so libversion.so \
+ libw32sys.so libwin87em.so libwinsock.so \
+ libwinspool.so
+LIBVER= 0
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/twin
- ${INSTALL_DATA} ${WRKSRC}/documentation/* ${PREFIX}/share/doc/twin
- ${GZIP_CMD} ${PREFIX}/share/doc/twin/*
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/documentation/* ${DOCSDIR}
.endif
+# version these libraries to make ldconfig happy
+.for lib in ${LIBRARIES}
+ @${LN} -sf ${lib} ${PREFIX}/lib/${lib}.${LIBVER}
+.endfor
+ @${FMT} ${PKGMESSAGE}
.include <bsd.port.mk>