aboutsummaryrefslogtreecommitdiff
path: root/emulators/uae/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2002-04-20 17:04:48 +0000
committerAnders Nordby <anders@FreeBSD.org>2002-04-20 17:04:48 +0000
commit789a860dad0d654df0b1c45b9ef5a38c05fb9b84 (patch)
tree5e9eae1cfe6284557e15813c88ae6c4faed1b107 /emulators/uae/Makefile
parent43b27cb8ba306196402b9e95633d7b0cdc1ec191 (diff)
downloadports-789a860dad0d654df0b1c45b9ef5a38c05fb9b84.tar.gz
ports-789a860dad0d654df0b1c45b9ef5a38c05fb9b84.zip
Enable threading, enable the GUI.
PR: 36848 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=57932
Diffstat (limited to 'emulators/uae/Makefile')
-rw-r--r--emulators/uae/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/emulators/uae/Makefile b/emulators/uae/Makefile
index f6408e569f45..f69333f617c8 100644
--- a/emulators/uae/Makefile
+++ b/emulators/uae/Makefile
@@ -7,6 +7,7 @@
PORTNAME= uae
PORTVERSION= 0.8.21
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.freiburg.linux.de/pub/uae/sources/develop/
@@ -14,8 +15,15 @@ MAINTAINER= simond@irrelevant.org
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-sound --enable-vidmode --enable-dga --disable-ui
+CONFIGURE_ARGS= --enable-sound --enable-vidmode --enable-dga
USE_XLIB= yes
+USE_GTK= yes
+
+CFLAGS+= ${PTHREAD_CFLAGS}
+
+pre-configure:
+ @${PERL} -pi.orig -e 's:-lpthread:${PTHREAD_LIBS}:g' \
+ ${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/uae ${PREFIX}/bin