aboutsummaryrefslogtreecommitdiff
path: root/emulators/vba
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-01 20:22:05 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-02-01 20:22:05 +0000
commite019fe53d931b6594d7ea3d49b98cb04ab671026 (patch)
tree6821f72106d4d270ff34987ab9d22236ccdaf681 /emulators/vba
parent526d47e271d9f12c4d717177d29bde9022c929aa (diff)
downloadports-e019fe53d931b6594d7ea3d49b98cb04ab671026.tar.gz
ports-e019fe53d931b6594d7ea3d49b98cb04ab671026.zip
emulators/vba: unbreak with libc++ 3.9
../GBA.cpp:1133:12: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char * p = strrchr(file,'.'); ^ ~~~~~~~~~~~~~~~~~ ../GBA.cpp:1148:12: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char * p = strrchr(file,'.'); ^ ~~~~~~~~~~~~~~~~~ ../GBA.cpp:1172:12: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char * p = strrchr(file,'.'); ^ ~~~~~~~~~~~~~~~~~ ../GBA.cpp:1192:12: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char * p = strrchr(file,'.'); ^ ~~~~~~~~~~~~~~~~~ ../Util.cpp:481:12: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char * p = strrchr(file,'.'); ^ ~~~~~~~~~~~~~~~~~ ../Util.cpp:505:12: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char * p = strrchr(file,'.'); ^ ~~~~~~~~~~~~~~~~~ ../Util.cpp:525:12: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char * p = strrchr(file,'.'); ^ ~~~~~~~~~~~~~~~~~ ../Util.cpp:555:12: error: cannot initialize a variable of type 'char *' with an rvalue of type 'const char *' char * p = strrchr(file,'.'); ^ ~~~~~~~~~~~~~~~~~ In file included from expr.y:12: In file included from ../../src/System.h:24: In file included from ../../src/unzip.h:68: In file included from /usr/include/zlib.h:34: In file included from /usr/include/zconf.h:247: /usr/include/c++/v1/stddef.h:52:7: error: reference to 'std' is ambiguous using std::nullptr_t; ^ /usr/include/c++/v1/__nullptr:22:1: note: candidate found by name lookup is 'std' _LIBCPP_BEGIN_NAMESPACE_STD ^ /usr/include/c++/v1/__config:388:47: note: expanded from macro '_LIBCPP_BEGIN_NAMESPACE_STD' #define _LIBCPP_BEGIN_NAMESPACE_STD namespace std {inline namespace _LIBCPP_NAMESPACE { ^ /usr/include/c++/v1/__config:392:11: note: candidate found by name lookup is 'std::std' namespace std { ^ Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=433097
Diffstat (limited to 'emulators/vba')
-rw-r--r--emulators/vba/Makefile2
-rw-r--r--emulators/vba/files/patch-src-Util.cpp45
-rw-r--r--emulators/vba/files/patch-src_GBA.cpp38
-rw-r--r--emulators/vba/files/patch-src_expr.cpp19
4 files changed, 102 insertions, 2 deletions
diff --git a/emulators/vba/Makefile b/emulators/vba/Makefile
index 6ee0a085ece9..6e96b04f4048 100644
--- a/emulators/vba/Makefile
+++ b/emulators/vba/Makefile
@@ -53,8 +53,6 @@ GTK2_DATA_FILES= ${WRKSRC}/src/gtk/vba.glade
post-patch:
@${REINPLACE_CMD} -e '/for(int i = 0; i < 16; i++/s| i|&_|g' \
${WRKSRC}/src/sdl/debugger.cpp
- @${REINPLACE_CMD} -e '/^namespace std/ { x; \
- s|^|#include <sys/types.h>|; H; x; }' ${WRKSRC}/src/expr.cpp
do-install:
${INSTALL_PROGRAM} ${PROG_FILES} ${STAGEDIR}${PREFIX}/bin
diff --git a/emulators/vba/files/patch-src-Util.cpp b/emulators/vba/files/patch-src-Util.cpp
index 6fc6be57bffa..02b50f49fa45 100644
--- a/emulators/vba/files/patch-src-Util.cpp
+++ b/emulators/vba/files/patch-src-Util.cpp
@@ -9,6 +9,51 @@
png_destroy_write_struct(&png_ptr,NULL);
fclose(fp);
return false;
+@@ -478,7 +478,7 @@ bool utilIsGBAImage(const char * file)
+ {
+ cpuIsMultiBoot = false;
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gba") == 0)
+@@ -502,7 +502,7 @@ bool utilIsGBAImage(const char * file)
+ bool utilIsGBImage(const char * file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gb") == 0)
+@@ -522,7 +522,7 @@ bool utilIsGBImage(const char * file)
+ bool utilIsZipFile(const char *file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".zip") == 0)
+@@ -537,7 +537,7 @@ bool utilIsZipFile(const char *file)
+ bool utilIsRarFile(const char *file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".rar") == 0)
+@@ -552,7 +552,7 @@ bool utilIsRarFile(const char *file)
+ bool utilIsGzipFile(const char *file)
+ {
+ if(strlen(file) > 3) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gz") == 0)
@@ -984,7 +984,7 @@ void utilWriteData(gzFile gzFile, variab
gzFile utilGzOpen(const char *file, const char *mode)
diff --git a/emulators/vba/files/patch-src_GBA.cpp b/emulators/vba/files/patch-src_GBA.cpp
new file mode 100644
index 000000000000..20fbbadbd7f1
--- /dev/null
+++ b/emulators/vba/files/patch-src_GBA.cpp
@@ -0,0 +1,38 @@
+--- src/GBA.cpp.orig 2004-05-13 14:37:59 UTC
++++ src/GBA.cpp
+@@ -1130,7 +1130,7 @@ bool CPUWriteBMPFile(const char *fileNam
+ bool CPUIsZipFile(const char * file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".zip") == 0)
+@@ -1145,7 +1145,7 @@ bool CPUIsGBAImage(const char * file)
+ {
+ cpuIsMultiBoot = false;
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gba") == 0)
+@@ -1169,7 +1169,7 @@ bool CPUIsGBAImage(const char * file)
+ bool CPUIsGBABios(const char * file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".gba") == 0)
+@@ -1189,7 +1189,7 @@ bool CPUIsGBABios(const char * file)
+ bool CPUIsELF(const char *file)
+ {
+ if(strlen(file) > 4) {
+- char * p = strrchr(file,'.');
++ const char * p = strrchr(file,'.');
+
+ if(p != NULL) {
+ if(_stricmp(p, ".elf") == 0)
diff --git a/emulators/vba/files/patch-src_expr.cpp b/emulators/vba/files/patch-src_expr.cpp
new file mode 100644
index 000000000000..e500e6062cd4
--- /dev/null
+++ b/emulators/vba/files/patch-src_expr.cpp
@@ -0,0 +1,19 @@
+--- src/expr.cpp.orig 2002-10-20 13:03:12 UTC
++++ src/expr.cpp
+@@ -14,15 +14,12 @@
+
+ #line 1 "expr.y"
+
+-namespace std {
++#include <sys/types.h>
+ #include <stdio.h>
+ #include <memory.h>
+ #include <stdlib.h>
+ #include <string.h>
+-}
+
+-using namespace std;
+-
+ #include "System.h"
+ #include "elf.h"
+ #include "exprNode.h"