aboutsummaryrefslogtreecommitdiff
path: root/emulators/vboxtool
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-07-06 14:48:47 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-07-06 14:48:47 +0000
commitcff87df13351e5b3c77e7b583cfd595baa2ee43e (patch)
tree45895a7951e258d01218305c96bff57b830ae407 /emulators/vboxtool
parent041923401e3a1073db5b89f678389a5b5957dd5d (diff)
downloadports-cff87df13351e5b3c77e7b583cfd595baa2ee43e.tar.gz
ports-cff87df13351e5b3c77e7b583cfd595baa2ee43e.zip
Support stage
Use @sample
Notes
Notes: svn path=/head/; revision=360914
Diffstat (limited to 'emulators/vboxtool')
-rw-r--r--emulators/vboxtool/Makefile23
-rw-r--r--emulators/vboxtool/pkg-plist7
2 files changed, 9 insertions, 21 deletions
diff --git a/emulators/vboxtool/Makefile b/emulators/vboxtool/Makefile
index 5ce973957d32..926f629d5120 100644
--- a/emulators/vboxtool/Makefile
+++ b/emulators/vboxtool/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vboxtool
PORTVERSION= 0.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= SF
@@ -24,7 +24,6 @@ GROUPS= vboxusers
SAMPLESDIR= ${PREFIX}/share/${PORTNAME}
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|!/bin/bash|!/usr/bin/env bash|' \
-e 's|/etc/|${PREFIX}&|g' \
@@ -32,18 +31,10 @@ post-patch:
${WRKSRC}/script/vboxtoolinit
do-install:
- @if [ ! -f ${PREFIX}/etc/${PORTNAME} ]; then \
- ${MKDIR} ${PREFIX}/etc/${PORTNAME};\
- fi
- ${MKDIR} ${EXAMPLESDIR}
- @if [ ! -f ${PREFIX}/etc/${PORTNAME}/vboxtool.conf ]; then \
- ${INSTALL_DATA} ${FILESDIR}/vboxtool.conf ${PREFIX}/etc/${PORTNAME}/vboxtool.conf;\
- fi
- @if [ ! -f ${PREFIX}/etc/${PORTNAME}/machines.conf ]; then \
- ${INSTALL_DATA} ${FILESDIR}/machines.conf ${PREFIX}/etc/${PORTNAME}/machines.conf;\
- fi
- ${INSTALL_SCRIPT} -m 0750 ${WRKSRC}/script/vboxtool ${PREFIX}/bin/vboxtool
- ${INSTALL_SCRIPT} -m 0750 ${WRKSRC}/script/vboxtoolinit ${PREFIX}/etc/rc.d/vboxtoolinit
- ${INSTALL_DATA} ${FILESDIR}/machines.conf ${EXAMPLESDIR}/machines.conf
- ${INSTALL_DATA} ${FILESDIR}/vboxtool.conf ${EXAMPLESDIR}/vboxtool.conf
+ @${MKDIR} ${STAGEDIR}${ETCDIR}
+ ${INSTALL_DATA} ${FILESDIR}/vboxtool.conf ${STAGEDIR}${ETCDIR}/vboxtool.conf.sample
+ ${INSTALL_DATA} ${FILESDIR}/machines.conf ${STAGEDIR}${ETCDIR}/machines.conf.sample
+ ${INSTALL_SCRIPT} -m 0750 ${WRKSRC}/script/vboxtool ${STAGEDIR}${PREFIX}/bin/vboxtool
+ ${INSTALL_SCRIPT} -m 0750 ${WRKSRC}/script/vboxtoolinit ${STAGEDIR}${PREFIX}/etc/rc.d/vboxtoolinit
+
.include <bsd.port.mk>
diff --git a/emulators/vboxtool/pkg-plist b/emulators/vboxtool/pkg-plist
index ad055a17a139..055fbd706b2f 100644
--- a/emulators/vboxtool/pkg-plist
+++ b/emulators/vboxtool/pkg-plist
@@ -1,8 +1,5 @@
-@unexec if cmp -s %%PREFIX%%/%%EXAMPLESDIR%%/machines.conf %D/etc/vboxtool/machines.conf; then rm -f %D/etc/vboxtool/machines.conf; fi
-@unexec if cmp -s %%PREFIX%%/%%EXAMPLESDIR%%/vboxtool.conf %D/etc/vboxtool/vboxtool.conf; then rm -f %D/etc/vboxtool/vboxtool.conf; fi
bin/vboxtool
etc/rc.d/vboxtoolinit
-%%EXAMPLESDIR%%/machines.conf
-%%EXAMPLESDIR%%/vboxtool.conf
+@sample etc/vboxtool/machines.conf.sample
+@sample etc/vboxtool/vboxtool.conf.sample
@dirrmtry etc/vboxtool
-@dirrmtry %%EXAMPLESDIR%%