aboutsummaryrefslogtreecommitdiff
path: root/emulators/vice/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-23 17:41:54 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-11-23 17:41:54 +0000
commite42ec06795b960bd478c101a71303beff8a60048 (patch)
tree6e78052d4e1bf42a99d6a6df1d13f33bf8ac1031 /emulators/vice/Makefile
parent274b4872abe0d76351efdb5070a54ab45319fa1c (diff)
downloadports-e42ec06795b960bd478c101a71303beff8a60048.tar.gz
ports-e42ec06795b960bd478c101a71303beff8a60048.zip
Notes
Diffstat (limited to 'emulators/vice/Makefile')
-rw-r--r--emulators/vice/Makefile27
1 files changed, 21 insertions, 6 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index 0da5821d1ee5..f8f47345d781 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -5,21 +5,20 @@
# $FreeBSD$
PORTNAME= vice
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= emulators
MASTER_SITES= ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
-USE_XLIB= yes
RESTRICTED= ROMs are copyrighted by Commodore Business Machines
NO_CDROM= ${RESTRICTED}
NO_PACKAGE= ${RESTRICTED}
+USE_XPM= yes
+WANT_GNOME= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-xaw3d
MAN1= vice.1 c1541.1 petcat.1
MLINKS= vice.1 x64.1 \
@@ -28,7 +27,23 @@ MLINKS= vice.1 x64.1 \
vice.1 xpet.1 \
vice.1 xcbm2.1
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS= --enable-gnomeui
+.else
+LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
+CONFIGURE_ARGS= --with-xaw3d
+.endif
+
+post-extract:
+ @${RM} -f ${WRKSRC}/doc/vice.info*
+
+post-patch:
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/man/vice.1
+
post-install:
- @${LN} -sf vice_toc.html ${PREFIX}/share/doc/vice/index.html
+ @${LN} -sf vice_toc.html ${DOCSDIR}/index.html
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>