aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose-legacy
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2014-01-16 16:45:29 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2014-01-16 16:45:29 +0000
commit4e32fe4224e2e28b31f2360f2f09e40c7dd5b97a (patch)
treefda7181f711da5e947d419bffa3a55c0cc9fc44c /emulators/virtualbox-ose-legacy
parent3fa03dfd6eed93c65ad0eaa70296742fa0b279bd (diff)
downloadports-4e32fe4224e2e28b31f2360f2f09e40c7dd5b97a.tar.gz
ports-4e32fe4224e2e28b31f2360f2f09e40c7dd5b97a.zip
- Update to 4.2.22
- Convert USE_PYDISTUTILS=easy_install to USE_PYDISTUTILS=yes - Add patch to fix building with new gsoap [1] - Add direct dependency on qt4-opengl [2] PR: ports/185579 [2] Security: CVE-2013-5892 Submitted by: Jung-uk Kim <jkim@FreeBSD.org> [1] Jimmy Olgeni <olgeni@FreeBSD.org> [2]
Notes
Notes: svn path=/head/; revision=339932
Diffstat (limited to 'emulators/virtualbox-ose-legacy')
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile7
-rw-r--r--emulators/virtualbox-ose-legacy/distinfo8
-rw-r--r--emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-webservice-Makefile.kmk42
3 files changed, 49 insertions, 8 deletions
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index b78dbbc2b690..5af302e16842 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= virtualbox-ose
-DISTVERSION= 4.2.20
-PORTREVISION= 1
+DISTVERSION= 4.2.22
CATEGORIES= emulators
MASTER_SITES= http://download.virtualbox.org/virtualbox/${DISTVERSION}/ \
http://tmp.chruetertee.ch/ \
@@ -39,7 +38,7 @@ USE_GCC= any
USE_GNOME= libidl
USE_BZIP2= yes
USE_PYTHON= 2
-USE_PYDISTUTILS= easy_install
+USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= vboxapi
PYDISTUTILS_PKGVERSION= 1.0
PYDISTUTILS_NOEGGINFO= yes
@@ -125,7 +124,7 @@ CONFIGURE_ARGS+=--build-headless
.if ${PORT_OPTIONS:MQT4}
QT_NONSTANDARD= yes
-USE_QT4= gui network moc_build uic_build rcc_build linguist
+USE_QT4= gui network moc_build opengl uic_build rcc_build linguist
INSTALLS_ICONS= yes
VBOX_FRONTENDS+=VirtualBox VBoxTestOGL
.else
diff --git a/emulators/virtualbox-ose-legacy/distinfo b/emulators/virtualbox-ose-legacy/distinfo
index 28aa1dc9d1d9..c1afb8b75a1e 100644
--- a/emulators/virtualbox-ose-legacy/distinfo
+++ b/emulators/virtualbox-ose-legacy/distinfo
@@ -1,4 +1,4 @@
-SHA256 (VirtualBox-4.2.20.tar.bz2) = 193aa3ce7c0e700fe6a12b64bf462ce633a856f1e831ee4a337cc3439b21df61
-SIZE (VirtualBox-4.2.20.tar.bz2) = 77050211
-SHA256 (VBoxGuestAdditions_4.2.20.iso) = 2fb3aa0f370d503b0e77725dbec76b989a251f613abee378f53c1fed9d6edf01
-SIZE (VBoxGuestAdditions_4.2.20.iso) = 59664384
+SHA256 (VirtualBox-4.2.22.tar.bz2) = 4a017ec5fa0e0cfa830ae6c2b9d680c9b108e5fb96348e1397a7d0ea051f8bc1
+SIZE (VirtualBox-4.2.22.tar.bz2) = 77039185
+SHA256 (VBoxGuestAdditions_4.2.22.iso) = 222e003d038b757cd761361bb5da33123e0f9574af246fb95eb558593c8c7c76
+SIZE (VBoxGuestAdditions_4.2.22.iso) = 59686912
diff --git a/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-webservice-Makefile.kmk b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-webservice-Makefile.kmk
new file mode 100644
index 000000000000..0f80ecabe040
--- /dev/null
+++ b/emulators/virtualbox-ose-legacy/files/patch-src-VBox-Main-webservice-Makefile.kmk
@@ -0,0 +1,42 @@
+Ticket #11803: Fails to build with gSOAP 2.8.13
+https://www.virtualbox.org/ticket/11803
+
+--- src/VBox/Main/webservice/Makefile.kmk.orig 2013-12-18 11:10:26.000000000 -0500
++++ src/VBox/Main/webservice/Makefile.kmk 2014-01-09 15:56:26.000000000 -0500
+@@ -159,7 +159,6 @@
+ RECOMPILE_ON_MAKEFILE_CURRENT := $(MAKEFILE_CURRENT)
+
+ PATH_TARGET_SOAPDEMOXML := $(VBOXWEB_OUT_DIR)/demo_soapxml
+-PATH_TARGET_SOAPDEMOHEADERS := $(VBOXWEB_OUT_DIR)/demo_headers
+ PATH_TARGET_SOAPDEMONSMAPS := $(VBOXWEB_OUT_DIR)/demo_namespacemaps
+ PATH_TARGET_WEBTEST := $(VBOXWEB_OUT_DIR)/webtest
+
+@@ -512,8 +511,6 @@
+ $(VBOXWEB_OUT_DIR)/gsoap_copy_all_ts \
+ $(wildcard $(PATH_TARGET_SOAPDEMOXML)/*) \
+ $(PATH_TARGET_SOAPDEMOXML)/dummy_file \
+- $(wildcard $(PATH_TARGET_SOAPDEMOHEADERS)/*) \
+- $(PATH_TARGET_SOAPDEMOHEADERS)/dummy_file \
+ $(wildcard $(PATH_TARGET_SOAPDEMONSMAPS)/*) \
+ $(PATH_TARGET_SOAPDEMONSMAPS)/dummy_file
+
+@@ -690,17 +687,14 @@
+ # want to use wildcard (all commands are expaned when the rule is evaluated).
+ $(VBOXWEB_OUT_DIR)/gsoap_copy_all_ts: $(VBOXWEB_OUT_DIR)/gsoap_generate_all_ts | $$(dir $$@)
+ $(RM) -f $@
+- $(MKDIR) -p $(PATH_TARGET_SOAPDEMOXML) $(PATH_TARGET_SOAPDEMOHEADERS) $(PATH_TARGET_SOAPDEMONSMAPS)
++ $(MKDIR) -p $(PATH_TARGET_SOAPDEMOXML) $(PATH_TARGET_SOAPDEMONSMAPS)
+ ifdef VBOX_GSOAP_VERBOSE
+ $(MV) -f $(wildcard $(VBOXWEB_OUT_DIR)/*.req.xml $(VBOXWEB_OUT_DIR)/*.res.xml) $(PATH_TARGET_SOAPDEMOXML)
+ endif
+- $(MV) -f $(wildcard $(VBOXWEB_OUT_DIR)/soapvbox*.h) $(PATH_TARGET_SOAPDEMOHEADERS)
+ $(MV) -f $(VBOXWEB_OUT_DIR)/vboxBinding.nsmap $(PATH_TARGET_SOAPDEMONSMAPS)
+ $(APPEND) $@ done
+
+-$(PATH_TARGET_SOAPDEMONSMAPS) \
+-$(PATH_TARGET_SOAPDEMOHEADERS)/soapvboxBindingProxy.h \
+-$(PATH_TARGET_SOAPDEMOHEADERS)/soapvboxBindingObject.h: $(VBOXWEB_OUT_DIR)/gsoap_copy_all_ts
++$(PATH_TARGET_SOAPDEMONSMAPS): $(VBOXWEB_OUT_DIR)/gsoap_copy_all_ts
+
+ # soapcpp2 -2: generate SOAP 1.2 calls
+ # soapcpp2 -S: server-side code only