aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose/Makefile
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2020-03-31 17:46:10 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2020-03-31 17:46:10 +0000
commit28b4da349ddcc9e8493e8c3d013eb2fc4107098a (patch)
tree40e9eb579a79a75bd17e32d2d6b1588dec7e57b3 /emulators/virtualbox-ose/Makefile
parent858f9adf3a30bc88969035f8aead590ddb346dde (diff)
downloadports-2020Q1.tar.gz
ports-2020Q1.zip
MFH: r5299932020Q1
- Fix runtime for gcc rpath. [1] This is a regression of something that was working in the past. Please keep the _GCC_RUNTIME handling even if removing USE_GCC as it may come back again in the future and be forgotten. - Fix build on 11.3 with ports ssl. [2] PR: 245048 [1] PR: 243315 [2] Submitted by: John Hein <jcfyecrayz at liamekaens.com> [2] Approved by: portmgr (implicit)
Notes
Notes: svn path=/branches/2020Q1/; revision=529997
Diffstat (limited to 'emulators/virtualbox-ose/Makefile')
-rw-r--r--emulators/virtualbox-ose/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 8ddf0f9abdbb..263e807bad26 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -3,6 +3,7 @@
PORTNAME= virtualbox-ose
PORTVERSION= 5.2.34
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= https://download.oracle.com/virtualbox/${PORTVERSION}/
DISTFILES= VirtualBox-${PORTVERSION}${EXTRACT_SUFX} ${GUESTADDITIONS}
@@ -240,7 +241,9 @@ post-patch:
${WRKSRC}/LocalConfig.kmk
@${ECHO_CMD} 'VBOX_PATH_SHARED_LIBS = ${VBOX_DIR}' >> \
${WRKSRC}/LocalConfig.kmk
- @${ECHO_CMD} 'VBOX_WITH_RUNPATH = ${VBOX_DIR}' >> \
+ # Please keep this even if using Clang to avoid repeated regressions.
+ # PR 245048
+ @${ECHO_CMD} "VBOX_WITH_RUNPATH = ${_GCC_RUNTIME:D${_GCC_RUNTIME}\:}${VBOX_DIR}" >> \
${WRKSRC}/LocalConfig.kmk
@${ECHO_CMD} 'VBOX_PATH_APP_PRIVATE = ${DATADIR}' >> \
${WRKSRC}/LocalConfig.kmk