aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-07-01 23:41:31 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-07-01 23:41:31 +0000
commitf7c6b7b0f8f32bd21279460c52990b538ce763e6 (patch)
treee7070e98153d3f92d103e472e5b979ec595357f5 /emulators/virtualbox-ose/Makefile
parent8780449a669c0970cadfe8fe7da525e3b2a14f2f (diff)
downloadports-f7c6b7b0f8f32bd21279460c52990b538ce763e6.tar.gz
ports-f7c6b7b0f8f32bd21279460c52990b538ce763e6.zip
Notes
Diffstat (limited to 'emulators/virtualbox-ose/Makefile')
-rw-r--r--emulators/virtualbox-ose/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index fef83f70f8de..3389c75d7687 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -19,9 +19,6 @@ EXTRACT_ONLY= VirtualBox-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= vbox@FreeBSD.org
COMMENT= A general-purpose full virtualizer for x86 hardware
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
-
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
as86:${PORTSDIR}/devel/dev86 \
xsltproc:${PORTSDIR}/textproc/libxslt \
@@ -32,6 +29,9 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
curl.6:${PORTSDIR}/ftp/curl
RUN_DEPENDS= /boot/modules/vboxdrv.ko:${PORTSDIR}/emulators/virtualbox-ose-kmod
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}
ONLY_FOR_ARCHS= i386 amd64
USE_CDRTOOLS= yes
@@ -77,8 +77,6 @@ PLIST_SUB+= PYTHON_VER=${PYTHON_VER} \
SUB_LIST+= VBOXUSER=${VBOXUSER}
USE_RC_SUBR+= vboxheadless
-.include <bsd.port.pre.mk>
-
KMK_BUILDTYPE= release
KMK_CONFIG= VBOX_LIBPATH_X11=${LOCALBASE} VBOX_FREEBSD_SRC=${SRC_BASE}/sys
KMK_FLAGS=
@@ -173,6 +171,8 @@ KMK_ARCH= freebsd.${ARCH}
PLIST_SUB+= I386="@comment "
.endif
+.include <bsd.port.pre.mk>
+
.if ${OSVERSION} < 802000
BROKEN= Does not compile on FreeBSD < 8.2
.endif